1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DIS Showing Door Open But Its Not

Discussion in 'A3/S3 Forum (8L Chassis)' started by s3bow, May 21, 2006.

  1. s3bow
    Offline

    s3bow Member

    Joined:
    Apr 2, 2003
    Messages:
    377
    Likes Received:
    1
    [May 21, 2006]
    I've had this intermittently for a while now. The DIS is showing the door as being open when it is closed. This then won't switch the interior light off and when stopped, won't allow you to set the alarm with the fob.
    My brother (Audi Tech) says its a faulty micro switch on the door catch.

    Anyone else had this ?

    Chris.
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. imported_Stewart
    Online

    imported_Stewart Guest

    [May 21, 2006]
    It is a faulty microswitch, mine does it on hot days..
    #2
  4. s3bow
    Offline

    s3bow Member

    Joined:
    Apr 2, 2003
    Messages:
    377
    Likes Received:
    1
    [May 21, 2006]
    It seems to be worse on hot days too.
    Did you change yours ?

    Chris.
    #3
  5. imported_Stewart
    Online

    imported_Stewart Guest

    [May 21, 2006]
    Not yet, i got a refurbished one off ebay, its not annoying me enough yet to spend half a day stripping the door down...
    #4
  6. god_thats_quick
    Offline

    god_thats_quick Numptie of the highest order

    Joined:
    Jun 1, 2004
    Messages:
    2,507
    Likes Received:
    1
    [May 21, 2006]
    It's pretty common, can do wierd things... my interior lights would pulse and the car would lock but it would go off a few mins later.

    It's not that hard to do and only takes max 2 hours if your careful - you don't need to seperate the door from the car just the inner frame from the skin there a thread or ten on here with what you need to do too.
    #5
  7. [May 21, 2006]
    [ QUOTE ]
    Anyone else had this ?

    Chris.

    [/ QUOTE ]

    You bet - a very common fault. I got mine replaced under warranty.

    Not only was it irritating, my concern was that the car wasn't properly alarmed, not sure if that was the case though.
    #6
  8. hamski
    Offline

    hamski Member

    Joined:
    Sep 16, 2005
    Messages:
    121
    Likes Received:
    0
    [May 21, 2006]
    I've got the same with mine. DIS shows door open and interior lights come on over bumps and round corners.
    #7
  9. C_Audiboy
    Offline

    C_Audiboy Vroom Vroom

    Joined:
    Nov 29, 2004
    Messages:
    822
    Likes Received:
    0
    [May 21, 2006]
    [ QUOTE ]
    [ QUOTE ]
    Anyone else had this ?

    Chris.

    [/ QUOTE ]

    You bet - a very common fault. I got mine replaced under warranty.

    Not only was it irritating, my concern was that the car wasn't properly alarmed, not sure if that was the case though.

    [/ QUOTE ]

    I don't think the car will be alarmed properly as it thinks the door is ajar. When the same problem happened with mine the red LED on the door would not light, but the remote would still lock the doors. All the more reason to get it fixed.

    Mine was replaced under warranty too /ubbthreads/images/graemlins/tongue.gif
    #8
  10. s3bow
    Offline

    s3bow Member

    Joined:
    Apr 2, 2003
    Messages:
    377
    Likes Received:
    1
    [May 21, 2006]
    Mine's out of warranty. Stewart, how much did it cost you ?

    Chris.
    #9
  11. Defratos
    Offline

    Defratos YouÂ’re Dethpicable!!

    Joined:
    May 26, 2004
    Messages:
    2,232
    Likes Received:
    0
    [May 22, 2006]
    anyone know any old threads where this problem can be fixed?
    #10
  12. imported_Stewart
    Online

    imported_Stewart Guest

    [May 22, 2006]
    It only cost me a fiver off fleabay, the guy had bought a brand new one then fixed his old one...

    Sorry I havent looked too closely at it but its something to do with the microswitch itself...

    I got the whole lock mechanism with the switch built into it...

    Maybe he stripped the switch down and repaired it, i dont know, sorry.
    #11
  13. god_thats_quick
    Offline

    god_thats_quick Numptie of the highest order

    Joined:
    Jun 1, 2004
    Messages:
    2,507
    Likes Received:
    1
    [May 22, 2006]
    A quote from me in another thread...

    [ QUOTE ]
    these two posts cover pretty much everything, I was going to do a better write up, but my camera was being a pain on the day that I actually fixed it.

    http://www.audi-sport.net/ubbthreads/sho...true#Post340661

    http://www.audi-sport.net/ubbthreads/sho...true#Post337282

    the other problem is there is no real point in listing the part numbers because it'll be different for each side and could be different for different cars, however Audi seem happy to help and gave me the right part.

    [/ QUOTE ]

    And if they don't clear things up a quick look on the below might answer any other questions but if not just ask.

    http://www.audi-sport.net/ubbthreads/sho...true#Post338516

    http://www.audi-sport.net/ubbthreads/sho...true#Post345088
    #12
  14. hamski
    Offline

    hamski Member

    Joined:
    Sep 16, 2005
    Messages:
    121
    Likes Received:
    0
    [Jul 1, 2006]
    I finally had the driver's door sensor replaced. But the DIS still does the same!! anyone got any ideas??
    #13
  15. DPM
    Offline

    DPM Site Sponsor Site Sponsor

    Joined:
    Jun 10, 2006
    Messages:
    4,339
    Likes Received:
    57
    [May 20, 2007]
    Mines also doing this now, so annoying!
    #14
  16. JustSports
    Offline

    JustSports Member

    Joined:
    Jan 22, 2007
    Messages:
    88
    Likes Received:
    0
    [May 20, 2007]
    I had this when i first bought my car, this is going to sound stupid, but i closed the lock with my finger with the door open, then reopened the lock and then shut the door ! its been fine since !

    I think the lock just gets stuck, especially on hot days, perhaps just needs some grease / wd40 ??
    #15
  17. QUATTRO_REP
    Offline

    QUATTRO_REP Diesel Power!

    Joined:
    Oct 31, 2006
    Messages:
    229
    Likes Received:
    0
    [May 21, 2007]
    i had this last year, and yes it pissed me off a great deal with the interor lights being on after the car was locked and no alarm being on. i just hammered the door lock mech with WD40 and i havent had any trouble since. the hotter days really did make it worse tho.
    #16
  18. rickparmar
    Offline

    rickparmar va va voom

    Joined:
    May 18, 2004
    Messages:
    2,268
    Likes Received:
    0
    [Jun 2, 2007]
    This is now happening to me :(
    #17
  19. voorhees
    Offline

    voorhees Moderator Staff Member Moderator

    Joined:
    Dec 18, 2005
    Messages:
    15,103
    Likes Received:
    1,180
  20. Smoke Breather
    Offline

    Smoke Breather Member

    Joined:
    Apr 30, 2007
    Messages:
    94
    Likes Received:
    0
    [Jun 2, 2007]
    And me, bloody hot weather! nothing a bit of a slam didn't sort out though.
    #19
  21. voorhees
    Offline

    voorhees Moderator Staff Member Moderator

    Joined:
    Dec 18, 2005
    Messages:
    15,103
    Likes Received:
    1,180
    [Jun 2, 2007]
    Something else to blame on global warming
    #20

Share This Page