1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dash Warning Light on - with ignition off.

Discussion in 'A3/S3/Sportback (8P Chassis)' started by garethrees, Jan 5, 2013.

  1. garethrees
    Offline

    garethrees Member

    Joined:
    Jan 5, 2013
    Messages:
    30
    Likes Received:
    1
    [Jan 5, 2013]
    Hi - I have a strange problem which I think is an electrical fault, did a search but cannot see anything like this on the forum.

    Basically the little Wheel warning light is permanently on (a little yellow ish) even when the ignition if off. It's like there is an earth problem on the light.

    Here is a pic with the ignition on: [​IMG]

    And off with the key out: [​IMG]

    I'm check for Engine Codes there are none.

    Any help, pointers appreciated before I pop over to Audi.

    Regards Gareth
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Jan 5, 2013]
    If its under warranty, then dont bother with pointers, just goto them, but looks like either the led is getting some load even when not required, therefore faulty cluster or thats getting residual light in that area, you could remove cluster fascia, turn on so you can see the pcb/led direct to see what it is doing with nothing covering that area.
    #2
  4. garethrees
    Offline

    garethrees Member

    Joined:
    Jan 5, 2013
    Messages:
    30
    Likes Received:
    1
    [Jan 5, 2013]
    Thanks for the prompt reply, yes its under warranty, I was just interested if this was a common fault or just me ;) I'll pop into Audi next week and post an update.
    #3
  5. garethrees
    Offline

    garethrees Member

    Joined:
    Jan 5, 2013
    Messages:
    30
    Likes Received:
    1
    [Jan 11, 2013]
    So just to close this off, took the car into Audi to investigate:-

    • They check for any engine codes there were none.
    • I was notified that dash LEDs have some residual light which can sometimes show faintly. (like mine)
    • They compared my dash with other similar models of the same age RS3, S3 etc they are the same - so classed as "no fault found".
    Given that the faint light is very different from the Yellow Warning light which is obvious when it's on, I had no problem with the explanation. However I was a little worried that it might be a common fault or a undocumented feature of the dash lights. Either way I've reported the problem within warranty so they have a formal record of it going forward.

    That being said, I think they must have tweaked something because when I got back in the car the problem was solved. So maybe they turned down the light just enough not to show anymore???

    Anyone else have this issue please post and image I would be curious to see how common it really is.
    #4
  6. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Jan 11, 2013]
    Check the interior light dial setting on the headlight switch, probably wont do squat, but you never know as I always try to think of anything/everything that may affect a given issue.
    #5
  7. garethrees
    Offline

    garethrees Member

    Joined:
    Jan 5, 2013
    Messages:
    30
    Likes Received:
    1
    [Jan 19, 2013]
    Yep wiggled that both ways no effect.

    Update: one week later this glow comes and goes.. not bothered as it's not that obvious you have to really look for it. Would still be interested to see some pics of others if they have the same issue or not. Thank again for the help.
    #6
  8. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Jan 25, 2013]
    Ok found another person with same issue I directly had access to & it seems in part to be related to the light sensor thats on the speedo cluster area, below the fastest speed marker, as when I shone a light on this at various times, it affected the brightness of this icon, for me its a pcb fault, needs researching further as I advised this guy.
    #7
  9. garethrees
    Offline

    garethrees Member

    Joined:
    Jan 5, 2013
    Messages:
    30
    Likes Received:
    1
    [Jan 25, 2013]
    Thanks very much, mine does flicker a little depending on the light so your diagnosis does sound spot on. I too believe it's a fault not an "undocumented feature" as Audi have stated. I'm sure at some point it will fail and then I'll have a chat with Audi again.
    #8
  10. Alk
    Offline

    Alk New Member

    Joined:
    Oct 30, 2013
    Messages:
    6
    Likes Received:
    0
    [Oct 30, 2013]
    Apologies for digging up an old thread, but I've just noticed the same problem on my 09 A3. Did yours ever fail in the end?

    I've found another forum thread with someone else that has an 09 and the same issue: http://www.audi-sport.net/vb/a3-s3-...g-light-dashbord-a3-tdi-170-ignition-off.html so I start to wonder if it is a common fault on 09 models as you stated that Audi also checked against models of the same age.
    #9
  11. garethrees
    Offline

    garethrees Member

    Joined:
    Jan 5, 2013
    Messages:
    30
    Likes Received:
    1
    [Oct 31, 2013]
    Hello Alk, I think it's a common fault with the 09 model, mine is the same as it has always been, Audi refused to accept it was a fault stating that it's a feature of the car. However it's now 1yr on and not failed if that helps.
    #10
  12. Alk
    Offline

    Alk New Member

    Joined:
    Oct 30, 2013
    Messages:
    6
    Likes Received:
    0
    [Oct 31, 2013]
    That is good to know - thank you. It hasn't caused issues with draining the battery has it?
    #11
  13. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Oct 31, 2013]
    Not a chance with such a low draw from the minor led pulse its putting out.
    #12
  14. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Oct 31, 2013]
    Welcome to the site Alk, yeap its not going to cause an issue, although we've changed a few out for members because warranty paid for the job & was fine with replacement.

    I think its batch of dodgy clusters tbh & the fact they QC'd the cars with that issue does beg the question.
    #13
  15. Alk
    Offline

    Alk New Member

    Joined:
    Oct 30, 2013
    Messages:
    6
    Likes Received:
    0
    [Oct 31, 2013]
    I understand - thanks Nigel you've been very helpful. I may well make enquiries to see if I can also get it repaired under warranty.
    #14
  16. garethrees
    Offline

    garethrees Member

    Joined:
    Jan 5, 2013
    Messages:
    30
    Likes Received:
    1
    [Oct 31, 2013]
    I asked Audi Reading to replace under warranty, they refused stating it was normal! Needless to say I did not renew the warranty with Audi. This is clearly a fault.

    Does it effect the battery nope, not that I have found.
    #15
  17. Alk
    Offline

    Alk New Member

    Joined:
    Oct 30, 2013
    Messages:
    6
    Likes Received:
    0
    [Oct 31, 2013]
    Thanks garethrees - Mine is not with Audi, but where I bought the car. Very much appreciate everyone's help!
    #16
  18. akis
    Offline

    akis New Member

    Joined:
    Sep 18, 2013
    Messages:
    5
    Likes Received:
    0
    [Sep 21, 2014 at 3:14 PM]
    Any update for this fault?I have the same problem on a 2009 S3.
    #17
  19. garethrees
    Offline

    garethrees Member

    Joined:
    Jan 5, 2013
    Messages:
    30
    Likes Received:
    1
    [Sep 21, 2014 at 3:20 PM]
    akis, nothing from Audi, I have no other issues with mine, just living with it... however I might be a Volvo next time my wife's C30 T5 (same age) is faultless I have to say.
    #18
  20. akis
    Offline

    akis New Member

    Joined:
    Sep 18, 2013
    Messages:
    5
    Likes Received:
    0
    [Sep 21, 2014 at 4:15 PM]
    In my case it stated after cleaning with distilled water and all purpose cleaner around the earth cables,it was some oil from itg cai.After applying contact cleaner and letting it without out battery for two days the light went away.Now a month after this it showed up again without obvious reason.Very annoying "feature" I would say.
    #19
  21. Alk
    Offline

    Alk New Member

    Joined:
    Oct 30, 2013
    Messages:
    6
    Likes Received:
    0
    [Sep 22, 2014 at 8:37 PM]
    I nearly went for a c30 before my first A3, but I kept getting my clutch foot caught on the surround due to how the steering column is positioned. It is a problem that I experienced even in my old volvo 440 as well! I went for the A3 because I knew that I could get it serviced easily and there is plenty of room in the footwell (the steering column is in a different position).
    I digress... :)

    Akis; in my case I made a petition for repair to the used car dealer that I purchased my A3 from. I explained that it was an MOT failure and provided various evidence to this effect. I was quoted (over the phone) ~£750 for a new dash from Audi, but the used car dealer didn't want to pay this. So I took a week off work, removed my dash and sent it to Cluster Repairs UK. They were able to recreate the issue in their workshop and found some corrosion, due to condensation, in the area around the LED. They cleaned it up and tested it again and the problem seemed to have gone so they sent it back to me. I sent if off on the Monday and I got it back on the Saturday (paid extra delivery) and it cost ~£76. This was in February. It is a lot better now than it was; it no longer glows with varying intensity with the ignition off and it is only just noticeable sometimes at night....but you really have to look to notice it (previously it was even visible in low light eg. dawn). The used car dealer covered the cost of this repair and it seems to be holding up so I'm happy with it now (it passed the MOT).
    #20
  22. akis
    Offline

    akis New Member

    Joined:
    Sep 18, 2013
    Messages:
    5
    Likes Received:
    0
    [Sep 22, 2014 at 9:18 PM]
    Alk,thanks for your reply the instrument cluster was the last thing to look for as it's very expensive to replace and I don't want to spend more money on the car as a had already have a haldex failure not covered from the dealer.Is your car having also the hazard switch issue,if yes it got any better after the cluster fix?
    #21
  23. Alk
    Offline

    Alk New Member

    Joined:
    Oct 30, 2013
    Messages:
    6
    Likes Received:
    0
    [Sep 22, 2014 at 9:36 PM]
    Sorry to hear that. No, I am unaware of any issue with the hazard switch and I think that I would have noticed it from what you have described in your other posts.
    Incidentally, I also had an auto-electrician look at the car concerning the steering warning light issue. They did a VCDS scan etc. and concluded that the LED was the issue and therefore that the instrument cluster was faulty and required repair/replacement.

    NHN is very experienced in these cars, and like he says:
    NHN has replaced a few instrument clusters for customers with refurbished units (he has the necessary equipment to recode the immobiliser) as it is obviously cheaper than a new cluster.

    I don't think that you will find it to be a problem, as long it is not so bad that an MOT tester will think that it is actually illuminated. However, if it is very dull then I suspect that it wouldn't be noticed. If you can afford it and you can be without the car for a week and a bit, I would suggest sending the cluster for repair in the first instance as they can conduct some testing on it which would then be independent of the environment of your car.
    #22

Share This Page