1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dash clock removal

Jay85 Mar 24, 2012

  1. Jay85

    Jay85 New Member

    27
    0
    1
    I have an 97 A4 and some of the dials aren't illuminating, including the speedo needle. How do I go about removing the clocks so I can replace the bulbs.
    Also should there be a light on the dash for when you have headlights on? That isn't illuminating neither.
    Many thanks.
     
  2. ScottD3

    ScottD3 I want your faulty electronics Supporter Team V6 quattro Audi A8 Team Akoya saloon TDi Audi S8

    15,160
    1,121
    113
    I think they are LED and not bulbs.

    To take the clocks you, you move the steeling wheel down and towards you as far as possible.
    remove the top section of the trim, if you look at the bottom of the clocks, you can see a little bit of trim. that unclips towards you and exposes 2 torx screws.
    Remove theses and the clocks will come out towards you a couple of inches before the plugs get tight.
    reach round the back and unclip cables and its free. :)
     
  3. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    17,775
    674
    113
    older cars have bulbs. They changed over around 97-98.

    Never seen a blown LED yet though, so its almost certainly and earlier car!
     
  4. sssstew80

    sssstew80 New Member

    21
    0
    1
    They are bulbs on the older models like mentioned. Ive just replaced exactly the same ones as Jay mentions as my clock and rev needle were not lit. Scotts instructions are right above, there are three plugs into the back of the unit, two on the left and one tight one on the right, do the left ones first.

    Some of the bulbs are a pain in the ass to get in and out, use a socket is recommended a screw driver can chew the plastic heads. Orangle bulbs are 1.1w and black are 1.2.

    Oh and watch the top of your steering wheel trip when putting the dash in and out as i scratched mine up! grrr

    As for a light for when the headlights are on.... you should have a light for side lights on and main beam on. probably just bulbs gone like you say, i had 3 gone on mine, note they looked ok when pulled out, the filament was there but when putting voltage through with a battery they didnt light, so make sure you check yours.
     
  5. Mike-S

    Mike-S New Member

    21
    0
    1
    Just taken mine out tonight to replace some bulbs, what a pain it was to unclip the wiring!

    Some of the bulbs appear to have been replaced with blanks?! Anyone know why? That'll explain why part of my speedo isn't lit up!
     

Share This Page