1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cruise Control Retrofit Guide

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Avus Sportback, Jan 23, 2011.

  1. ron burgandy

    ron burgandy Member

    Joined:
    Jan 7, 2011
    Messages:
    165
    Likes Received:
    19
    I have a 2010 s3 sports back I have bought the cowling and stalk if anyone can fit it for me and code it ideally tomorrow, that would be great I live in Blackpool so if there's anyone close and free then please give me pm. Thanks
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. Lee540

    Lee540 Member

    Joined:
    Aug 5, 2012
    Messages:
    123
    Likes Received:
    10
    I have MY2009 A3 (8P3), I want to do this retro fit myself.. does anyone have part numbers? I will buy the stalk and upper and lower steering column cowling I guess. I'd like new probably, my interior is in top condition, wouldn't want inferior parts to let it down.

    Cheers

    Lee
     
  4. Lee540

    Lee540 Member

    Joined:
    Aug 5, 2012
    Messages:
    123
    Likes Received:
    10
    Figured it out now.. should have looked properly before posting.. :)
     
  5. Lee540

    Lee540 Member

    Joined:
    Aug 5, 2012
    Messages:
    123
    Likes Received:
    10
    Will I loose my stereo coding if disconnect the battery? I dont have security card. MY2009 8P3 Symphony 2
     
  6. jb0o

    jb0o North East Forum Moderator
    Site Sponsor Regional Rep VCDS Map User

    Joined:
    Feb 2, 2009
    Messages:
    2,648
    Likes Received:
    110
    Nope, radio info gets stored in the car's memory.
     
  7. Zak0123

    Zak0123 Active Member

    Joined:
    Apr 8, 2012
    Messages:
    469
    Likes Received:
    31
    Great guide! Looking at doing this myself on my 2011 3dr, does anyone know where I can get the bottom cowling (hopefully not from audi)? Am I right in thinking that the cowling and the stalk are all I need?
     
  8. Lee540

    Lee540 Member

    Joined:
    Aug 5, 2012
    Messages:
    123
    Likes Received:
    10
    I am buying this.. its the same for your car also.

    Audi A3 (8P) TT (8J) 2009 onwards Cruise Control & Trim | eBay
     
  9. Zak0123

    Zak0123 Active Member

    Joined:
    Apr 8, 2012
    Messages:
    469
    Likes Received:
    31
  10. bennymac

    bennymac New Member

    Joined:
    Jul 14, 2013
    Messages:
    18
    Likes Received:
    2
    Hi everyone
    bit of a thread revival for me ... I sourced the cruise switch for our 8p 3 door Quattro s-line tfsi but need to source the lower plastic trim, does anyone have the part number ? also not sure if we will need the extra wire our car Is a 2006 model.
     
  11. Phil-1

    Phil-1 Well-Known Member
    Regional Rep

    Joined:
    Sep 15, 2013
    Messages:
    1,755
    Likes Received:
    437
    I got mine from Huntingdon Audi. I gave them a call and they confirmed that I didn't need the control wire.
    It was £109 delivered.
     
  12. Phil-1

    Phil-1 Well-Known Member
    Regional Rep

    Joined:
    Sep 15, 2013
    Messages:
    1,755
    Likes Received:
    437
    All fitted and working thanks to Shaun.
    Thanks mate
     
  13. davF

    davF ibiza cupra 177bhp

    Joined:
    Feb 11, 2007
    Messages:
    10
    Likes Received:
    0
    Followed this guide yesterday... Fitting went very well coding however is being a nightmare.

    After fitting the retrofit parts yesterday, today I went to get it coded. Steering control module coded fine but the engine wouldn't code?

    Few screen shots:
    ** standard coding**
    https://dl.dropboxusercontent.com/u/28079959/step1.png
    **cruise control selected**
    https://dl.dropboxusercontent.com/u/28079959/step2.png
    **current vs new coding**
    https://dl.dropboxusercontent.com/u/28079959/step3.png
    ** FAIL - error message**
    https://dl.dropboxusercontent.com/u/28079959/step4.png

    Looks to be that the equipment number is too high and not in range but this couldn't be altered.

    Anyone able to shed done light on this?

    Thanks
     
  14. alexi77

    alexi77 Old bloke with too much time on his hands.

    Joined:
    Dec 27, 2012
    Messages:
    101
    Likes Received:
    11
    NHN is your man, Nigel can sort anything.
     
  15. mikeyf

    mikeyf New Member

    Joined:
    Apr 26, 2014
    Messages:
    3
    Likes Received:
    0
    Did anyone have a view on this? Seems a lot of work to put the cable into here if it just goes to a 3amp fuse? Why can this not go direct to the fuse board?
     
  16. mikeyf

    mikeyf New Member

    Joined:
    Apr 26, 2014
    Messages:
    3
    Likes Received:
    0
    So - after stripping the whole thing down - the T12a Pin Layout is WRONG - DO NOT USE this part of the diagram
    The plug is a standard layout 1 to 6 on one row and 7 to 12 on another

    As to the rest - no idea if it is right or wrong
     
  17. manniakk

    manniakk New Member

    Joined:
    Mar 13, 2014
    Messages:
    1
    Likes Received:
    0
    hi, friends. this guide is great, i have followed it and i was ready in less than hour. i have the 1K0 953 549 AF steering module and the cc is not working correctly as previously stated, but i`m fine with that. maybe i`ll get the 8p0 ecu later to make the cc work as expected, if i found it at good price, my only question is: is it possible to display the set speed on the DIS. i have full dis with board computer (the red one). do i need the new module or a new dash. the car is 06.2005 with 3 spoke steering wheel..

    p.s. sorry if it is double post, i could not find my previous message
     
    #96 manniakk, May 2, 2014
    Last edited: May 2, 2014
  18. Lee+Ash_a3

    Lee+Ash_a3 Member

    Joined:
    Feb 9, 2014
    Messages:
    52
    Likes Received:
    11
    Anybody do a supply and fit or just fitting and coding in Scotland, Central preferably? 2009 sb with mfsw.
     
  19. Gaz-M

    Gaz-M Member

    Joined:
    Jun 15, 2014
    Messages:
    153
    Likes Received:
    20
    Lee where in Scotland are you?

    Just used this guide/ coding for mine and couldnt get short code to work- luckily long coding tips worked. What did we ever do before tinterweb!
     
  20. 1inchwarrior

    1inchwarrior Member

    Joined:
    Apr 20, 2011
    Messages:
    40
    Likes Received:
    0
    Awesome guide, picked up a stalk from eBay for £30 delivered, fitted it myself. I stumbled across a thread on another forum (which I can't find again) whereby the guy had cut the lower steering trim to fit the new stalk, looked simple so I gave it a go and....I have to say it looks awesome and was easy too, plus saved myself £45 not having to buy a proper one.
    All the dash warning lights went off about 100yrds down the road and it works!
    It's a 1k0 module ending in AF so works a bit arse backwards but it works, actually looking forward to going back to work (currently on leave) just to put it to full use!
    Thanks again
     
  21. Lee540

    Lee540 Member

    Joined:
    Aug 5, 2012
    Messages:
    123
    Likes Received:
    10
    Is there a definitive coding guide to follow?

    I have 2009 CR170, parts fitted.

    Thanks

    Lee
     
  22. Google AdSense Guest Advertisement



    to hide this advert.
  23. Dommyem

    Dommyem New Member

    Joined:
    Nov 8, 2014
    Messages:
    1
    Likes Received:
    0
    "If you need the control wire, it goes to pin 13 on steering main black plug, and pin 4 on a blue connector under dash, the instructions say remove the connector but using pin nose pliers i pushed it into the connector in place, simply because i couldn't for the life of me get the connector out as it's in the most akward place and no room for tools really to undo it...

    Big thanks to Sijones :arco:[/QUOTE]"


    HELP: Hi, I've got a 2004 3.2 8p 3dr. Could someone shed some more light on this additional Control wire that needs running in. I saw that it goes from pin 13 to some other blue connector pin 4? I assume it's pin 13 on the black connector that plugs into the steering ECU (mounted under the steering wheel??? please confirm) and goes to the main ECU under the bonnet (Is this the one that requires the wiper motor removal???). Any help would be greatly appreciated.
     
  24. Jimmybuckrogers

    Jimmybuckrogers Audi OCD

    Joined:
    Sep 4, 2008
    Messages:
    107
    Likes Received:
    7
    Thanks to sijones and avus sportback for the brilliant guide that got me through the installation on my 2005 A3 DSG S-line. In addition to this I found a great install video on youtube that includes instructions on fitting the control/repair wire which should hopefully clear things up for a few people. I was lucky to have it already in place and found you can check without any dismantling anything by looking up through the gap for the steering column adjustment lever, you can see the black plug into the back of the steering ecu, and the repair wire is (or isn't) 4th from the right on the top row.



    I took my car to a local garage last night where they did the coding for £20, took a few attempts but I think it was after leaving the ignition off for over 30 seconds that did it.
     
  25. M320au

    M320au New Member

    Joined:
    Sep 14, 2012
    Messages:
    10
    Likes Received:
    0
    Cheers fellas for the instructions. I just installed into my 2004 8P 2.0 FSI. I had the control wire standing by as I was certain I would need it - but, to my surprise, it appeared to be present already in the black steering connector?

    According to the numbers on the back of the plug, top right pin is pin 10, hence the black wire is pin 13. Could this be right in a 2004 build - maybe just an Australian market thing?

    If so, will head off to get it coded asap.

    I stupidly reinstalled my airbag without first reconnecting the yellow airbag connector and an airbag warning light appeared. Realised my mistake, disconnected battery again and reconnected the airbag, but the light is still on. Would this sequence create a fault which can be cleared when coding?

    Cheers
    Matt
     

    Attached Files:

  26. Jimmybuckrogers

    Jimmybuckrogers Audi OCD

    Joined:
    Sep 4, 2008
    Messages:
    107
    Likes Received:
    7
    Yeah that's right, pin 13 is for the control wire (4th pin from the right)

    I had an airbag light that went out after about a minute of driving. If you connected your battery with it unplugged it may stay on until you get the fault code cleared, just get it done when it's being coded, 2 second job.
     
  27. M320au

    M320au New Member

    Joined:
    Sep 14, 2012
    Messages:
    10
    Likes Received:
    0
    Yeah, battery got reconnected with airbag still unplugged unfortunately. The remaining warning lights (esp, etc) went out after a minute of driving but airbag stayed on. That's clearly why it's happened then. Thanks for the advice!

    M
     
  28. Conza

    Conza South East
    VCDS Map User

    Joined:
    Jan 1, 2015
    Messages:
    114
    Likes Received:
    20
    Sorry to bump a bit of a old thread, how can I tell if I have the correct steering ecu etc and take it due to previous comments as mines a 2007 sportback I only need the stalk and coul not the wiring
     
  29. Jimmybuckrogers

    Jimmybuckrogers Audi OCD

    Joined:
    Sep 4, 2008
    Messages:
    107
    Likes Received:
    7
  30. Conza

    Conza South East
    VCDS Map User

    Joined:
    Jan 1, 2015
    Messages:
    114
    Likes Received:
    20
    Mine is a 1k0 953 549 AH
    as just looked previous diagnosis log I printed out
     

    Attached Files:

  31. Jimmybuckrogers

    Jimmybuckrogers Audi OCD

    Joined:
    Sep 4, 2008
    Messages:
    107
    Likes Received:
    7
  32. colonialoutcast

    colonialoutcast New Member

    Joined:
    Feb 15, 2015
    Messages:
    4
    Likes Received:
    0
    Hi, i have retrofitted the cruise control on my 2007 A3 by following your awesome guide. I have a mufu steering wheel and DIS factory installed. unfortunately, after completing the retrofit and reconnecting the battery, my car does not turn on anymore. apart from clock and milage displays, everything else remains off. vagcom says as follows:

    01-Engine -- Status: Cannot be reached 1100
    03-ABS Brakes -- Status: Cannot be reached 1100
    04-Steering Angle -- Status: Cannot be reached 1100
    08-Auto HVAC -- Status: OK 0000
    09-Cent. Elect. -- Status: Malfunction 0010
    15-Airbags -- Status: Cannot be reached 1100
    16-Steering wheel -- Status: Malfunction 0010
    17-Instruments -- Status: OK 0000
    19-CAN Gateway -- Status: OK 0000
    25-Immobilizer -- Status: OK 0000
    37-Navigation -- Status: OK 0000
    42-Door Elect, Driver -- Status: Malfunction 0010
    44-Steering Assist -- Status: Cannot be reached 1100
    46-Central Conv. -- Status: OK 0000
    47-Sound System -- Status: OK 0000
    52-Door Elect, Pass. -- Status: OK 0000
    55-Xenon Range -- Status: Cannot be reached 1100
    56-Radio -- Status: OK 0000
    62-Door, Rear Left -- Status: OK 0000
    72-Door, Rear Right -- Status: OK 0000
    76-Park Assist -- Status: OK 0000
    77-Telephone -- Status: OK 0000

    I'm very thankful for any help to get my car running again!
     
  33. Conza

    Conza South East
    VCDS Map User

    Joined:
    Jan 1, 2015
    Messages:
    114
    Likes Received:
    20
    Think u may of damaged the ecu that u remove under the collum
    Mite be worth disconnecting the battery and reconnecting it
     
  34. Conza

    Conza South East
    VCDS Map User

    Joined:
    Jan 1, 2015
    Messages:
    114
    Likes Received:
    20
    MitE also be worth removing the ecu and checking all the connections etc and puting it back
     
  35. colonialoutcast

    colonialoutcast New Member

    Joined:
    Feb 15, 2015
    Messages:
    4
    Likes Received:
    0
    Thanks for your reply Conza!

    I already tried disconnecting and reconnecting the battery to no avail. Hopefully, the ecu has not been damaged, would be a nightmare getting a new one quickly were i live (Kosovo/Balkans). Will check all connections again tomorrow.
     
  36. Conza

    Conza South East
    VCDS Map User

    Joined:
    Jan 1, 2015
    Messages:
    114
    Likes Received:
    20
    Mine worked fine after fitting so that's the only thing that u have touched so start there :)
     
  37. colonialoutcast

    colonialoutcast New Member

    Joined:
    Feb 15, 2015
    Messages:
    4
    Likes Received:
    0
    Btw., when i open the door and press the turn signal lever, the usual signal is audible. I believe this to be a sign that the ecu is not damaged or am i wrong with my assumption?
     
  38. Conza

    Conza South East
    VCDS Map User

    Joined:
    Jan 1, 2015
    Messages:
    114
    Likes Received:
    20
    I'm unsure, I would just work back on what u have touched 1st as it was working before u starting fitting the stalk then go from there
     
  39. colonialoutcast

    colonialoutcast New Member

    Joined:
    Feb 15, 2015
    Messages:
    4
    Likes Received:
    0
    will do tomorrow and let you know! thanks!
     
  40. rsvrider

    rsvrider Member

    Joined:
    May 6, 2013
    Messages:
    56
    Likes Received:
    5
    Hi guys. I fitted my cruise control yesterday and coded it. Engine code was fine but bit unsure of steering wheel part. The original code was 0002012 using the ross tech wiki. I have changed the code to 0002042. I have a manual g,box a three spoke steering wheel with radio controls also has telephone and voice control. No tiptronic. Dis. And a rear wiper.
    Should my code be 0000410000411. Thanks for any help
    Coding
    • 00?xxxx: Transmission
      • 0 = Manual Transmission
      • 1 = Automatic Transmission
    • 00x?xxx: Steering Wheel
      • 0 = 3-Spoke, w/o Tiptronic, w/o Multi-Function
      • 1 = 3-Spoke, with Tiptronic, w/o Multi-Function
      • 2 = 4-Spoke Multi-Function (with Radio Control)
      • 3 = 4-Spoke Multi-Function (with Radio/Telephone Control)
      • 4 = 4-Spoke Multi-Function (with Radio/Telephone/Voice Control)
    • 00xx?xx: Tiptronic/Heating
      • +1 = Tiptronic on Steering Wheel
    • 00xxx?x: Cruise Control/Board Computer
      • 0 = no Board Computer, no Cruise Control
      • 1 = Board Computer, no Cruise Control
      • 2 = no Board Computer, Cruise Control
      • 4 = Board Computer, Cruise Control
    • 00xxxx?: Rear Wiper
      • 0 = w/o Rear Wiper
      • 1 = with Rear Wiper
     
  41. woter324

    woter324 New Member

    Joined:
    Mar 15, 2012
    Messages:
    8
    Likes Received:
    1
    Hi,

    Your coding of 0002042 is correct.

    Thanks,

    W.
     
  42. rsvrider

    rsvrider Member

    Joined:
    May 6, 2013
    Messages:
    56
    Likes Received:
    5
    Thank you for your reply
     

Share This Page