1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cruise control not working!!

SL11CKK Sep 7, 2011

  1. SL11CKK

    SL11CKK Active Member

    686
    35
    28
    Hello all!

    Ive installed cruise control on my car and done the correct coding however it still doesn't work.

    Nothing comes up on the dash to say its working.

    I have searched in the forums however found nothing to be of use.


    I heard something about the clutch pedal sensor could be a cause however how do I go abouts checking this?


    H.
     
  2. kite

    kite Member VCDS Map User

    676
    18
    18
    i believe you can check the operation of the clutch and brake switches with VCDS, don't ask me how thou...
     
  3. manosskali

    manosskali Member

    34
    0
    6
    When mine stopped working it was due to a faulty clutch switch. Remove the panel above the pedals (under the steering wheel). There are two switches above the clutch pedal, the one on the right should be White if original switch, mine was blue. I removed the connector and used a paper clip to create a circuit and my cc started working! I replaced the switch with a new one £15 from audi and it works fine! There is a thread on here for this that helped me a lot. I ve got a picture somewhere but I'm on my phone at the moment, will try to upload later. Hope that's your problem as it's easily fixed!
     
  4. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,272
    1,685
    113
    Have you tested the steering cu measuring blocks for the cruise stalk functions 1st, just so you know this is being seen at the 1st port as such.
     
  5. manosskali

    manosskali Member

    34
    0
    6
    [​IMG]
     
  6. SL11CKK

    SL11CKK Active Member

    686
    35
    28
    Ive tested the switch via the measuring block on VCDS and it seems to be fine. As for the steering module, I've changed that from the "F" variation to the "Q" variation. I've read that it supports the full whack. However how do I go abouts testing the cruise function via VCDS.
     
  7. SL11CKK

    SL11CKK Active Member

    686
    35
    28
    OK cruise control now sorted, turns out it needed coding in the engine too which is strange as majority "how to" don't specify this.

    Now another "small problem". My steering wheel seems slightly (5 degrees approx) bent towards the right when going straight. Before I even opened the steering wheel to install the cruise I tipexed it so that I put the steering wheel straight. Now could this be anything with the steering angle sensor?
     
  8. hades-

    hades- Yorkshire & Humber Rep. Regional Rep VCDS Map User

    9,468
    645
    113
    when u used the tipex
    did u do both wheel and spline ?
     
  9. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,272
    1,685
    113
    I would move it 1 tooth round to see if you just mis-marked it as such, easily done considering the size of the spline teeth
     
  10. SL11CKK

    SL11CKK Active Member

    686
    35
    28
    What does the steering wheel angle sensor do, coz I was thinking it was the angle sensor that was causing the problem.
     

Share This Page