1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

crashing when i go over bumps on the pasenger side top mount ?

harvey01 Sep 2, 2012

  1. harvey01

    harvey01 Member

    523
    9
    18
    hi could this be a topmount or a shock as the shocks are new if its a topmount what ones are best to use ?
     
  2. <tuffty/>

    <tuffty/> Badger 5 Edition...Its all about the flow... Staff Member Moderator Audi S3

    20,320
    3,487
    113
    Std ones and new bearings are fine or an 'upgrade' is to fit LCR ones as they are harder

    <tuffty/>
     
  3. Greg-S3

    Greg-S3 Active Member

    527
    48
    28
    Define a "crashing" noise mate, cause in my experience top mounts normally "creak" unless they have totally fell to bits! Have you checked the lower arms, drop links and anti roll bar D bushes?
     
  4. Greg-S3

    Greg-S3 Active Member

    527
    48
    28
    Has a spring snapped? Checked the top and bottom coils are still seated!
     
  5. harvey01

    harvey01 Member

    523
    9
    18
    hi all its got coilovers (new) its when you go over a pot hole it bangs quite bad but only one side .
     
  6. Greg-S3

    Greg-S3 Active Member

    527
    48
    28
    How low have you set the ride? It may be the car is to low and the suspension is to hard so has minimal compression and the banging is part of the joys of coilovers! Have you still got the helper springs on? Could be something hitting on the chassis/subframe
     
  7. stevegti2

    stevegti2 Member

    229
    13
    16
    i dout its top mounts they would have to be 40 years old lol

    snapped spring
    ball joint
    wishbone bush
    too low bottoming out

    pull it apart and look only way to find out :)
     
  8. harvey01

    harvey01 Member

    523
    9
    18
    hi mate its got helper sprinps im going to look to make shore there is nothing loose . its not that low
     
  9. Greg-S3

    Greg-S3 Active Member

    527
    48
    28
    Check the lock nuts are tight, check your ball joints, lower arm bushes etc. Are they good coilovers or a more affordable kit? I have a friend with a budget kit on a mk4 golf, and that is a hard "crashy" ride
     
  10. harvey01

    harvey01 Member

    523
    9
    18
    ill check the bits , they are a cheaper kit but ive used them before and they where still going strong 5 years later and its only one side and its been getting worse
     
  11. Greg-S3

    Greg-S3 Active Member

    527
    48
    28
    Have you put the shock in the hub seated correctly, could be a faulty damper, drop link tight, ball joint seated correctly, top mount fastened tightly to the damper, lock nut tight, both front coil overs adjusted to the same height, hub nut tight, lower arm bushes. It could be that now its lowered and the lower arm is sat at a more horizontal angle the rear bush could be coming out and it's getting worse as the bush is coming out?
     
  12. harvey01

    harvey01 Member

    523
    9
    18
    im going to check all this monday afternoon mate thanks for the help
     

Share This Page