1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

coolant leak... water pump?

s-line style Jun 10, 2013

  1. s-line style

    s-line style Member

    Messages:
    53
    Likes Received:
    6
    Trophy Points:
    6
    looked on the bottom of me sump a few days ago and noticed the pink coolant had been leaking from somewhere and making its way to me sump lads at work (bmw technicians) say it might be me water pump?? ive been checking me coolant level which isn't going down unless its a really small leak anyone else had this problem or got any other answers?? cars only got 64k on and looked through receipts and its had a water pump on before a think within 10 to 20k miles
     
  2. Mike B

    Mike B Well-Known Member

    Messages:
    1,091
    Likes Received:
    40
    Trophy Points:
    48
    If its coolant I would just wait and see if it gets worse or try some Radseal
     
  3. bradh

    bradh Active Member

    Messages:
    542
    Likes Received:
    57
    Trophy Points:
    28
    Why put rad seal in and mask a problem ?? Find the issue and fix it what engine is this diesel?? If its on the sump it's either water pump located at front or possible thermoset seal on side of the block best thing to do is wipe it off get engine nice and hot and check for leaks
     
  4. Audi Doodah

    Audi Doodah Active Member

    Messages:
    377
    Likes Received:
    35
    Trophy Points:
    28
    +1

    Sort the problem properly otherwise you could end up stuck somewhere with a car that won't hold coolant. Recent thread on water pump failure
     
  5. stu_m

    stu_m Well-Known Member VCDS Map User

    Messages:
    1,440
    Likes Received:
    38
    Trophy Points:
    48
    yup sort the problem dont mess with rad seal!

    check the top rubber hose where it connects to the metal pipe (provide its tdi like mine) mine started weeping and was dripping on to the alternator then going down near the water pump then down to the sump

    It looked like the water pump was leaking
     
  6. s-line style

    s-line style Member

    Messages:
    53
    Likes Received:
    6
    Trophy Points:
    6
    its the 1.8t turbo 190bhp on a 54 and i'd never use radseal ect didn't expect problems like this on a car with 60k and full service history so much for "reliable cars" :S
     
  7. Ian2012

    Ian2012 Active Member

    Messages:
    473
    Likes Received:
    29
    Trophy Points:
    28
    Exact same problem i had (twice) it's the pump get it changed asap if it goes it might make the cambelt jump and you lose the engine

    If it's due a belt change then get the whole lot done audi did mine for £549 and that's tensioner roller belt and pump plus new coolant
     
  8. s-line style

    s-line style Member

    Messages:
    53
    Likes Received:
    6
    Trophy Points:
    6
    dear that a suppose its about right for a dealership price its still under RAC warranty so they should do it well they have to a guess that's the whole point of a warranty and its had a water pump and timing belt within 20k might even be less that's why I don't think I should be having these problems?
     
  9. Audi Doodah

    Audi Doodah Active Member

    Messages:
    377
    Likes Received:
    35
    Trophy Points:
    28
    If it's still under warranty, get it booked in and sort the problems at no cost.

    And if you don't want stuff to fail, buy something that has no moving parts or electronics...a block of wood maybe...s**t drive though! :laugh:
     

Share This Page