1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

convenience control module

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by Deadsmart, Mar 16, 2010.

  1. Deadsmart
    Offline

    Deadsmart New Member

    Joined:
    Mar 16, 2010
    Messages:
    9
    Likes Received:
    0
    [Mar 16, 2010]
    Audi A6 Avant 2.5TDI SE 2003.

    Yep i have had that flood in the back passenger footwell. Fair bit of stuff about it on the forums and a few good tips. Carpet cut, bucket of water removed, sponge sound proof squeezed (another bucket), cleared drain plugs under battery, ( nearly strained me back on that, battery is a ton weight). Now i need to locate the convenience control module. Will i need to remove front passenger seat for this? Is it a straight forward unplug and plug back in? Also how do i dry it out? If its buggered is it a straight replacement part? Just wanna make sure my next steps are the right ones. I was sweating over cutting the carpet, knowing a mass of wires were under there. Any help would be most welcomed


    Thanks in anticipation of whoever points me in the way of the light. Phil
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. Deadsmart
    Offline

    Deadsmart New Member

    Joined:
    Mar 16, 2010
    Messages:
    9
    Likes Received:
    0
    [Mar 19, 2010]
    Car is nice and dry now. Still indicators are stuck on and the rad/cd/nav keeps wanting me to eneter code and now won't com to the dash. Sure its to do with the CCM. Just need to know where its located and how to get to it. Is it under the front passenger Seat? Rear or back of seat area? Please help am due an Mot in a few days gotta get indicators sorted. Many thanks Phil
    #2
  4. Cockney Boy
    Offline

    Cockney Boy Member VCDS Map User

    Joined:
    Nov 26, 2007
    Messages:
    481
    Likes Received:
    6
    [Mar 20, 2010]
    Under the passenger seat, along with the BT module
    #3
  5. Deadsmart
    Offline

    Deadsmart New Member

    Joined:
    Mar 16, 2010
    Messages:
    9
    Likes Received:
    0
    [Mar 21, 2010]
    Well ave found it. Thought i would have to remove seat but upon lifting the front carpet there i was in the floor pan, (sat i a puddle). Cleared water out and removed the CCM. Lucky the water had'nt got into the electronics. Not so lucky, one of the plugs to the box. 2 wires had come out due to corrosion. One was for the indicator reasons why they were flashing madly and one for the courtesy light this to was flashing like a disco light. I managed a botch temp repair but i will have to replace the plug. Just hopin that audi will give me just the plug and not say i have to buy a whole wiring loom. Also the sat nav radio is playing up now, not communicating with the dash display. Just hopin that it may be linked to the box and changing the plug may solve it. Only had problems since the flood of water i,ve had.

    Thanks to those who have put me in the right direction. Phil
    #4
  6. Deadsmart
    Offline

    Deadsmart New Member

    Joined:
    Mar 16, 2010
    Messages:
    9
    Likes Received:
    0
    [Mar 29, 2010]
    Got a replacement plug £12. Took about half an hour snipping and soldering. Cured the problem. To stop it happening again ave shrinked wrapped the the CCM box.

    Thats it done. Phil
    #5

Share This Page