1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Completely dead Speedo cluster- dials, DIS etc all dead.

Discussion in 'A3/S3/Sportback (8P Chassis)' started by heyadamhey, Apr 30, 2011.

  1. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [Apr 30, 2011]
    Hi guys,
    I hope someone can give me some ideas here. I just got back from my honeymoon and found that my speedo cluster is dead - only sign of life is a flashing handbrake light.

    The car drives fine, radio, aircon etc all work 100%. It's just the speedo cluster looks like the car is turned off.

    I ran a VCDS scan which reported some errors: (I'm aware of the fan malfunction and am about the get that fixed)


    Saturday,30,April,2011,12:18:14:24995
    VCDS Version: Release 908.2
    Data version: 20100326



    --------------------------------------------------------------------------------
    --------------------------------------------------------------------------------


    Chassis Type: 1K0
    Scan: 01 03 08 09 15 16 17 19 25 42 44 46 47 52 56 7D

    VIN: WAUZZZ8P44A119475 Mileage: 128980km/80144miles

    00-Steering Angle Sensor -- Status: OK 0000
    01-Engine -- Status: Malfunction 0010
    03-ABS Brakes -- Status: OK 0000
    08-Auto HVAC -- Status: OK 0000
    09-Cent. Elect. -- Status: Malfunction 0010
    15-Airbags -- Status: OK 0000
    16-Steering wheel -- Status: OK 0000
    17-Instruments -- Status: OK 0000
    19-CAN Gateway -- Status: Malfunction 0010
    25-Immobilizer -- Status: OK 0000
    42-Door Elect, Driver -- Status: OK 0000
    44-Steering Assist -- Status: OK 0000
    46-Central Conv. -- Status: OK 0000
    47-Sound System -- Status: OK 0000
    52-Door Elect, Pass. -- Status: OK 0000
    56-Radio -- Status: Malfunction 0010
    7D-Aux. Heat -- Status: OK 0000

    -------------------------------------------------------------------------------
    Address 01: Engine Labels: 03G-906-016-BKD.lbl
    Part No SW: 03G 906 016 G HW: 028 101 136 4
    Component: R4 2,0L EDC 0000SG 5705
    Revision: 12345678 Serial number: AUX7Z0CDFN40BP
    Coding: 0000072
    Shop #: WSC 06435 000 00000

    2 Faults Found:
    18354 - Control Module 1 for Coolant Fan: Defective
    P1946 - 000 - -
    Freeze Frame:
    RPM: 777 /min
    Torque: 22.0 Nm
    Speed: 0.0 km/h
    Load: 0.0 %
    Voltage: 13.98 V
    Bin. Bits: 11000100
    Temperature: 56.7°C
    Duty Cycle: 9.6 %

    18617 - Engine Coolant Temp Sensor on Radiator Outlet (G83): Signal too High
    P2185 - 000 - - - Intermittent
    Freeze Frame:
    RPM: 1701 /min
    Torque: 8.0 Nm
    Speed: 61.0 km/h
    Load: 7.1 %
    Voltage: 13.91 V
    Bin. Bits: 11000000
    Temperature: 88.2°C
    Temperature: 75.6°C

    Readiness: 0 0 0 0 0

    -------------------------------------------------------------------------------
    Address 03: ABS Brakes Labels: 1K0-907-379-MK60-F.lbl
    Part No: 1K0 907 379 K
    Component: ESP FRONT MK60 0103
    Coding: 0023686
    Shop #: WSC 06435 000 00000

    No fault code found.

    -------------------------------------------------------------------------------
    Address 08: Auto HVAC Labels: 8P0-820-043.lbl
    Part No SW: 8P0 820 043 D HW: 8P0 820 043 D
    Component: KlimavollautomatH12 0150
    Revision: 022432 Serial number: 8P0820043D
    Shop #: WSC 00000 000 00000

    1 Fault Found:
    01177 - Engine Control Unit
    013 - Check DTC Memory
    Freeze Frame:
    Fault Status: 01101101
    Fault Priority: 3
    Fault Frequency: 1
    Reset counter: 112
    Mileage: 128984 km
    Time Indication: 0
    Date: 2011.04.28
    Time: 01:14:47

    Freeze Frame:
    ON


    -------------------------------------------------------------------------------
    Address 09: Cent. Elect. Labels: 8P0-907-279-23-H.lbl
    Part No SW: 8P0 907 279 A HW: 8P0 907 279 A*
    Component: Bordnetz-SG 1.0 H30 0501
    Revision: 00030000 Serial number: 00000000388376
    Coding: A1885F00AA141000000000000000000000
    Shop #: WSC 00000 000 00000

    Part No: 8P2 955 119
    Component: Wischer WWS Audi350 0130
    Coding: 16711696
    Shop #: WSC 00000

    9 Faults Found:
    02104 - Light Detection Sensor (G399)
    010 - Open or Short to Plus
    01330 - Central Control Module for Central Convenience (J393)
    004 - No Signal/Communication - Intermittent
    01331 - Door Control Module; Driver Side (J386)
    004 - No Signal/Communication - Intermittent
    01335 - Drivers Seat/Mirror Position Control Module (J543)
    004 - No Signal/Communication
    01332 - Door Control Module; Passenger Side (J387)
    004 - No Signal/Communication - Intermittent
    01320 - Control Module for Climatronic (J255)
    004 - No Signal/Communication - Intermittent
    00483 - Control Module for Auxiliary Air Heater
    004 - No Signal/Communication - Intermittent
    01341 - Control Module in Instrument Panel On Comfort CAN (J285)
    004 - No Signal/Communication - Intermittent
    00466 - Control Module for Steering Column Electronics (J527)
    004 - No Signal/Communication - Intermittent

    -------------------------------------------------------------------------------
    Address 15: Airbags Labels: 8P0-959-655-84.lbl
    Part No SW: 8P0 959 655 E HW: 8P0 959 655 E
    Component: Airbag 8.4EDmin H00 0130
    Coding: 0010102
    Shop #: WSC 06435 000 00000

    No fault code found.

    -------------------------------------------------------------------------------
    Address 16: Steering wheel Labels: 1K0-953-549-MY8.lbl
    Part No SW: 1K0 953 549 A HW: 1K0 953 549 A
    Component: Lenksäulenmodul 012 0030
    Coding: 0000012
    Shop #: WSC 06435 000 00000

    No fault code found.

    -------------------------------------------------------------------------------
    Address 17: Instruments Labels: 8P0-920-xxx-17-MY7.lbl
    Part No SW: 8P0 920 930 F HW: 8P0 920 930 F
    Component: KOMBIINSTR. VDO H25 0110
    Revision: D07 Serial number: 224DCD07029694
    Coding: 0004803
    Shop #: WSC 01333 996 64399

    No fault code found.

    -------------------------------------------------------------------------------
    Address 19: CAN Gateway Labels: 1K0-907-530.lbl
    Part No SW: 1K0 907 530 B HW: 1K0 907 951
    Component: Gateway H08 0090
    Revision: 08 Serial number: 2400103B179596
    Coding: 3D0F0B42070101
    Shop #: WSC 06435 000 00000

    1 Fault Found:
    00381 - Databus Instrument Cluster
    014 - Defective - Intermittent
    Freeze Frame:
    Fault Status: 00101110
    Fault Priority: 1
    Fault Frequency: 1
    Reset counter: 151


    -------------------------------------------------------------------------------
    Address 25: Immobilizer Labels: 1K0-920-xxx-25.lbl
    Part No SW: 8P0 920 930 F HW: 8P0 920 930 F
    Component: KOMBIINSTR. VDO H25 0110
    Revision: D07 Serial number: AUX7Z0CDFN40BP
    Shop #: WSC 01333 996 12757

    No fault code found.

    -------------------------------------------------------------------------------
    Address 42: Door Elect, Driver Labels: 8P0-959-801-MIN1.lbl
    Part No: 8P0 959 801 A
    Component: Tuersteuerger. H10 0010
    Coding: 0000016
    Shop #: WSC 06435 000 00000

    No fault code found.

    -------------------------------------------------------------------------------
    Address 44: Steering Assist Labels: 1Kx-909-14x.lbl
    Part No: 1K2 909 144 E
    Component: EPS_ZFLS Kl.10 1202
    Shop #: WSC 00000 000 00000

    No fault code found.

    -------------------------------------------------------------------------------
    Address 46: Central Conv. Labels: 8P0-959-433.lbl
    Part No: 8P0 959 433
    Component: KSG H02 0040
    Coding: 198800186D280F0FC8DAC67000
    Shop #: WSC 01333 996 12757

    Part No: 1K0 951 605 A
    Component: LIN BACKUP HORN H01 1201

    Part No: 1K0 907 719
    Component: Neigungssensor 002 0002

    Part No: 8P0 951 177
    Component: Innenraumueberw.H03 0010

    No fault code found.

    -------------------------------------------------------------------------------
    Address 47: Sound System Labels: 8Px-035-382.lbl
    Part No SW: 8P3 035 382 HW: 8P3 035 382
    Component: AB2 SUBWOOFERBOXH23 0100
    Revision: 00001 Serial number: 10000001089764
    Shop #: WSC 00000 000 00000

    No fault code found.

    -------------------------------------------------------------------------------
    Address 52: Door Elect, Pass. Labels: 8P0-959-802-MIN1.lbl
    Part No: 8P0 959 802 A
    Component: Tuersteuerger. H10 0010
    Coding: 0000016
    Shop #: WSC 06435 000 00000

    No fault code found.

    -------------------------------------------------------------------------------
    Address 56: Radio Labels: 8P0-035-1xx-56.lbl
    Part No SW: 8P0 035 186 HW: 8P0 035 186
    Component: concert II EU H53 0060
    Revision: 07S Serial number: AUZ2Z3C1742411
    Coding: 0001001
    Shop #: WSC 06435 000 00000

    2 Faults Found:
    01317 - Control Module in Instrument Cluster (J285)
    004 - No Signal/Communication - Intermittent
    Freeze Frame:
    Fault Status: 00100100
    Fault Priority: 5
    Fault Frequency: 3
    Reset counter: 145

    Freeze Frame:
    Bin. Bits: 10

    01299 - Diagnostic Interface for Data Bus (J533)
    004 - No Signal/Communication - Intermittent
    Freeze Frame:
    Fault Status: 00100100
    Fault Priority: 5
    Fault Frequency: 3
    Reset counter: 145


    -------------------------------------------------------------------------------
    Address 7D: Aux. Heat Labels: 1K0-963-235.lbl
    Part No SW: 1K0 963 235 C HW: 1K0 963 235 C
    Component: PTC-Element 0404
    Revision: 00600000 Serial number:
    Shop #: WSC 00000 000 00000

    No fault code found.

    End ---------------------------------------------------------------------

    Any help or suggestions would be greatly appreciated.
    Thanks in advance!

    Adam
    #1
  2. Ads

    Ads

    [Sep 30, 2014]

  3. mike foster
    Offline

    mike foster Fossie VCDS Map User

    Joined:
    Jan 16, 2010
    Messages:
    3,969
    Likes Received:
    79
    [Apr 30, 2011]
    Looks like a fuse to me with all those faults just turning up.

    Have you checked them ?

    Not sure which fuse it is but the manual will tell you.
    #2
  4. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [Apr 30, 2011]
    Forgot to mention that I had checked all the fuses and they were all fine.
    I drove a bit more and the dials and odometer worked intermittently, but the DIS stayed dead.

    I checked in the engine bay and found some half-eaten acorns... seems a rat must've had a taste of the wiring loom... GRRR
    Hopefully it's not too hard to find the nibbled section ...and that there hasn't been a short that's damaged the cluster
    #3
  5. mike foster
    Offline

    mike foster Fossie VCDS Map User

    Joined:
    Jan 16, 2010
    Messages:
    3,969
    Likes Received:
    79
    [Apr 30, 2011]
    Nice one mate !

    I hadn't noticed that you were in South Africa and were obviously subjected to outside agencies that we do not experience here in Blighty !

    Well not much anyway !lol

    Hope you get the nibbler sorted !

    Cheers
    #4
  6. flying oyster
    Offline

    flying oyster flying oyster

    Joined:
    Jul 25, 2009
    Messages:
    554
    Likes Received:
    22
    [Apr 30, 2011]
    Ub40 remix there's a rat in.me engine what am me gonna do
    :Flush:
    #5
  7. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [May 1, 2011]
    Hahahah I'm gonna get dat rat dat's what I'm gonna do
    #6
  8. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [May 10, 2011]
    ok, so my mechanic says there's no damaged wiring i.e. it doesn't look like a rat chewed anything.
    He's quoted R5500 (apprx 550 pounds) to get the cluster 'fixed'.

    My dad (who was using the car while I was on honeymoon) swears it was 100% (barring a flashing handbrake light) when he last used it. When I got in next, the cluster was dead - warning lights, indicators etc work; but dials and DIS don't. The dials and mileage/date displays did work intermittently for a little while, but they're showing no signs of life now either.

    My mechanic said that jump-starting can cause a voltage spike which can cause damage like this.
    I'm gonna take it to the dealer to get their opinion.

    Anyone have any ideas as to what could cause this?
    My only other thought is lightning, but surely this is a stretch because the car body acts as a Faraday cage

    Any suggestions/thoughts would be greatly appreciated...
    #7
  9. Gti Jazz Blue
    Offline

    Gti Jazz Blue Active Member VCDS Map User

    Joined:
    Feb 26, 2007
    Messages:
    1,655
    Likes Received:
    6
    [May 10, 2011]
    Have you tried a disconnect of the battery for 20 minutes to reset all modules.

    Might be worth a go.

    That is a lot of faults thrown that could effect the can-bus.

    Also that temp sensor for the coolant return is a pig - I know I changed mine last night - mine was quite straightforward as I did it with the EGR and IMF off which gives you room to get to it.

    Paul
    #8
  10. consilio
    Offline

    consilio Up the owls!

    Joined:
    Aug 29, 2007
    Messages:
    666
    Likes Received:
    3
    [May 10, 2011]
    As its intermittent it sounds more like a loose connection or damaged wiring to me. Have you noticed it working when going over bumps / right or left turns / speeding up or slowing down? etc etc
    #9
  11. asasprey
    Offline

    asasprey Member

    Joined:
    Mar 14, 2011
    Messages:
    125
    Likes Received:
    1
    [May 10, 2011]
    I would start by asking the mechanic what he would do to fix it. If you see my post, i had a similar problem and it turned out to be abs pump ecu. I would imagine your problem would be the central electronics module, or failing that, new cluster. I would start with the cheapest (C.E module) or remove your instrument cluster, disconnect and reconnect and see if it has sorted it. Or if you have acces to VAG com, or any decent car scanner, you can test the instrument cluster and see if the unit itself works. I would actually test the cluster first definatly! Hope this helps.
    #10
  12. N8
    Offline

    N8 Kowalski Details VCDS Map User

    Joined:
    Jul 4, 2007
    Messages:
    17,161
    Likes Received:
    688
    [May 10, 2011]
    Time for a white cluster? :whistle2:
    #11
  13. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [May 11, 2011]
    I'll try disconnecting the battery tonight - see if it does anything.
    @consilio - I tried to find a consistency with the 'intermittent-ness' but it seems totally random. Was flickering on and off randomly while idling. Not working at all now. Rev counter is stuck on 1000rpm and speedo is stuck at 40kph.

    My mechanic wasn't sure what the electrician (?) was gonna do, but he suspected it was damaged circuitry as a result of a power surge after a jump start. Surely the lower voltage elements would be protected from this kind of thing - flat batteries are possible on any car.

    I phoned Audi and I've got it booked in for a diagnostics check with them. The technician I spoke to asked if I have a vehicle tracking device (quite common here in South Africa). He said that if the car wasn't driven for a few days and the tracker's battery died, it would use the car's battery. after a few days this could then leave the car's battery too low to support the electronics.

    The car started perfectly when I got in (no sign of a low battery), but the Audi guy insisted the 'damage' could already have been done...
    He also asked if the battery had been replaced (which it has) with a non-audi (silver calcium) battery.

    So hopefully the problem is a result of power going too low, rather than too high, and can be resolved with a 'reset'.

    N8 - would love to mate, but the car is actually for sale, so no point in doing that now...
    #12
  14. N8
    Offline

    N8 Kowalski Details VCDS Map User

    Joined:
    Jul 4, 2007
    Messages:
    17,161
    Likes Received:
    688
    [May 11, 2011]
    Shame, whats next?
    #13
  15. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [May 11, 2011]
    Actually planning on getting a Jeep. Need something that can go off road and tow my dirt bike.

    Gonna miss the old girl...
    #14
  16. N8
    Offline

    N8 Kowalski Details VCDS Map User

    Joined:
    Jul 4, 2007
    Messages:
    17,161
    Likes Received:
    688
    [May 11, 2011]
    Fair play lad.
    #15
  17. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [May 13, 2011]
    Riiiiiight, so Audi quoted me R17000 (1700 quid) to fix the problem!!! oh - and R650 to tell me about the raping they have planned.

    All the monkey on the phone could tell me was that the cluster needs replacing due to - wait for it - "unit failure". WTF is that?

    The first mechanic I went to told me that replacing the cluster (with a 2nd hand one) was not worth the mission. The cluster is apparently matched to the chassis number and the keys have to be re-coded. true? N8 - thoughts?
    Last edited: May 13, 2011
    #16
  18. Blue_Thunder
    Offline

    Blue_Thunder Active Member

    Joined:
    Feb 1, 2007
    Messages:
    1,708
    Likes Received:
    9
    [May 13, 2011]
    May be a very stupid question... but your dad hasn't turned the DIS off has he?

    On the S4, the DIS can be switched off by touching the stalk button (rather than holding it for a trip reset, etc.). Not sure if it's the same on your car, but worth looking into.
    #17
  19. Khufu
    Offline

    Khufu Active Member

    Joined:
    Jan 2, 2003
    Messages:
    5,703
    Likes Received:
    30
    [May 13, 2011]
    A 2nd hand unit can be used no problem, the only thing that Audi couldnt do is alter the mileage/KMs to match yours. Plenty of us have had ours replaced with the white Lights cluster including myself.
    #18
  20. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [May 13, 2011]
    Blue Thunder - I'm pretty sure that's not possible on mine. I've never seen that kind of option and I've played with it loads. It's definitely buggered - the speedo and rev counters are stuck...

    Thanks Khufu - good to know.

    The manager at the dealership recommend I get in touch with Audi SA and lodge a formal complaint regarding quality. He said it's not reasonable that such a part should fail at this mileage. The SA government has just passed a new Consumer Protection Act, so he said I should make a big deal out of it and they'll probably cave and replace the cluster. Optimistic, but I'll try my luck...
    #19
  21. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [May 14, 2011]
    1st check the connections to yoour CE board as so many comms issues with so many different modules seems to coincidental to me, maybe a connector has come loose.

    Unit failure means its failed as in gone faulty, doesnt work/properly, kinda obvious tbh fella.

    Yes the keys & cluster are matched to chassis, but fitting a 2nd user or new one transfers the chassis across to another unit & keys are coded at the same time anyway, so your mechanic is making a mountain out of a mole hill.
    #20
  22. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [May 15, 2011]
    Thanks Nigel. I looked all over the engine bay for any damaged wiring or loose connections and couldn't find anything that looked damaged or loose. Where is the CE board?

    hahah regarding the "unit failure" I was being sarcastic :) I expected them to be able to give me a little more information than "unit failure" when the cost is so high. At least give me a "blown flux capacitor" or "overloaded flange coupling" or something! heh heh heh
    #21
  23. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [May 15, 2011]
    CE is hidden above drivers footwell mate, have to remove the trim that covers that whole area & get a torch in there mate, I just think there's too many errors onthe board to call it a cluster fault atm, although its possible the fault is causing some feedback down to that module, but discount this 1st, I would disconnect the cluster & see if you can clear those faults aswell, then you'd know if they were because of the faulty unit, guess you could also stick it on a bench & connect up 12v to the cluster itself & see if it lights up fully.

    Yeah I get yer, but that price is extortionate, given vw make a number of things in SA, you'd think they'd be cheaper, clusters arent that expensive new & swapping over takes 30 minutes tops, they still making the citi golf?
    #22
  24. heyadamhey
    Offline

    heyadamhey Member VCDS Map User

    Joined:
    May 15, 2009
    Messages:
    126
    Likes Received:
    1
    [May 15, 2011]
    The cluster isn't actually completely dead as the topic states (sorry) - the warning lights, indicators etc work, but nothing else.

    I'll have a go at disconnecting the cluster and do another scan. Thanks for the info.

    They actually only just stopped making the citi golfs. Can't believe they made the same model for 35(ish) years!
    #23
  25. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [May 15, 2011]
    Yeah surprised me back in 00 when lived there, that there were new mk1's on the road lol
    #24

Share This Page