1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CLUNKY CLUNKY, FRONT OF CAR CLUNKS

nick-barnes07 Feb 17, 2009

  1. nick-barnes07

    nick-barnes07 Member

    554
    0
    16
    Hi all, on my s3 the front seems to clunk, it only clunks when the car is lifting of or juddering, i replaced the 2 top mounts, cv boots, and top mount bearings, we have checked all the bushes and that but cant seem to find anything, as i said the car only really clunk's when you are either pulling of from stand still or when the car accelarates and lifts on the front, anyone had this problem?????????????????????????
     
  2. mat20vt

    mat20vt Member

    450
    0
    16
    engine mounts?:ermm:

    no luck selling it yet nick?
     
  3. nick-barnes07

    nick-barnes07 Member

    554
    0
    16
    yeah its sold matt, just need to get the mounts done
     
  4. audi18tdan

    audi18tdan Member

    241
    0
    16
    Hi,

    i also have the same sort of problem but only when going over bumps and only since fitting coilovers and if i remember right it's only on the passenger side and that was the side which went down a hugh pot hole so think it may be the top mount bearing.

     
  5. btmotorsport

    btmotorsport Soon be christmas!!!!!!!!!!

    164
    1
    16
    arb drop links?? easy fix if it is
     
  6. jcs356

    jcs356 Brum brum

    2,734
    70
    48
    Another vote for the ARB drop links.
     
  7. nick-barnes07

    nick-barnes07 Member

    554
    0
    16
    ill order some from my local tps tommorow
     
  8. Mr.G

    Mr.G Well-Known Member Team Sepang Audi S3

    1,434
    228
    63
    Mine needs top mounts im sure, had my drop links and bushes done so cant think what else it could be!

    G
     
  9. fran-s3

    fran-s3 Active Member VCDS Map User

    1,103
    3
    36
    Sorry to ressurect an old thread but was this the drop links? This is exactly what my car is doing, clunking lunks when the car is lifting of or juddering... Had the front arb and bushes changed and still the same.
     
  10. s3 ryan

    s3 ryan ryan s3

    26
    0
    1
    same here ive changed the antiroll bushes for power flex ones and ive still got a clunking or sometimes a creak from the front drivers side when going over bumps! its annoying as hell is it worth changing the drop links or could it be somthing else?
     
  11. Kingston

    Kingston Member

    183
    0
    16
    My does the same first time was pads in Calipers so I fitted my nice new front brake kit and rear up grade.
    Still did it but sounded different mmm
    Had all bushes etc changed at front and everything else checked suspension the lot and still none the litter.

    So next on my list is new suspension and top mounts i'm sure this will sort it but as on my report the ones fitted are fine.
     
  12. nick-barnes07

    nick-barnes07 Member

    554
    0
    16
    i never got mine sorted so wasn't sure what it was ???
     
  13. s3 ryan

    s3 ryan ryan s3

    26
    0
    1
    after changing wish bone bushes, top mounts etc i found out by taking the wheel off putting the car on an axle stand then jacked under the hub it was the anti roll bushes still making a noise even tho they are new powerflex ones so i took them off put loads of grease on and it went for 2 weeks without a noise but has started again! im contiplating changing the anti roll bar to an uprated one see if that makes a difference
     

Share This Page