1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Climate control flap motor

Matty5 Mar 8, 2010

  1. Matty5

    Matty5 New Member

    1
    0
    1
    Hi,

    I'm after a climate control flap motor for my 2003 A4. Mine is moving about all the time making a noise and it's driving me nuts. Is anyone breaking an A4 and got one for sale? The part number on it is 8E2.820.511A.

    Cheers
     
  2. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,050
    576
    113
    Just have to try the eBay breakers I think.

    Or PM pjmspeedy for a good deal on a new one - I think he might be away at the moment though I'm not sure....
     
  3. phil_w

    phil_w Active Member VCDS Map User Audi A4 Audi Avant Owner Group S-line owners group Team Brill Red

    591
    54
    28
    I need a 8E0 820 511 B for the same reason - windscreen defroster going mad and sometimes not blowing at all...
     
  4. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,050
    576
    113
    There's a very handy temporary fix detailed HERE
     
  5. simon.m

    simon.m Active Member

    2,747
    6
    38
    round and round and round we go hehehehehe
     
  6. markyzs180

    markyzs180 Member

    543
    1
    16
    hehehe lol...
     
  7. Turkster

    Turkster Bro.Paul 2.5TDI Quattro Sport

    2,797
    47
    48
    iv got one for grabs, £40 + £7 postage

    [​IMG]
     
    Last edited: Mar 10, 2010
  8. Chrismawa

    Chrismawa Active Member

    457
    46
    28
    Thread revival! What was the temporary fix mate? The link is broken and my car is doing the same thing and its annoying as hell!
     
  9. kevbu

    kevbu Member

    85
    7
    8
    Mine failed Tue night in all the fog!! but wed morning was all ok again, still ok. Just keeping me on my toes I guess.
    This is the info in the diy guides. The temp fix is disconnecting servo and leaving lever in a position to direct air to screen.
     
  10. PetrolDave

    PetrolDave Well-Known Member

    1,559
    85
    48
    I've found that the problem is often caused by corrosion on the contacts in the connector. I've solved a similar problem with my passenger temperature flap motor simply by cleaning the contacts in the connector.
     
  11. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,050
    576
    113
    What Kev said..
     
  12. Greeny233

    Greeny233 It's all about the V8. Team V8 Team Silver Audi S4 Audi Avant Owner Group

    1,094
    385
    83
    Update on this FYI 8e2 820 511B (windscreen demist motor) is now superseded by part number ending in 'G' price from TPS £99 + vat retail or £79.95 + vat trade price.
     

Share This Page