1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Centre brake light

Andrewr12 Jun 6, 2013

  1. Andrewr12

    Andrewr12 New Member

    8
    1
    3
    Hi all


    On a bit of a roll fixing things at the minute after VagPro saving the day. Anyway on my partners convertible the centre brake light works intermittently, any of you guys changed bulbs or cleaned contacts?

    Many thanks
     
  2. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,417
    1,740
    113
    It appears to be an led unit as no bulbs show in parts, so I would remove & check the connectors for corrosion, if its not this, then maybe split the unit & check the pcb, its about £45 part, but verify wirings all ok to the unit 1st.
     
  3. Abb

    Abb Member

    309
    11
    18
    I had this problem about a year ago. Removed brake light, cleaned all connections etc, and it seemed to sort it.......for a very short time! You will be best off replacing the brake light, if I remember correctly, it was about £40, straight forward to do and I have never had any problems since.
     
  4. hades-

    hades- Well-Known Member VCDS Map User

    9,481
    646
    113
    as above but
    the cab has a prob with breaking wires
    so pull the rubber boots back and check for any damage,
    think that wire runs through the pass side rubber
     
    NHN likes this.
  5. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,417
    1,740
    113
    Don't know why I didn't think of that one, nice one bez obvious 1st place to look, doh.
     
  6. hades-

    hades- Well-Known Member VCDS Map User

    9,481
    646
    113
    only cos mine went last week
    ans the warning was bugging me all week.
     
  7. Andrewr12

    Andrewr12 New Member

    8
    1
    3
    Hi guys,

    Many thanks for the advice will take a look hopefully over the weekend
     
  8. maikysupra

    maikysupra Active Member

    111
    25
    28
    I had the same problem with my B7 Cabrio recently. The promblem was caused by dry solder joints in the LED unit. Easy fix if you have or can get hold of a solder iron. Let me know if you not sure how to do this!
     
  9. Andrewr12

    Andrewr12 New Member

    8
    1
    3
    Hi, thanks for that still not had chance to take a look as stuck at work.

    Will let you know what I find
     
  10. bearder2006

    bearder2006 Member

    205
    0
    16
    ive got the same problem now whats best to fix it please
     

Share This Page