1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

central locking issues, a6 4.2 quattro 1999 saloon

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by shufti, Jun 17, 2010.

  1. shufti
    Offline

    shufti Member

    Joined:
    Dec 23, 2005
    Messages:
    211
    Likes Received:
    0
    [Jun 17, 2010]
    hi guys

    I haven't had many central locking for a while as I had the usual water problems due to blocked drain holes under the battery and it corroded my comfort/central locking module in the passenger footwell. As well as not having central locking the interior hazard light switch would flash constantly and the indicators blinked twice as fast when in use

    It took me a while to get the correct module but the car has all been completely dried out today, the holes unblocked and the module replaced.

    The indicators are now back to normal and no flashing of the hazard switch etc but the central locking is still not working and still nothing from the key remote. I have cleared all codes with vag-com

    What I am getting is a noise from the rear on occasion sometimes when I turn the key in the door lock. I have had the back interior panel off the boot but I'm not sure if it's in there or maybe the right hand panel. I have taken the power lead from the small pump that operates the boot lock and the noise still happens on occasion so I have ruled that out.

    The module definitely needed replacing anyway but thats unfortunately not the whole story.... Has anyone any ideas of what part I should be replacing next and it's exact location in my car?

    Any help is greatly appreciated

    thanks
    #1
  2. Ads

    Ads

    [Sep 18, 2014]

  3. shufti
    Offline

    shufti Member

    Joined:
    Dec 23, 2005
    Messages:
    211
    Likes Received:
    0
    [Jun 17, 2010]
    quick update......

    when I turn the key slightly in the boot this sometimes (maybe 1 in 10 or 20) locks all the doors. This is the only way I can operate the central locking to lock, I get nothing from the drivers door or from the internal buttons

    Unlocking the drivers door usually just does just the door only but again about 1 in 20 it will work with all doors. This is unlocking only and does nothing other than the single door when locking

    I have taken the power wires from both the small modules in the rear boot so I'm guessing the problem is elsewhere? does this sound familiar with anyone? Any suggestions?

    thanks
    #2
  4. shufti
    Offline

    shufti Member

    Joined:
    Dec 23, 2005
    Messages:
    211
    Likes Received:
    0
    [Jun 18, 2010]
    any takers? It's awfully quiet out there...... lol

    does anyone know where the central locking pump is located on this car? It's a a6 4.2 quattro saloon, 1999.

    I've looked everywhere and I can't find it. thanks
    #3
  5. joedredd
    Offline

    joedredd 2006 A6 S line 3.0tdi Quattro Avant

    Joined:
    Dec 1, 2009
    Messages:
    167
    Likes Received:
    21
    [Jun 18, 2010]
    There is no pump its all electric, thats why you cannot find one.
    #4

Share This Page