1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cd/radio dead but backlight always on?

Discussion in 'A3/S3 Forum (8L Chassis)' started by foss99, Jul 19, 2009.

  1. foss99

    foss99 New Member

    Joined:
    Jul 19, 2009
    Messages:
    2
    Likes Received:
    0
    Hi everyone

    I have an audi a3 2002 plate. My radio/cd/tape in the car is not working. The backlight on the display is lit up but nothing is shown on the display, and no tapes/cds play, and the radio doesnt tune.

    Also when I try to turn the radio off the backlight is still lit up. Even when i turn the ignition off and remove the key the backlight is still lit up.

    Can anyone advise or has anyone had a similar problem?

    Thanks in advance

    Ben
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. AndyMac

    AndyMac Moderator
    Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    39
    Sounds like the HU is getting the trigger from CANBUS to switch on but doesn't have the live feed to do so. Have you checked the fuses, there's one in the fusebox and also one on the back of the HU.
     
  4. foss99

    foss99 New Member

    Joined:
    Jul 19, 2009
    Messages:
    2
    Likes Received:
    0
    cheers, i have fixed it! :beerchug: it was a fuse issue that fixed it but weirdly the fuse wasnt blown. how i did it:


    1. open the fusebox (which is on the driver side dash, hidden until you open the door. jemmy up the lid to reveal it)

    2. consult the handbook and remove the relevant fuse

    3. put the fuse back in

    4. the radio resets itself! all you then need to do is plug in the security code for the symphony radio

    hope this helps someone else!

    ta
    ben
     

Share This Page