1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cd changer not working

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Richard Halpin, Aug 18, 2011.

  1. Richard Halpin
    Offline

    Richard Halpin New Member

    Joined:
    Aug 18, 2011
    Messages:
    2
    Likes Received:
    0
    [Aug 18, 2011]
    hi, can anyone help i have just bought a 2003 audi s4 avant, with rns d head unit and cd changer in the glovebox, when i bought the car the previous owner took his cd's out of the changer, so when i got home i put 4 of my cd's in to the changer, when i went to play them the head unit says no cd changer? i have checked if the wiring is in and it all lookes fine only i found a 2 pin plug behind the head unit dont know where this is meant to go. also the head unit will not illuminate when its turned on so in the dark its a bit ............

    thanks for your time.
    #1
  2. Ads

    Ads

    [Sep 18, 2014]

  3. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,888
    Likes Received:
    477
    [Aug 18, 2011]
    Welcome to the forum!

    I'm not very knowledgable on RNSe compatability, I don't know if they work with every changer or if it's a retrofitted system. Some of these links are dead, but have a look here:

    RNS-E DVD Navigation Plus Quick Links | Audi Forum
    #2
  4. Az
    Offline

    Az Hard slammed!

    Joined:
    Jun 11, 2008
    Messages:
    1,026
    Likes Received:
    32
    [Aug 18, 2011]
    He mentions that he's got an RNS-D not E James. ;)

    I'm not 100% sure if the RNS-D has a separate illumination wire or if it becomes illuminated when the canbus wires tell it to illuminate when the side/headlights are switched on like the RNS-E does, so can't really help you with that bit. As for the cd changer not being recognised, it could of thrown up a fault on the headunit which will need reading via vcds (vagcom) I had several faults on my old RNS-D when I retro fitted my glovebox changer, I had a similar problem to you when I fitted the changer but it was down to a wiring issue, but the vag specialist I use told me the headunit was holding several fault codes.
    #3
  5. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,888
    Likes Received:
    477
    [Aug 19, 2011]
    D/E... You know what I mean! My answer applies to both anyway really.

    Sent from my BlackBerry 9700 using Tapatalk
    #4
  6. dsmclark40v
    Offline

    dsmclark40v Member

    Joined:
    Sep 24, 2006
    Messages:
    720
    Likes Received:
    5
    [Aug 19, 2011]

    Take your cd changer out and give it too me.... just kidding. Sounds like a wiring fault to me. when I was retrofitting mine with an RNS-E and fitting bluetooth something went wrong and I lost illumination which was a pain in the a$$. It was some time last year tho and my bookshelf type memory has forgotten what I did to fix it. where abouts in the uk are you? might be a member with vdcs near by who can scan the car for you
    #5
  7. Richard Halpin
    Offline

    Richard Halpin New Member

    Joined:
    Aug 18, 2011
    Messages:
    2
    Likes Received:
    0
    [Aug 20, 2011]
    thanks for your posts its not a retro fit, it was always there. Also my headlights wont turn off, could this be part of the fault?

    A friend of mine has vagcom so i'll try and get him to scan it for me.
    #6

Share This Page