1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

car wobbles on idle TDI(possible injector problem!?)

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by MAD_Adamski, Nov 21, 2010.

  1. MAD_Adamski
    Offline

    MAD_Adamski Member

    Joined:
    Jan 5, 2009
    Messages:
    313
    Likes Received:
    13
    [Nov 21, 2010]
    my audi a4 wobbles the car on idle i have determined it to be a engine/injector fault and it only does it when stationary....

    has anyone got any experience with this? ie would it be injector seals or the injectors blocking or sticking?

    Should i buy new injectors or 1 new one and try and find the fautly one!?

    cheers Ad
    #1
  2. Ads

    Ads

    [Nov 20, 2014]

  3. paul20v
    Offline

    paul20v Audi fanatic

    Joined:
    May 24, 2009
    Messages:
    1,109
    Likes Received:
    3
    [Nov 21, 2010]
    I would get the injector loom changed first
    its very rare for an injector to go down like this
    #2
  4. Phil MC
    Offline

    Phil MC SerialAudiOffender

    Joined:
    Aug 3, 2010
    Messages:
    100
    Likes Received:
    0
    [Nov 22, 2010]
    If it's the 1.9 lump, then I'm sure the engine mounts have a history of knackering and causing severe idle shaking and vibrating of the whole unit??? Normally ok when driving the car under load though. Worth checking out I'd say.
    #3
  5. RU55SSO
    Offline

    RU55SSO Member

    Joined:
    Aug 3, 2010
    Messages:
    781
    Likes Received:
    19
    [Nov 22, 2010]
    my a3 8p 2004 model does this... not all the time only sometimes like now and then
    #4
  6. MAD_Adamski
    Offline

    MAD_Adamski Member

    Joined:
    Jan 5, 2009
    Messages:
    313
    Likes Received:
    13
    [Nov 22, 2010]
    yes its a 1.9 lump pd130...

    The injector loom is a twat to change tho is it not!? we had the rocker cover off and checked the loom, cleaned it and refitted and was still the same.... but the way it looked was the loom had to be removed backwards ie would need the head off for removal!?

    i know people suggest the loom but i REALLY don't think it is that... and i also think the engine mounts are a bit **** too and need replacing but it is not this causing the wobbles my mechanic suggest there is a miss on it...

    JUST to add this is my GF's car so i' kinda doing this for her so i dont drive it daily too see how it acts BUT i do drive it once a week and have tried things like injector cleaner in the fuel to sort it but has made it slightly better but not fixed by no means...

    Are the pd injectors all the same? or can the nozzles be changed? perhaps that could be a option? I have a 2001 A3 tdi and i have changed the nozzles on that one no problem but just unsure if the PD injectors can be done in the same way!? if so we could change them upto a higher flow to improve the power before we remap it...
    Last edited: Nov 22, 2010
    #5
  7. simon.m
    Offline

    simon.m Active Member

    Joined:
    Oct 5, 2009
    Messages:
    2,747
    Likes Received:
    6
    [Nov 22, 2010]
    I'm pretty sure you don't need to take the head off to do the loom mate I had this and although I did not need a new one looked into it and it says nothing about the head from memory rocker cover and then it pulls out from the back .
    Also a guy on here just adjusted his tick over a wee bit and it stopped it to just a thought though
    #6
  8. Turkster
    Offline

    Turkster Bro.Paul 2.5TDI Quattro Sport

    Joined:
    Dec 11, 2007
    Messages:
    2,759
    Likes Received:
    33
    [Nov 22, 2010]
    im surprised nobody has said duel mass fly wheel yet, they make the engine rock at tick over, when you drive the car, does it settle down?
    #7
  9. CHRIS555
    Offline

    CHRIS555 DOPE with added OCD

    Joined:
    Jul 4, 2010
    Messages:
    1,941
    Likes Received:
    2
    [Nov 22, 2010]
    Does this model have a crankcase breather valve?????

    If so - thats your baby!

    On the petrol models these go all time and only show themselves at idle, by creating a vibration which feels like a misfire or as if the car is being battered by the wind, yet as soon as you increase the revs and drive away everything is fine.

    If it is this the part is normally under £10 and is a DIY job.
    #8
  10. chrisash32
    Offline

    chrisash32 Member

    Joined:
    Nov 10, 2009
    Messages:
    573
    Likes Received:
    1
    [Nov 22, 2010]
    my TDi has suffered from this for at least 12 months.. As described above the car feels like its shaking side to side.
    Would also be interested to hear a fix on this.
    #9
  11. MAD_Adamski
    Offline

    MAD_Adamski Member

    Joined:
    Jan 5, 2009
    Messages:
    313
    Likes Received:
    13
    [Nov 22, 2010]
    as said it seems to have a slight miss which leads me to think its a injector!? does anyone know about the injectors in my previous post?
    #10
  12. MAD_Adamski
    Offline

    MAD_Adamski Member

    Joined:
    Jan 5, 2009
    Messages:
    313
    Likes Received:
    13
    [Nov 22, 2010]
    yes but if its stationary in gear, out of gear, on bite, on revs, it still does it so not clutch/fly problem....
    #11
  13. paul20v
    Offline

    paul20v Audi fanatic

    Joined:
    May 24, 2009
    Messages:
    1,109
    Likes Received:
    3
    [Nov 22, 2010]
    No
    the injector loom bends into sections its a fiddle but does come out and go back in ive done a few
    personally i wouldnt start fiddling with pd injectors there very fussy and also any dirt of any type in them could render them useless.
    have you had the car on a diagnostic and check what fault codes the missfire is bringing up?
    #12
  14. MAD_Adamski
    Offline

    MAD_Adamski Member

    Joined:
    Jan 5, 2009
    Messages:
    313
    Likes Received:
    13
    [Nov 22, 2010]
    i have handled injectors before so that is not a worry to me a have done alot of hands on stuff before just not with his car yet,, i will try and get a chap i know with a fault reader to come have a look.. but just wondered if others have had/solved this before!?
    #13
  15. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    35
    [Nov 23, 2010]
    when you had the loom out did you try just closing up the little spade terminals on the plugs to the injectors?
    #14
  16. hybenz
    Offline

    hybenz New Member

    Joined:
    Nov 25, 2010
    Messages:
    10
    Likes Received:
    0
    [Nov 25, 2010]
    Hi MAD_Adamski, i remember reading one post from audi repair questions that has the same case as yours. He replaced his injectors-that solved his problem. If i remember it correctly,it has something to do with DMF failure.
    #15
  17. paul20v
    Offline

    paul20v Audi fanatic

    Joined:
    May 24, 2009
    Messages:
    1,109
    Likes Received:
    3
    [Nov 25, 2010]
    DMF= Dual Mass Flywheel
    did he change injectors or the fly wheel or both ?
    #16
  18. hybenz
    Offline

    hybenz New Member

    Joined:
    Nov 25, 2010
    Messages:
    10
    Likes Received:
    0
    [Nov 27, 2010]
    He replaced his injectors first,but it only work for a while. He's planning to change his fly wheel this week.
    #17
  19. MAD_Adamski
    Offline

    MAD_Adamski Member

    Joined:
    Jan 5, 2009
    Messages:
    313
    Likes Received:
    13
    [Nov 27, 2010]
    well go a mate coming to plug it in when h's next round he's a customer of mine but a mechanic, so he will have a look for me then if not we may change the injectors it seems definatly to be fuel related i could be wrong but just seems unlikely to be DMF by the way its acting
    #18
  20. deanski
    Offline

    deanski wax on, wax off

    Joined:
    May 20, 2010
    Messages:
    373
    Likes Received:
    6
    [Nov 27, 2010]
    mine wobbles on idle sometimes. it has a brand new DMF in it and the wobble persists with the clutch in. Nothing shows on vagcom even when its doing it. I have a cold start problem and roughness at around 2k rpm to coincide with the wobble so its pointing to the injectors for me.
    #19
  21. legin
    Offline

    legin Member

    Joined:
    Dec 6, 2009
    Messages:
    76
    Likes Received:
    1
    [Nov 29, 2010]
    Its something to do with injectors being dirty i think. injector cleaner fixed mine for a while but it is back again and a small missfire as you describe also you said injector cleaner helped. i think a really heavy dose of injector cleaner and right foot is the way to go. its not dmf as it wouldnt fix itself sometimes. mine shows no fault codes.
    #20
  22. MAD_Adamski
    Offline

    MAD_Adamski Member

    Joined:
    Jan 5, 2009
    Messages:
    313
    Likes Received:
    13
    [Nov 29, 2010]
    we have tried a few types of cleaner with no joy so think we need the injectors cleaned properly or changed....
    #21
  23. choimaloy
    Offline

    choimaloy Member

    Joined:
    Aug 24, 2009
    Messages:
    110
    Likes Received:
    0
    [Dec 2, 2010]
    i've got this problem to,its deffinitly not the flywheel on mine as i've just had it changed ,only seems to do it though when the engine is warm,when started from cold its steady as a rock.
    #22
  24. Steve Wiles
    Offline

    Steve Wiles New Member

    Joined:
    Jul 20, 2010
    Messages:
    18
    Likes Received:
    0
    [Dec 3, 2010]
    Mine does it on start up but not tickover, is this a sign of future problems?
    #23
  25. Jonay
    Offline

    Jonay Member

    Joined:
    May 31, 2010
    Messages:
    274
    Likes Received:
    0
    [Dec 3, 2010]
    My A3 2.0TDI only does this when idling (handbrake applied, clutch disenganged/out of gear) on a slight inclined hill.. rarely when level but it has happened.
    #24
  26. Leea4tdi
    Offline

    Leea4tdi Member

    Joined:
    Mar 31, 2009
    Messages:
    33
    Likes Received:
    0
    [Dec 6, 2010]
    My a4 2.5 quattro 180 did this and it was the dual mass flywheel, only on idle and smoothed out once reved. could not notice it when driving or in gear.
    #25
  27. simon.m
    Offline

    simon.m Active Member

    Joined:
    Oct 5, 2009
    Messages:
    2,747
    Likes Received:
    6
    [Dec 6, 2010]
    so it whent when you put your cluch in ?
    #26
  28. mein_schwein_audi
    Offline

    mein_schwein_audi New Member

    Joined:
    Dec 23, 2010
    Messages:
    1
    Likes Received:
    0
    [Dec 23, 2010]
    Hi Chaps,
    Going back to the start of this thread, I started to notice exactly the same thing with my 57 A3 TDI 170 Sportback (88K) a couple of months ago, that I could feel the motor shaking the car slightly at idle when waiting at traffic lights. Which it didn't use to do.
    And then, last Friday leaving work, the thing conked out dead halfway round the carpark and couldn't be started at all.
    So I had it recovered to Watford Audi because I had no means of diagnosing the falut or attempting a repair in the work carpark.
    And today I got a call..a fault on the number 2 injection unit, cost to replace: £1092...ouch. There was no detail as to whether the fault was mechanical or electrical.
    That quote was based on a 4-hour job, which seemed long to me...but not much option at this point.
    Anyhow, it will be interesting to see afterwards whether the lumpy idle still exists or not.
    If it still is, then I would start to suspect DMF.
    #27
  29. choimaloy
    Offline

    choimaloy Member

    Joined:
    Aug 24, 2009
    Messages:
    110
    Likes Received:
    0
    [Dec 31, 2010]
    did you ever get to the bottm of what was causing the shake cause mines exactly the same but steady when cold on first startup but get pretty back if the car has been running awhile.
    #28
  30. deanski
    Offline

    deanski wax on, wax off

    Joined:
    May 20, 2010
    Messages:
    373
    Likes Received:
    6
    [Mar 9, 2011]
    sorry to dig an oldish thread but mine also wobbles sometimes at idle but i just noticed that it starts when i turn the heater controls off. if i turn it back on it will stop for a minute then start again?
    #29
  31. brownie 25
    Offline

    brownie 25 Member

    Joined:
    Apr 13, 2010
    Messages:
    347
    Likes Received:
    7
    [Apr 27, 2011]
    ime in the same boat lads,changed the loom today and its still the same going to try injectors tomorrow,just wondering has any one come to a conclusion on this
    #30
  32. BILKO1
    Offline

    BILKO1 Member

    Joined:
    Sep 1, 2003
    Messages:
    301
    Likes Received:
    1
    [May 2, 2011]
    You could try upping the tickover if you have VCDS. I had an annoying exhaust vibration / resonance at idle put the tickover up a few clicks and resonance gone:)
    #31
  33. deanski
    Offline

    deanski wax on, wax off

    Joined:
    May 20, 2010
    Messages:
    373
    Likes Received:
    6
    [May 2, 2011]
    i think mine is the alternator clutch pulley so gonna try and change that.
    #32
  34. philfingers
    Offline

    philfingers New Member

    Joined:
    Sep 27, 2009
    Messages:
    1
    Likes Received:
    0
    [Jan 19, 2012]
    My 1.9TDI 130 A4 does this. I'm convinced it's also a fuel/injector problem. Car has done 170k.
    It misses when ticking over, seems to be better when cold than when it's warm. Raising the tickover with my right foot very slightly (10-20rpm etc) seems to smooth it out. I was just wondering if by doing this and adding a tiny amount of fuel, that if I do have a slightly lazy injector then it's giving it enough to allow it to run ok.
    I have VCDS, anyone any tips as to how to raise the tickover slightly? I'm lucky in that most of my driving doesn't see a lot of traffic and hence ticking over
    I'm also convinced it's not a clutch/DMF issues, or the alternator clutch which I did last year.
    Phil
    #33
  35. PhilW
    Offline

    PhilW Member

    Joined:
    Jul 7, 2010
    Messages:
    182
    Likes Received:
    4
    [Jan 19, 2012]
    Mine was caused as the timing was out. Check one of my threads on how to check for it.
    #34
  36. marktdisport
    Offline

    marktdisport Active Member

    Joined:
    Jul 14, 2011
    Messages:
    1,195
    Likes Received:
    15
    [Jan 19, 2012]
    my brother owns a jetta 140 tdi 56plate with 60k which has the biggest shaky idle ever and it's been diagnosed as dual mass flywheel also being faulty !! it's now been like this since 30k... diagnosed by vw main stealers... my a4 pdi130 is also going in next monday for new engine mount, DMFlywheel, new clutch, rear mains and the rear gearbox mount my a4 has a perfect tick over though so cant say i got a tick over problem to compare it to when i get it back, But my car running std 130hp didnt have a clutch fault at all apart from biting a bit high up but since mapped it know shakes and judders under load, few times in the cold spell ive noticed a few shakes on tick over when start up but id guess that as normal for a diesel
    #35
  37. ZeeSaffa
    Offline

    ZeeSaffa Member

    Joined:
    Jan 20, 2012
    Messages:
    116
    Likes Received:
    2
    [Jan 26, 2012]
    #36
  38. white.akita
    Offline

    white.akita Member

    Joined:
    May 7, 2008
    Messages:
    280
    Likes Received:
    2
    [Jan 26, 2012]
    In my opinion 90% of the time when these vag diesels have an intermittant shaky idle it is because the timing is out.
    it doesnt matter if your timing belt was just changed it can still be wrong unless the timing was set with vcds.
    There are 3 bolts on the cam pulley that need to be loosened slightly then the cam pulley can be moved a few mm in either direction using the big nut in the middle until it is within the correct tollerence.
    Its very very easy to fix you just need vcds and the tollerence figures.
    Audi call this procedure idle stabilization and the timing is fine tuned this way.
    check this out also How to adjust rough idle and camshaft timing on VW and Audi TDI pumpe duse engine
    Last edited: Jan 26, 2012
    #37
  39. Charlie Ford
    Offline

    Charlie Ford Member

    Joined:
    Nov 15, 2011
    Messages:
    96
    Likes Received:
    1
    [Jan 26, 2012]
    i have spoken to Audi about mine and the tech at the garage thinks my timing could be out slightly not enough to cause damage but a slower start and a slight wobble.
    #38
  40. white.akita
    Offline

    white.akita Member

    Joined:
    May 7, 2008
    Messages:
    280
    Likes Received:
    2
    [Jan 27, 2012]
    i had exactly the same problem before the new cambelt kit was fitted, after it was fitted the idle was fine but after about 6 weeks the rough intermittant idle came back.

    after ALOT of searching this VERY common vag diesel problem i deceided to alter the timing on the cam sprocket as detailed above but without the use of vcds as i dont have it or could get the use of it.

    anyway, i turned the cam sprocket clockwise about 1mm then tightened the 3 nuts back up and tried it, the idle was better but still not as smooth as i wanted so i turned it clockwise about another 2mm and now the car idles/starts/drives perfectly.

    it seems that hundreds of people have had this problem and people have been searching for years to fix it without any luck and most have just put up with it or adjusted the idle with vcds to mask the problem ,but just by adjusting the idle with vcds it means that the timing is still not correct and it is probably down on power and mpg as im sure it would be better if the timing was set correctly.
    Last edited: Jan 27, 2012
    #39
  41. deanski
    Offline

    deanski wax on, wax off

    Joined:
    May 20, 2010
    Messages:
    373
    Likes Received:
    6
    [Jul 3, 2012]
    sorry to bump and old thread but my car had the exact same problem and it as fixed today by Ian Collins Automotive in Preston.

    My car had had a timing belt fitted under warranty when I bought it and they hadn't set it properly so it wobbled at idle when warm. He picked it up on VCDS as the KW power units were down slightly. All fixed and rock steady now. :)
    #40

Share This Page