1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

car not well

Discussion in 'A4/S4 forum(B5 Chassis)' started by disley, Aug 30, 2008.

  1. disley
    Offline

    disley Member

    Joined:
    Aug 20, 2004
    Messages:
    76
    Likes Received:
    1
    [Aug 30, 2008]
    Recently i noticed the s4 missfiring/hesitating, on cold start, only for first 30 secs, give it a couple of revs and off she goes.
    So i took it to me mates garage so he could plug it in
    Came up with 2 codes
    1128 fuel preasure, inlet leak air system, hose leak
    1130 same description
    So he reset the codes and then when we run car it has a constant missfire
    Disconnected the MAF while running and missfire dissapears, also driving without MAF connected it pulls much stronger
    So as all the garages are shut I will have to wait till monday morning to get it sorted,
    I take it the new MAF should do the trick, should i check anything else
    #1
  2. Ads

    Ads

    [Oct 20, 2014]

  3. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,687
    Likes Received:
    330
    [Aug 30, 2008]
    check there is no air leaks or split pipes?
    #2
  4. Fraser
    Offline

    Fraser Member

    Joined:
    Aug 31, 2003
    Messages:
    584
    Likes Received:
    2
    [Aug 30, 2008]
    agree do a pressure check

    have you ever replaced any of the know culprits in this space? i.e. tbb, f-hose
    #3
  5. Siena
    Offline

    Siena Active Member

    Joined:
    Oct 28, 2007
    Messages:
    2,626
    Likes Received:
    3
    [Aug 31, 2008]
    If there's unmetered air being drawn in, disconnecting the MAF will make it run better.

    The MAF may not be faulty, check for leaks and splits, before condemning it.

    Best of luck.
    #4
  6. disley
    Offline

    disley Member

    Joined:
    Aug 20, 2004
    Messages:
    76
    Likes Received:
    1
    [Aug 31, 2008]
    Done a pressure test today to check for leaks
    didnt find any leaks on the intake system
    Diverter valves seem ok
    the only thing i could hear was air hissing down the side of the camshaft adjustment valve on the front passenger side of the engine,
    couldnt see the exact location the air was comming from but dont think this is part of the intake system anyway(Im probably wrong) but i thought this was due to air getting through to the engine and into the cam area
    If I take the oil cap off the pressure is released
    Or am I doing something wrong?
    #5
  7. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,687
    Likes Received:
    330
    [Sep 1, 2008]
    i _THINK_ the crank case breathers would allow air from the inlet to flow into the crankcase then up and out the oil filler...
    #6
  8. Blue_Thunder
    Offline

    Blue_Thunder Active Member

    Joined:
    Feb 1, 2007
    Messages:
    1,709
    Likes Received:
    9
    [Sep 1, 2008]
    If the crankcase is getting pressurised then chances are that one of your one-way valves is shot. There are three I think, two green, one grey. You can see them under your Y-pipe.

    Don't cost much to replace, and there have been a few S4's where these have started to fail now, mine included.
    #7
  9. disley
    Offline

    disley Member

    Joined:
    Aug 20, 2004
    Messages:
    76
    Likes Received:
    1
    [Sep 1, 2008]
    I will check the 1 way valves, thanks for that
    makes it a bit awkward with them silly one use jubly clips
    #8
  10. Blue_Thunder
    Offline

    Blue_Thunder Active Member

    Joined:
    Feb 1, 2007
    Messages:
    1,709
    Likes Received:
    9
    [Sep 1, 2008]
    Pinched from www.RS246.com:
    #9
  11. disley
    Offline

    disley Member

    Joined:
    Aug 20, 2004
    Messages:
    76
    Likes Received:
    1
    [Sep 2, 2008]
    After doing a few checks on the usual suspects and not coming up with anything, I decided to go ahead with a new MAF and put it on today.
    BINGO!!
    Car now feels like an s4 again, much stronger acceleration than before,
    Must have been on its way out for a while just that I didnt realy feel the gradual reduction in power.

    A BIG Thanks to everyone for their input, Much appreciated
    :respekt:
    #10

Share This Page