1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Car jerking when releasing accelerator anyone help ?

Discussion in 'A3/S3/Sportback (8P Chassis)' started by TDI140, Dec 19, 2013.

  1. TDI140
    Offline

    TDI140 Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    1,405
    Likes Received:
    146
    [Dec 19, 2013]
    Cars drivjng fine pick up and power is fine but when i release accelerator it feels like ive dabbed the brakes on and it feels liek its dipping down on the front and slowing down and not just rolling along i can feel it significantly when release accelerator, someoen said it could be egr valve clogged up and not allowing air to pass through efficiently ?? Anyone had this issue ?

    also everyone with egr delete says that there cars drive much smoother so im thinking its the same thing ?

    any advice is appreciated thanks
    #1
  2. Ads

    Ads

    [Sep 20, 2014]

  3. Phil-1
    Online

    Phil-1 Well-Known Member

    Joined:
    Sep 15, 2013
    Messages:
    1,242
    Likes Received:
    308
    [Dec 19, 2013]
    Have you checked that you don't have a sticking brake? This could be why the nose dips when you ease off
    #2
  4. TDI140
    Offline

    TDI140 Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    1,405
    Likes Received:
    146
    [Dec 19, 2013]
    Brakes are all fine having all pads and discs replaced in january for the snow and bad weather to be safe. Its not brakes they have been all checked seems like egr clocked or something along those lines
    #3
  5. Brodster
    Offline

    Brodster Shark Performance In Scotland Regional Rep Site Sponsor VCDS Map User

    Joined:
    Mar 17, 2011
    Messages:
    3,444
    Likes Received:
    802
    [Dec 19, 2013]
    If it was the EGR you would feel it elsewhere in the rev range and would probably be a nightmare to drive. Is it sluggish when cold or jerky under acceleration under normal driving conitions?
    #4
  6. TDI140
    Offline

    TDI140 Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    1,405
    Likes Received:
    146
    [Dec 19, 2013]
    Only happens in gear was thinkig boost leak but boost gauge shows no psi drop under load, ive already replaced IMF so its not that, brakes seem fine and functioning, yeah bit sluggish when its cold but thats normal isnt it ? I dont put strain on engine unless its warmed up
    #5

Share This Page