1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't get hub off of driveshaft?

Discussion in 'A3/S3 Forum (8L Chassis)' started by Bad Sir Culation, Feb 8, 2014.

  1. Bad Sir Culation
    Offline

    Bad Sir Culation Member

    Joined:
    Nov 9, 2011
    Messages:
    287
    Likes Received:
    17
    [Feb 8, 2014]
    Hi guys, I'm hard at it again today, and stuck again! I'm replacing the driveshaft on the driver side but I cant see how to get it out of the hub? I have undone the centre nut and tried giving it a bit of a whack, but I'm a bit worried about damaging something.

    The hub is currently not attached to anything else but the driveshaft now. Need to get this sorted tonight to stay on track for finishing the car this weekend, so any advice is very much appreciated!
    #1
  2. s3dave
    Offline

    s3dave TFSI Hybrid Supporter

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    730
    [Feb 8, 2014]
    Spray with WD and leave for an hour, it will be just stuck on the splines, a good sharp blow in the centre with a pointed chisel should get it moving...
    #2
  3. Bad Sir Culation
    Offline

    Bad Sir Culation Member

    Joined:
    Nov 9, 2011
    Messages:
    287
    Likes Received:
    17
    [Feb 8, 2014]
    Will that still work with the hub no longer attached to the suspension?
    #3
  4. Bad Sir Culation
    Offline

    Bad Sir Culation Member

    Joined:
    Nov 9, 2011
    Messages:
    287
    Likes Received:
    17
    [Feb 8, 2014]
    Sorted, it's off. I've been googling torque specs for the 6 driveshaft to transmission bolts and most results say 40Nm, but that doesn't seem very tight!
    #4

Share This Page