1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can Led bulbs cause engine management light to come on??

Discussion in 'A4/S4 forum(B5 Chassis)' started by Andyb5, Dec 8, 2012.

  1. Andyb5
    Offline

    Andyb5 Member

    Joined:
    Nov 9, 2012
    Messages:
    62
    Likes Received:
    0
    As the title says really, i have brought some canbus (error free) or supposed to be any way side light bulbs off ebay took the headlights out today to fit them look lovely but within 20 mins of fitting them my engine management light had come on? Anyone else had this problem before?
    #1
  2. Broken Byzan
    Online

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,578
    Likes Received:
    270
    unrelated systems, you need to scan for faults
    #2
  3. Andyb5
    Offline

    Andyb5 Member

    Joined:
    Nov 9, 2012
    Messages:
    62
    Likes Received:
    0
    Did have to unclip part of the air box to get to one of the crews on the headlight could i have done something then? Just seems really weird 20 mins after doing the bulbs it came on? Doesn't seem to be any loss of power or anything still runs as before
    #3
  4. Bradderz_1988
    Offline

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,171
    Likes Received:
    100
    Check all your connections round the airbox. You may have left something a miss.
    #4
  5. HibiscusS4
    Offline

    HibiscusS4 Member

    Joined:
    Jul 14, 2012
    Messages:
    97
    Likes Received:
    3
    Cant see it being the problem but I have seen something very similar in the past and everyone including myself said then that it cannot happen. A friend of mine had a ford Ka and had the 2 rear light clusters replaced with European spec ones to get the car registered aborad (headlights had been done months before but he didnt realise you had to swap the fog light from right to left). After the lights had been changed his engine manegement light came on and the car started to run quite badly. It turned out that the main loom earth is at the very end of the loom and the last thing on the loom is one of the rear lights and the bolt had not been done up enough.
    #5
  6. Andyb5
    Offline

    Andyb5 Member

    Joined:
    Nov 9, 2012
    Messages:
    62
    Likes Received:
    0
    Well just been downstairs checking all the connections in and around the air box. i decided to take it all out and refit it just to make sure I wasn't missing anything. Fired her up and no engine management light so looks like I may have disturbed something around the air box hopefully that's sorted it. Now all my other lights look yellow with lovely crystal white side lights so just order a complete set to replace all the other bulbs with nice white xenon ones. Thanks for ur help all much appreciated
    #6
  7. 205man
    Offline

    205man Active Member

    Joined:
    May 28, 2006
    Messages:
    1,018
    Likes Received:
    4
    you didnt have to buy canbus error fix bulbs as the sidelights arent connected to the lights out warning.

    and led side shouldnt given you a warning anyway, ive been running led sidelights in mine now for about 3 years with no problems or warnings.

    but glad you got it fixed now
    #7

Share This Page