1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bulb Advice

Aidy06 Apr 20, 2013

  1. Aidy06

    Aidy06 Member VCDS Map User

    412
    19
    18
    Hi, I've just received some H7 bulbs from t8ups. Gone about fitting them this morning and turned them on and they started smoking, I could smell a burning smell. I've turned them off now, anybody any idea what's hapoened? I've PM'd t8ups but thought I'd ask on here whilst awaiting his reply, thanks
     
    Last edited: Apr 20, 2013
  2. Aidy06

    Aidy06 Member VCDS Map User

    412
    19
    18
    I've been sent 100w bulbs, shouldn't they be 55w???
     
  3. leeds2592

    leeds2592 When I grow up, I want a 964!

    1,399
    222
    63
    Always thought that anything over 55w are not legal for road use?

    Probably best to wait to hear back from t8ups though mind, don't want to jump to any conclusions as I know he's very helpful when it comes to his bulbs and LEDs.
     
  4. Aidy06

    Aidy06 Member VCDS Map User

    412
    19
    18
    Yeah I think he may of sent the wrong ones by mistake, good job I still had the bonnet up when I turned them on mind or I wouldn't of seen the smoke and smelt the burning
     
  5. Aidy06

    Aidy06 Member VCDS Map User

    412
    19
    18
    Spoke to t8ups, he says the burning is the silver paint on the end of the bulbs and after 30 seconds they will be fine. Anybody used the 100w H7 bulbs from t8ups? Any problems? I'm still kind of worried about them melting but if he says they will be ok then I'll obviously take his word as he knows a lot more than me about the bulbs, just wondering if anybody else is using them without any problems? Thanks
     
  6. OVRA3

    OVRA3 Well-Known Member

    1,079
    80
    48
    I've got them in mine and had them for the last year mot no dramas and never get flashed so they must be ok
     
  7. Sidhu88

    Sidhu88 Active Member

    808
    76
    28
    Running 80s with no probs. U may also get a bit of lens burn on first use but it'll be fine after a few mins.
     
  8. Aidy06

    Aidy06 Member VCDS Map User

    412
    19
    18
    Did you both get the burning smell and smoke upon turning them on the first time?
     
  9. OVRA3

    OVRA3 Well-Known Member

    1,079
    80
    48
    Yep smoky lights.. Coooooollllll. It's all good mate don't worry!

    ImageUploadedByTapatalk1366529718.629448.jpg
     
  10. Aidy06

    Aidy06 Member VCDS Map User

    412
    19
    18
    Yep they're the same ones, saw my arse yesterday and instantly pulled them out. They seemed to be melting on the ends so assumed the wattage was to high as the standard ones in there were 55w, I shall fit them back in today then. Can't believe I've got to go through it again, was awkward enough the first time...
    Thanks mate
     
  11. OVRA3

    OVRA3 Well-Known Member

    1,079
    80
    48
    Rip those knuckles :p
     
  12. hp88

    hp88 New Member

    28
    3
    3
    100w will be fine, I have been using t8ups bulbfor a year and haven't had issues.

    Headlights went in ok, the LED side lights are a pain to fit.
     
  13. Aidy06

    Aidy06 Member VCDS Map User

    412
    19
    18
    Just finished, took around half an hour to replace fogs, main/full beam and side lights. You're right, the side lights are horrible to replace. Hope I don't have to do them again anytime soon
     

Share This Page