1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Brake warning light woes!!!

fozworth Jul 11, 2010

  1. fozworth

    fozworth Member

    85
    0
    6
    I know this problems have cropped up in various forms but I can't find a problem like mine . Basically my large brake warning light comes on and flashes and beeps 3 times but not that often and not generally when cold but from time to time when engine is at running temp and sometimes when cold but only now and again. It doesn't seem lazy on startup and the fluid is full and all pads are fine and new on front.the old front ones were worn past the sensors and I don't know if I needed to reset anything? But I can't think what else it is brakes are working fine.
     
  2. GAudiTech

    GAudiTech Member

    113
    2
    16
    Only when starting?. Had this issue a few times and there is a known fix for it. Its due to the current draw during starting affecting the level sensor and involves fitting a relay on to the sensor signal wire to dash panel which disconnects it under cranking.
     
  3. fozworth

    fozworth Member

    85
    0
    6
    Cheers , is that a main dealer only job plus any idear of the cost. Cheers
     
  4. GAudiTech

    GAudiTech Member

    113
    2
    16
    If your handy with wiring then its a 10min job. Its only a relay so wont cost much. Is it still under warranty?
     
  5. fozworth

    fozworth Member

    85
    0
    6
    No mate but if I knew exactly where it went I could get it done.
     
  6. GAudiTech

    GAudiTech Member

    113
    2
    16
    il give you a diagram if you want. Just to confirm.. When your cranking the engine.. the red brake warning light iluminates?. Just dont wanna give you a fix and turns out not to be that. PM me your email. Cheers
     
  7. jwhat

    jwhat Member VCDS Map User

    541
    2
    18
    Could you PM me the fix too please.
     
  8. GAudiTech

    GAudiTech Member

    113
    2
    16
    Email sent..
     
  9. fozworth

    fozworth Member

    85
    0
    6
    Thanks mate I've printed it off but I will defo have to get someone to do it . Thanks again though. I will do a search to see if somevone is near to me that can do the job
     
  10. s4marsh

    s4marsh Member

    360
    3
    16
    i have this problem on a 99 S4, i read today that if your battery is on its way out it will cause this problem due to the voltage drop when cranking the engine. Would a battery test show the battery performance dropping and would a new battery resolve it? My problem only started when i'd been away working and had to charge the battery when i got home it never felt 100% for a while when starting but seems fine now
     
  11. mt.audi

    mt.audi New Member

    1
    0
    1
    have the same problem. red brake light iluminates when cranking. i would appreciate a diagram for fitting relay. cheers
     
  12. jon1982

    jon1982 diesel dodger

    115
    0
    16
    it is true about the battery because it did the brake warning light on mine a few times not long before the battery died, new battery fitted and i have,nt seen the warning light since.
     

Share This Page