1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Brake light warning symbol

Discussion in 'A3/S3 Forum (8L Chassis)' started by dougie175, Feb 20, 2011.

  1. dougie175
    Offline

    dougie175 Member

    Joined:
    Nov 15, 2010
    Messages:
    140
    Likes Received:
    0
    Since buying my car 6 months ago I have constantly had an intermittent brake light warning symbol, I have found it was my off side brake light and have replaced the bulb twice, Ive also replaced the nearside bulb but the problem still continues one time you will press the pedal and the offside will not illuminate, literally 2 seconds later you can press it and it will.

    Im guessing it is probably the connection to the bulb, i.e a faulty bulb holder.

    If I was to give it a bit of a clean up and spray with some electrical cleaner would this help or is it a case of sourcing a new bulb holder, getting sick of it now and just want to get it sorted.

    Thanks
    Last edited: Feb 20, 2011
    #1
  2. Mpathe
    Offline

    Mpathe 1st gear

    Joined:
    Aug 29, 2009
    Messages:
    394
    Likes Received:
    0
    yes give it a clean with some sand paper or wire wool and spray it with the contact cleaner and should work fine then if not replace it or it might be something else

    regards mike
    #2
  3. dougie175
    Offline

    dougie175 Member

    Joined:
    Nov 15, 2010
    Messages:
    140
    Likes Received:
    0
    What else you thin it could be Mike? Bit of faulty wiring to the bulb holder possibly?
    #3
  4. Mpathe
    Offline

    Mpathe 1st gear

    Joined:
    Aug 29, 2009
    Messages:
    394
    Likes Received:
    0
    could be the bulb holder, could be where the wires connect to the holder or could also be a dodgy wire but I start with the bulb holder.
    #4
  5. Prawn
    Offline

    Prawn My other car is a MINI!!!!

    Joined:
    Dec 8, 2006
    Messages:
    9,439
    Likes Received:
    9
    Epic bump here, google brought me to this thread.

    I have this problem too, and I've still not solved it after months of searching!

    I contantly get the brake light warning light come on, to say my brake lights are broken, but they're working just fine :S
    So far, I've changed all the bulbs, I've changed the bulb holders in the back, and I've changed the brake light switch on the pedal, and it's still just as bad. Sometimes it won't come on at all, but this is very rare. it usually comes on and off constantly every 30seconds - 1 minute the entire time you're driving.

    it really does drive me mad! Anyone got any suggestions? I was sure it was the switch at first, but its obviously not :(
    #5
  6. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,726
    Likes Received:
    20
    bad earth? sounds wiring related to me if its not the actual bulb...

    <tuffty/>
    #6
  7. Jason.s
    Offline

    Jason.s Active Member

    Joined:
    May 12, 2010
    Messages:
    2,879
    Likes Received:
    5
    Brake light switches are common on Mk4`s but you said you changed that so not sure..They do take a little while to register and clear the light but obviously not this long lol.

    Just asked the w/shop controller and as usual they never want to give too much away or think too hard but just said it needs to be plugged in and see what fault codes are popping up when the lights on.
    #7
  8. Prawn
    Offline

    Prawn My other car is a MINI!!!!

    Joined:
    Dec 8, 2006
    Messages:
    9,439
    Likes Received:
    9
    No fault codes at all! That's the annoying problem :(

    It's 100% the bulb warning lamp that comes on, but what's most confusing is that both sides as the high level light work perfectly the whole time despite the warning saying otherwise!
    #8
  9. A3Tom
    Offline

    A3Tom Smell my finger.

    Joined:
    Mar 3, 2009
    Messages:
    3,514
    Likes Received:
    0
    Random!

    I had a similar issue with mine, it was the drivers side rear bulb holder first... then shortly after fixing that the pedal switch went!. All been fine since then though. The beep was driving me up the wall!
    #9
  10. pj123
    Offline

    pj123 Member

    Joined:
    Oct 5, 2010
    Messages:
    295
    Likes Received:
    1
    Have you checked you battery voltage?

    I got the brake warning just on cold startups and was because the battery voltage was around 12.2v in the mornings not 12.4-12.6 for a healthy battery. New battery solved it for me.
    #10

Share This Page