1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Brake Light Switch - 0526 Haldex not working. Audi S3 8L.

Discussion in 'A3/S3 Forum (8L Chassis)' started by ceS3r, Oct 26, 2012.

  1. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    Hey everyone. This is my first thread I'm from Venezuela.

    I'm having this problem with my Audi S3 8L BAM 225. I have the "brake pads worn" yellow light on in the DIS. But I just changed the brake pads like 3 months ago, with it's proper wiring and everything. I connected the Vagcom and it says Brake light switch F implausible signal 0526 but my brake lights do work properly. It only shows when I log on 22-AWD, not in the complete scan. My car feels like fwd, no rear traction. I bought it in december 2012 with 68km on the clock. I don't know if the previous owner changed the haldex oil and filter. What could it be? Thank you in advance.
     
  2. Advert Guest Advertisement


  3. Vex182

    Vex182 Guess what I drive...

    Joined:
    Apr 23, 2012
    Messages:
    1,035
    Likes Received:
    78
    It's the actual brake light switch on the pedal that's gone, it's fairy common. Fit a new one and clear the codes and all should be good. The haldex won't work because its getting a siginal telling it that your braking.
     
  4. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    Thank you very much for the reply. Will try that and post later! Cheers
     
  5. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    A little update here. So I bought the Brake Light Switch and replaced it, deleted the codes and now working fine but still got the "Brake Pads Worn" Yellow light on the dis and still no haldex :banghead:.
    Maybe the pad's sensors causing this? Or the "Brake Pads Worn" yellow light won't make any difference with the haldex?
     
  6. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    I just took off my wheel to see the brake pads sensor wire and its gone, it's totally disconnected from the pads. Could that be the cause? What can I do to fix this without buying a new set of brake pads?
     
  7. Vex182

    Vex182 Guess what I drive...

    Joined:
    Apr 23, 2012
    Messages:
    1,035
    Likes Received:
    78
    The eaisest way is to link the two cables from the cars sensors together. This will sort that warning out.
     
  8. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    Yeah I read that in other threds but my question is if that will sort out the haldex problem? Will do that anyway and see.
     
  9. Vex182

    Vex182 Guess what I drive...

    Joined:
    Apr 23, 2012
    Messages:
    1,035
    Likes Received:
    78
    When my brake pads were worn and the warning came on, I did not notice any issues with the haldex to be honest. What year is your car?
     
  10. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    It's a BAM 2003.
     
  11. Vex182

    Vex182 Guess what I drive...

    Joined:
    Apr 23, 2012
    Messages:
    1,035
    Likes Received:
    78
    Sorry I have just seen its a BAM engine, have you checked your earth strap for the haldex?
     
  12. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    That will be the next thing I'll do. That's the strap located next to the haldex unit right? In the driver's side.
     
  13. Vex182

    Vex182 Guess what I drive...

    Joined:
    Apr 23, 2012
    Messages:
    1,035
    Likes Received:
    78
    Yeh it's about 10" long. Can't remember which side off the top of my head.
     
  14. vrbob

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,375
    Likes Received:
    170
    its visable from the passenger side as i replaced mine last week and now have communication with my haldex via VCDS. Once i had established connection i found a brake light switch fault which must of been stuck in the haldex for ages so now thats cleared and has not come back.
     
  15. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    Thanks for your replies

    I lifted my car up today and check for the Earth Strap and it was there, very tight. So what's next? Could be the haldex controller? Or the pump? What are the symptoms? Or maybe, an oil and filter change could help?
     
  16. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    Little update here. So I had my car on a lift today and checked everything underneath. Earth strap is ok, I pulled it a little to see if it was well attached and it was perfectly attached. Checked the pins to see if they were corroded and they were in perfect state. I run my vcds for codes in the AWD again and again, no fault errors. I run vcds on my abs and also no errors. So, what could it be? Is there any way to test the haldex pump? Or may be the control unit? I just don't wanna buy one of them if they are not the problem, they are very expensive. Any help would be appreciated.
     
  17. dancupra225

    dancupra225 Active Member

    Joined:
    Apr 27, 2012
    Messages:
    667
    Likes Received:
    25
    How much did the brake light switch cost and how hard to fit ? As mine has gone. As well.

    Cheers
     
  18. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    It's not that difficult. You need a torx screw driver to remove the panel that's above the pedals. After you remove the panel, you will se the brake light switch located over the brake pedal, it's a black piece. Twist it counter clockwise to unlock it and take it out. Press the brake pedal back and with your other hand fit the new one, let the pedal go back to it's normal position while still holding the brake light switch so it wont come back, and after that, rotate the new brake light switch clockwise to lock it. And that's it. It is a one time shot so do it carefully. Mine was 400 bolivares (venezuelan currency)thats like 35$ aprox.
     
  19. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    When I try to log with my vag com (VCDS lite free version), on 22-AWD, at first it shows no codes, but when I click, clear codes, it says "Retrieving fault codes" After that, appears a message that says "No fault codes found, or dtc not supported by controller or communication error" ?

    What does this means? I am thinking in buying the blue controller but just want to be sure that's the fault.
     
  20. dancupra225

    dancupra225 Active Member

    Joined:
    Apr 27, 2012
    Messages:
    667
    Likes Received:
    25
    Well I've done mine and now have clutch fault so going to service it check earth strap and wires to haldex

    And hope

    Diffs go for 200 quid on eBay at more so not to bad
     
  21. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    That's the problem, I checked the earth strap and connectors to haldex and they were in perfect state.
     
  22. Advert Guest Advertisement



    to hide this advert.
  23. ceS3r

    ceS3r Member

    Joined:
    Sep 25, 2012
    Messages:
    94
    Likes Received:
    8
    Just trying to remember when my haldex stopped working. I had a personal mechanic who took the car to do some fluid changes, like oil and coolant change. He got the car on a lift, and told me that they were some electrical stuff problem and he sorted out. Like 2 months later, I was on a traffic jam and my A/C wasn't working, and suddenly the water temperature started to go up to 120. I was near a parking lot so I entered there and turned off the car. Almost all the coolant was gone. It turned out to be the battery fuse that was blown and the fans weren't working. I remember that day was the day my haldex stopped working. Just to be sure, the two fuses that are next to the fans are for the abs, correct me if I'm wrong but one is for the ABS and the other for the ABS pump. I also have heard that if something wrong with the abs, haldex won't work. Those two fuses are in very good condition. So, my point here is, maybe the mechanic did something wrong with the electrical stuff and it cause the fuse to blow, and maybe there is other electrical problems with the abs causing the haldex won't work? I don't have abs light on the dash.

    Just hoping to someone can help me, thanks.
     

Share This Page