1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

boot lock problem

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by brownie 25, Aug 28, 2011.

  1. brownie 25
    Offline

    brownie 25 Member

    Joined:
    Apr 13, 2010
    Messages:
    347
    Likes Received:
    7
    [Aug 28, 2011]
    hi all can any one help.
    2001 a4 b6
    my boot will not open when i pull the handle,i have to use the button on the key and even at that it only opens sometimes,i took off the liner to have a look tonight,the actuator if that is what you would call it the thing that pulls the metal rod to release the boot only works sometimes and other times it only pulls the rod half way (one problem)when i disconnected the wire to the back of the handle the handle will work but when its connected it wont work. so any one any ideas.
    #1
  2. Ads

    Ads

    [Sep 19, 2014]

  3. BlackQuat
    Offline

    BlackQuat Well-Known Member VCDS Map User

    Joined:
    Nov 24, 2009
    Messages:
    1,803
    Likes Received:
    44
    [Aug 28, 2011]
    The micro switch will have died on the button.
    someone with abit more knowledge will be along shortly though.
    #2
  4. brownie 25
    Offline

    brownie 25 Member

    Joined:
    Apr 13, 2010
    Messages:
    347
    Likes Received:
    7
    [Aug 28, 2011]
    i was looking through a few threads about it but there is'nt much info hopefully some one will have a diy guide
    #3
  5. Rhencullen1989
    Offline

    Rhencullen1989 190 S LINE QUATTRO

    Joined:
    Nov 6, 2009
    Messages:
    81
    Likes Received:
    0
    [Aug 28, 2011]
    If the micro-switch has died like mine did, i did a really good repair. I bought a new micro-switch from maplins for £1.50, remove the complete numberplate light assy (aluminium on early B6's and plastic on 2004 onwards, due to numberplate light screws corroding in) and using a metal pick, picked out all the original potting, unsolder the connections, (only 2 of the 3 are used) and solder new micro-switch in. Check the NO/NC (normally open/ normally closed) connections as they were the opposite way around on the new switch, all i did was to put a link wire across to the correct pin. Check it all works by using a multimeter with a continuity bleeper (should bleep when pressed in) and re-pot using araldite or silicone sealant. When back on the car i had to bend the actuating tab on the micro-switch to get it to work in the correct place. My boot now works better than it ever has done, just a touch on the rubber pad and she opens....
    #4
  6. brownie 25
    Offline

    brownie 25 Member

    Joined:
    Apr 13, 2010
    Messages:
    347
    Likes Received:
    7
    [Aug 28, 2011]
    by any chance do you have a pic of the micro switch,i have no idea what it looks like
    #5
  7. Rhencullen1989
    Offline

    Rhencullen1989 190 S LINE QUATTRO

    Joined:
    Nov 6, 2009
    Messages:
    81
    Likes Received:
    0
    [Aug 28, 2011]
    Sorry, no i have not, i did the job at work during lunch so had to rush it a bit, once you have removed the black plastic bit that holds the numberplate lights it will all become clear, it's in 2 bits, i think there are some self tappers to remove, then it will all separate, the micro-switch will be visible, a haynes manual will be handy.
    #6
  8. brownie 25
    Offline

    brownie 25 Member

    Joined:
    Apr 13, 2010
    Messages:
    347
    Likes Received:
    7
    [Aug 29, 2011]
    would this be the reason for the too problems or is it possible i need a new actuator as well.why is it that when i disconnected the wires it will work by the handle
    #7
  9. necroeire
    Offline

    necroeire Active Member

    Joined:
    Feb 19, 2004
    Messages:
    1,008
    Likes Received:
    0
    [Aug 29, 2011]
    I had the exact same issue about 2 years ago. I bought a new actuator and fitted it. Very simple fix, worked straight away. I tried all the usual first with penetrating fluid etc..but the actuator was shagged.
    #8
  10. Rhencullen1989
    Offline

    Rhencullen1989 190 S LINE QUATTRO

    Joined:
    Nov 6, 2009
    Messages:
    81
    Likes Received:
    0
    [Aug 29, 2011]
    If the actuator has had it the boot won't open with the keyfob either. Mine worked ok with the key fob so i knew it was the micro-switch.
    #9
  11. brownie 25
    Offline

    brownie 25 Member

    Joined:
    Apr 13, 2010
    Messages:
    347
    Likes Received:
    7
    [Aug 29, 2011]
    sorry just checked again it is the wire that is plugged into the back of the key barrel that when unplugged the handle will work.the actuator works but it seems week but will open some times,it is pulling the rod slightly and releasing again.when i unplugged the wire last night i noticed that my hazard warning light comes on when i open the door or boot is that normal as i cant remember if it happened b4 i went at it
    Last edited: Aug 29, 2011
    #10
  12. brownie 25
    Offline

    brownie 25 Member

    Joined:
    Apr 13, 2010
    Messages:
    347
    Likes Received:
    7
    [Aug 30, 2011]
    any one know if leaving this wire disconnected will cause any problems
    #11

Share This Page