1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

bloody wiper blades!! help

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by tweed, May 24, 2013.

  1. tweed
    Offline

    tweed New Member

    Joined:
    May 19, 2013
    Messages:
    21
    Likes Received:
    0
    [May 24, 2013]
    Needed new blades so bought some and gave them the reg so got to be right.
    When I went to remove the old ones, I pulled the arm up and the blade dropped out, both sides. Then trying to install the new ones I have the same problem. The little plastic clip on the arm doesn't fit the blade. So I go back and make sure I've got the right ones and apparently they are.

    so am I missing a small part?
    Where do you lot get your blades from? Part number?
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. Audi Doodah
    Offline

    Audi Doodah Active Member

    Joined:
    Sep 1, 2012
    Messages:
    371
    Likes Received:
    34
    [May 24, 2013]
    It's possible a previous owner has done the aero wiper arm retro fit hence why the blades identified from your reg don't fit. Loads of wiper related threads in here if you try a search.
    #2
  4. tweed
    Offline

    tweed New Member

    Joined:
    May 19, 2013
    Messages:
    21
    Likes Received:
    0
    [May 24, 2013]
    Cheers people saying bosch 909 blades so will go back and try them in the morning.
    defo not the aero arms.
    Cheers
    #3

Share This Page