1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bloody brake switch issues again !

S3 Paul Oct 16, 2013

  1. S3 Paul

    S3 Paul Well-Known Member Regional Rep

    2,825
    107
    63
    About 3 months ago my euro car parts bought brake light switch apparently went faulty... Vag com brought up the code of 00526 brake light switch f 27 00. Implausible signal.

    i was told it was because the switch was no gen...
    so I replaced it with one from the dealers,
    well the code is back again... Same fault again,
    could it be something else?
    or can they fail this fast?.
     
  2. Andrew@A.L.D

    Andrew@A.L.D May add NOS to 600+bhp S3.

    3,879
    617
    113
    Could be the plug on the switch or the wires to the plug
     
  3. S3 Paul

    S3 Paul Well-Known Member Regional Rep

    2,825
    107
    63
    The fault isn't there all the time and once cleared can take months to come back or... Days
     
  4. Gops

    Gops Badger 5 Edition VCDS Map User Gold Supporter Audi S3

    3,198
    666
    113
    Comes with a guarantee? Ring the dealers and find out, I'm sure it comes with a guarantee, so they'll replace it.
     
  5. Tovs

    Tovs Member

    168
    56
    18
    You've replaces the switch, as said on previous post, have you check the wiring? This fault woing come up all the time, it'll show as and when it wants too.

    Also check, measuring value block, did you check this after replacing the switch? Can be that.

    Though I would of thought best bet was to check wires to and from the brake light switch.
     
  6. S3 Paul

    S3 Paul Well-Known Member Regional Rep

    2,825
    107
    63
    everything looked fine but that was a visual check,
    I remember that was a vag com check to see if the switch makes and brakes the signal... i think i tried that before and it was ok... but ive forgotten what is was.
    The last time i had problems with the car popping a brake light bulb all the time... turned out the switch was the cause.
    I was told this will hinder performance as the ecu will not let me have full power as it thinks the brake pedal maybe down a little??
     
  7. Tovs

    Tovs Member

    168
    56
    18
    Don't think you'll lose power, not to sure about that. Though as you know its just irritating. It may be a faulty switch again, go to a different garage, get it checked maybe? As said before too, check, the wiring too, from start to finish to and from the switch, I'm sure you may find the problem. Hopefully you can sort it :)
     
  8. Andrew@A.L.D

    Andrew@A.L.D May add NOS to 600+bhp S3.

    3,879
    617
    113
    The brake switch will kill power to the Haldex not the engine that i know of?
     
  9. Westy

    Westy Well-Known Member

    17,443
    1,105
    113
    Have you checked your brake lights? I had this exact same issue so I bought a new switch only to have the same problem again. Turned out that the bulb had blown on the brake light bit only. The tail light and brake light are in the same bulb. Worth a try.
     

Share This Page