1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

bkd misfire and long start issues.

Discussion in 'A3/S3/Sportback (8P Chassis)' started by chrisk1700, May 8, 2012.

  1. chrisk1700
    Offline

    chrisk1700 Member

    Joined:
    Mar 29, 2012
    Messages:
    92
    Likes Received:
    0
    hi all, right my a4 has a bkd engine fitted. it did have BLB but i assume it got nuked like most of them do.

    I thought id post about the bkd in the a3 section as its not in the a4s. by code anyway.

    i have cold start issues, it will wind and wind and then splutter into life and run for 15 seconds fine. then will misfire and chuck white smoke out as in plumes, but if you take it for a drive it clears and only pops the odd puff.

    it drives fine under load with no major issues but if you try to drive constant it lurches, not bad bad but bad enough to make any passengers think you cant drive.............

    when warm it starts fine, still smokes and misfires.

    its had a head so its not the coolant issue
    its had a head loom
    its had all 4 injectors recon'd
    egr valve cleaned
    maf cleaned
    tandem pump gasket - someone had used the old gasket when doing the head and had also used that gasket sealer which had gone into the diesel and oil ways but iv sorted all of that now.
    oil change
    turbo seems fine, no play in shaft etc

    now what? injector readouts when warm where 0.71 0.31 1.32 -2.38. i then had them recond and they are fine!

    im sending the ecu off to be checked tomorrow.

    but could i be right in thinking that if the tandem pump gasket was the issue and the oil has mixed with the diesel and the car now has less than a quarter tank in that the fuel could be contaminated? just a thought?

    any help will be very much appreciated.
    #1
  2. Best84
    Offline

    Best84 Member

    Joined:
    Feb 17, 2012
    Messages:
    137
    Likes Received:
    0
    I had the contaminated fuel from tandem pump in my a3. Didnt have what you are describing though, i had a judder when in 5th/6th between 1200-2k revs. This only happened when it was warm too, when it was cold you wouldn't know there was an issue.
    #2
  3. foxymk1
    Offline

    foxymk1 Member

    Joined:
    Apr 17, 2012
    Messages:
    300
    Likes Received:
    0
  4. chrisk1700
    Offline

    chrisk1700 Member

    Joined:
    Mar 29, 2012
    Messages:
    92
    Likes Received:
    0
    nothing shows, glow plugs wouldnt cause smoke or an issue once its running
    #4
  5. foxymk1
    Offline

    foxymk1 Member

    Joined:
    Apr 17, 2012
    Messages:
    300
    Likes Received:
    0
    it would cause blue smoke from unburt fuel on start up and cause starting delay
    #5
  6. chrisk1700
    Offline

    chrisk1700 Member

    Joined:
    Mar 29, 2012
    Messages:
    92
    Likes Received:
    0
    i will get them done when i get the ecu back, as i guess there not to expensive
    #6
  7. chrisk1700
    Offline

    chrisk1700 Member

    Joined:
    Mar 29, 2012
    Messages:
    92
    Likes Received:
    0
    rang the ecu people today and they have said its the wrong ecu for the car, but how? when u search for bkd and blb ecus they are the same part number? but somehow they are different?

    will no if they check it this week sometime.
    #7
  8. chrisk1700
    Offline

    chrisk1700 Member

    Joined:
    Mar 29, 2012
    Messages:
    92
    Likes Received:
    0
    ahhhhhhh just spotted, the last 2 letters are different. i have 03g 906 016 gn?
    #8

Share This Page