1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bi-Xenon light problem b7

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by tak1986, Dec 5, 2011.

  1. tak1986

    tak1986 New Member

    Joined:
    Jun 5, 2009
    Messages:
    21
    Likes Received:
    0
    Hi guys,

    I have been experiencing the xenon flickering issues with my b7 a4, both side, got checked by audi during servicing and they said no error comes up, and they said the battery was having low voltage. The problem still exist now, and thinking to change a set of bulb and see if its cure the problem, is anyone of you know which xenon bulb it use on b7 ?

    Cheers
    Sam
     
  2. Advert Guest Advertisement


  3. Richardesty

    Richardesty loves quattro

    Joined:
    Oct 10, 2008
    Messages:
    750
    Likes Received:
    19
  4. rizzini7

    rizzini7 Active Member
    VCDS Map User

    Joined:
    Jun 4, 2011
    Messages:
    941
    Likes Received:
    143
    Had a drivers bulb flickering and going out on me every now and then. Have since changed both bulbs and theyve been fine since. However it does look like they flicker around here with all the bumps/pot holes and auto level. Got brand new Genuine bulbs off Ebay for £35 each
     
  5. PhilMill63

    PhilMill63 Member

    Joined:
    Jan 11, 2011
    Messages:
    111
    Likes Received:
    0
    Sorry to bump this up! So I too have the flickering Xenon and i'm just coming up on the MOT. My problem is its always worse when the light is first turned on, for the first 5 mins its can be really bad, but not always... I have read so many posts on this problem I have lost any idea what the actual problem is, is it bulbs? if it's that simple I will stick two new ones in.

    All sensible comments welcome.

    Phil
     
  6. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,494
    Likes Received:
    645
    try bulbs 1st
    they if not sorted ballasts
     
  7. tak1986

    tak1986 New Member

    Joined:
    Jun 5, 2009
    Messages:
    21
    Likes Received:
    0
    Got it checked by Audi, they said bulb and control unit (ballast) both faulty.
    The flickering was bad when the car first start, and seems alright after a while. Probably will change e control unit and bulbs
     
  8. carlsarrou

    carlsarrou UnderwaterPilot

    Joined:
    Sep 28, 2007
    Messages:
    9
    Likes Received:
    0
    my a3 xenon drivers side flickers for first 5 minutes also, have looked at history the control unit was changed previously on my car!!! did the change of bulbs/control unit work??
     
  9. chrisa4quat

    chrisa4quat Active Member

    Joined:
    Sep 21, 2004
    Messages:
    959
    Likes Received:
    26
    My passenger bulb goes off within first few seconds of starting car on auto lights. Turn it off and on again seems ok. Don't know where I go myself
     
  10. wyliss

    wyliss Member

    Joined:
    Aug 4, 2004
    Messages:
    286
    Likes Received:
    3
    I have had this issue before. The dealer ended up changing both control units that are positioned below each lamp.
     

Share This Page