1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Best place for EGT sensor AMK

Discussion in 'A3/S3 Forum (8L Chassis)' started by s3gazz, May 23, 2013.

  1. s3gazz
    Offline

    s3gazz Active Member

    Joined:
    Aug 11, 2010
    Messages:
    1,263
    Likes Received:
    62
    Hi guys I've had a bad air leak exhaust gas leak give it some the other day and came up with some weird fault I've decided to look for another just to see if it the sensor that's not right. Engine Managment light also come up.

    do I get a brand new one or a second hand one be ok just need it for mapping next month so ASAP
    #1
  2. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,769
    Likes Received:
    1,277
    Brand new one from dealer or TPS... either way its 160 odd quid with little room for discount...

    May be lucky and find one on eBay... I l;ooked on ebay.de and got one for 50 quid a few years back...

    Not the sort of sensor you just buy to 'try'... may help if you post your 'weird' fault...

    <tuffty/>
    #2
  3. s3gazz
    Offline

    s3gazz Active Member

    Joined:
    Aug 11, 2010
    Messages:
    1,263
    Likes Received:
    62
    Emm bit dear then god. eBay or any s3 getting breaken what othe car could I get one off tuffet pal.

    this is the following fault and simptoms.

    New fault after opening up
    16620 - Manifold absolute pressure (MAP) sensor A, TC system - range/performance problem Intake/exhaust leak, hose connection(s), MAP sensor
    #3
  4. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,769
    Likes Received:
    1,277
    Could be that the ECU is getting conflicting information from the various sensors it uses to control stuff... worth logging 115 and airflow maybe or could just be every things leaking... smoke test, check all pipes and sensors, log a few things and try and eliminate the issues

    <tuffty/>
    #4
  5. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,769
    Likes Received:
    1,277
    Further reading suggests the code is thrown due to an intake or exhaust leak or an issue with the MAP sensor... assume there are no other codes?

    <tuffty/>
    #5
  6. s3gazz
    Offline

    s3gazz Active Member

    Joined:
    Aug 11, 2010
    Messages:
    1,263
    Likes Received:
    62
    I'll do some logs Tomoz pal. Still getting the other faults from ecu tuffty and the egt sensor fault I think

    16490 - Manifold absolute pressure (MAP) sensor/barometric pressure (BARO) sensor - range/performance problem Intake/exhaust leak, wiring, MAP sensor, BARO sensor

    Similar to the other leaks wise nowt else I can see been over it that many times now its unreal
    #6
  7. s3gazz
    Offline

    s3gazz Active Member

    Joined:
    Aug 11, 2010
    Messages:
    1,263
    Likes Received:
    62
    Once the 16620 code comes up and u stop car dies down so have to rev it and delete code then it's fine till u floor it again
    #7
  8. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,769
    Likes Received:
    1,277
    Then you have a problem clearly and should stop flooring it...

    <tuffty/>
    #8
    Broken Byzan likes this.
  9. s3gazz
    Offline

    s3gazz Active Member

    Joined:
    Aug 11, 2010
    Messages:
    1,263
    Likes Received:
    62
    I haven't since tuffty only happened yesterday first time and today just to see if it happened again but never happened on the dyno got a funny one here. EGT sensor on way Tomoz £21 gargin see if wot changes
    #9
  10. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,769
    Likes Received:
    1,277
    Why do you think its the EGT sensor when its saying to check for inlet/exhaust leeks or MAP sensor???

    If the EGT sensor was at fault there would be a code or EGT's would read 1110 deg in block 112

    If you are thinking its the fitting on the back a new one won't help you as it will not fully fit either

    <tuffty/>
    #10
  11. s3gazz
    Offline

    s3gazz Active Member

    Joined:
    Aug 11, 2010
    Messages:
    1,263
    Likes Received:
    62
    Just because that probe still ain't tight in the hole pal but the nut is now fully tight and probe still moves about that's my Exhurst leak there.

    womder with this new turbo If its flowing that much more compared to the map it is making the map sensor fault come up god nose ill do some logging Tomoz
    #11
  12. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,769
    Likes Received:
    1,277
    I told you why the probe is moving about mate... the chinese hotsides are machined too deep for the nut to tighten onto the probe... as for an exhaust leak it will be negligible in context... buying a new probe won't fix that issue, machining the hotside will...

    As for the turbo/map then all bets are off until the mapping has been done... you can't just bolt more capable stuff on and expect it to work as before...

    You just need to make sure that all the sensors are connected and working and the charge system etc is leak free... mapping should sort the rest out...

    <tuffty/>
    #12
  13. s3gazz
    Offline

    s3gazz Active Member

    Joined:
    Aug 11, 2010
    Messages:
    1,263
    Likes Received:
    62
    Ye that why half of these faults I'm getting due to all the stuff I've done and no map.

    im going to try a washer or somate to see if that pushes against the probe if no success ill put it in the down pipe head int coming off again.
    #13

Share This Page