1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B5 S4 rough idle

Discussion in 'A4/S4 forum(B5 Chassis)' started by S4_Biturb, Mar 3, 2012.

  1. S4_Biturb

    S4_Biturb New Member

    Joined:
    Jan 25, 2012
    Messages:
    22
    Likes Received:
    0
    Hi all, as per title, my S4's still idling rough. I had her put on a diagnostics machine week, which came up with an airbag fault (getting done next week) and a lambda sensor fault. I've have the lambda sensor changed and it has improved alot, but its still rough. Mainly when its settled down to around 8-900 revs. I changed the plugs yesterday to ngk platinum laser ones, and again it feels a little better but still not perfect. Im assuming its an air/vacuum leak i.e maf sensor, but any help is much appreciated.
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. Rick @ Unicorn Motor Dev.

    Site Sponsor

    Joined:
    Jan 25, 2012
    Messages:
    1,018
    Likes Received:
    308
    always been like this? is it std?
     
  4. murran

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    39
    what bank was the lambda fault on? did you look at the plugs when you changed them? any black/burned out plugs on the same bank?

    might be wise to have a comp test test done. see if anything correlating...........
     
  5. ldoshiv2

    ldoshiv2 Member

    Joined:
    Oct 11, 2010
    Messages:
    81
    Likes Received:
    0
    maybe coolant temp sensor ?
     

Share This Page