1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B5 RS4 Engine Problems

Discussion in 'RS4 Forum (B5 and B7 Chassis)' started by Danny Cawsey, Mar 11, 2014.

  1. Danny Cawsey
    Offline

    Danny Cawsey Cawsey

    Joined:
    Dec 29, 2009
    Messages:
    508
    Likes Received:
    16
    [Mar 11, 2014]
    Hi, I'm an 8l S3 owner so not normally over this side but my boss has a 2000 b5 rs4 with a few problems and need some help diagnosing whats wrong with it.

    I took it for a drive today and its got a bit of a lumpy idle doesn't really settle. when on boost its got a very slight stutter and doesn't pull so smooth.

    He recently blew the turbos and has just had two brand new one's fitted a couple weeks ago not sure if this could be anything to do with it?.

    Anyway i checked for fault codes and here is what i got:

    16730 Camshaft position sensor
    16730 Engine speed sensor
    17930 Camshaft adjustment bank 2
    18010 Power supply b+ terminal 30, voltage too low

    Any Help would be much appreciated.

    Thanks, Danny
    #1
  2. Ads

    Ads

    [Nov 28, 2014]

  3. PetrolDave
    Offline

    PetrolDave Well-Known Member

    Joined:
    Nov 25, 2003
    Messages:
    1,559
    Likes Received:
    83
    [Mar 12, 2014]
    Try clearing the fault codes and see which ones come back - some of those may be historical from before the recent work.
    #2
  4. Jedgar
    Offline

    Jedgar New Member

    Joined:
    Sep 1, 2013
    Messages:
    6
    Likes Received:
    0
    [May 10, 2014]
    Try Audi SRS forum they will point you in the right direction
    #3
  5. MartayMcFly
    Offline

    MartayMcFly Well-Known Member Regional Rep VCDS Map User

    Joined:
    Feb 17, 2009
    Messages:
    2,681
    Likes Received:
    306
    [May 10, 2014]
    Yup, audisrs is the 'go-to' for B5s
    #4
  6. Aeron
    Offline

    Aeron New Member

    Joined:
    Jul 25, 2014
    Messages:
    1
    Likes Received:
    0
    [Jul 25, 2014]
    Hi, I'm new to this but I have had three B5's and I'm not planning on getting rid of my present one which has been in my possession
    for the last seven years. I can tell you I had the same problem with the stutter it too run lumpy, I took it to Doug at MRC, and it turned out to be a Cam sensor.
    #5

Share This Page