1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AUDI S4 heater not working

PaulS4 Aug 8, 2006

  1. PaulS4

    PaulS4 New Member

    2
    0
    1
    MY S4 heater has stopped completely, the air con unit controls are fine and you can hear compressor coming on but no air blows through. Audi simply want £250 for a new motor but someone told me it may just be a relay? have checked all fuses but not sure where or what number blower relay is? does anyone now?
     
  2. Broken Byzan

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User quattro Audi A4

    13,237
    465
    83
    I bet your car has done around 60 k ish?? its a common fault, the fan stops working. The fan unit itself can be had new for around £120 from Ebay etc, if you are handy with tools its fiddly rather than impossible
     
  3. PaulS4

    PaulS4 New Member

    2
    0
    1
    best get my tools out and check the part numbers then!
     
  4. AndyMac

    AndyMac Moderator Staff Member Moderator

    9,832
    45
    38
    Mine went at 90k (depends how many hours your blower has done). The brushes wear out on the motor and no one seems to do replacements.
    The original blower is made by Valeo part number 8D2 820 021
    Don't go to Audi as you can get them for half that price and it's exactly the same unit.
    Fitting is a 10min job.
    Remove the glovebox, and the blower is behind it, 3 screws and it's out. You also have to remove a bracket above to give you enough room, but it's obvious what's needed.
     

Share This Page