1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi S3 rev problems after FORGE BOV

Allman45 Apr 4, 2014

  1. Allman45

    Allman45 Active Member

    196
    35
    28
    Went for a boost about today and when I hit 5 or 6k revs my car made a really funny sound like a rev limiter and the rev counter was bouncing all over the place.

    yesterday I fitted a forge BOV spacer, could this be the problem?

    any ideas?

    cheers
    james
     
  2. S3_Mat

    S3_Mat Active Member

    550
    192
    43
    Does it do it at high revs and part throttle? Could be crankshaft sensor. Maybe swap the dv back and test. You scanned it with vagcom yet?
     
    Jonse likes this.
  3. Jonse

    Jonse Active Member

    448
    49
    28
  4. S3_Mat

    S3_Mat Active Member

    550
    192
    43
    Camshaft sensor in the end was it? It was an odd one jonse!
     
  5. Jonse

    Jonse Active Member

    448
    49
    28
    Yeah once it was swapped car was back and drove like a dream:)
     
  6. Allman45

    Allman45 Active Member

    196
    35
    28

    Only just noticed iced it today so I haven't done any checks. Yea just high revs it cuts all power and sounds awful.

    im going on holiday this afternoon and will swap the standard valve back on when I'm home, hopefully that will sort it. Do you think? Or will I need a camshaft sensor?
     
  7. Allman45

    Allman45 Active Member

    196
    35
    28
  8. Jonse

    Jonse Active Member

    448
    49
    28
    Sensor with fitting i think was just under £200
     
  9. Allman45

    Allman45 Active Member

    196
    35
    28

    Do you think this is a cause of the forge spacer?
     
  10. S3_Mat

    S3_Mat Active Member

    550
    192
    43
    I doubt it if it is the camshaft sensor, beat thing to do is test drive it again, build the revs slowly if it cuts out without building boost its likely camshaft sensor
     

Share This Page