1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi S3 rev problems after FORGE BOV

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Allman45, Apr 4, 2014.

  1. Allman45
    Offline

    Allman45 New Member

    Joined:
    Apr 4, 2014
    Messages:
    4
    Likes Received:
    0
    [Apr 4, 2014]
    Went for a boost about today and when I hit 5 or 6k revs my car made a really funny sound like a rev limiter and the rev counter was bouncing all over the place.

    yesterday I fitted a forge BOV spacer, could this be the problem?

    any ideas?

    cheers
    james
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. S3_Mat
    Offline

    S3_Mat Active Member

    Joined:
    Oct 21, 2012
    Messages:
    264
    Likes Received:
    61
    [Apr 4, 2014]
    Does it do it at high revs and part throttle? Could be crankshaft sensor. Maybe swap the dv back and test. You scanned it with vagcom yet?
    #2
    Jonse likes this.
  4. Jonse
    Offline

    Jonse Active Member

    Joined:
    Oct 28, 2012
    Messages:
    379
    Likes Received:
    39
    [Apr 4, 2014]
    #3
  5. S3_Mat
    Offline

    S3_Mat Active Member

    Joined:
    Oct 21, 2012
    Messages:
    264
    Likes Received:
    61
    [Apr 4, 2014]
    Camshaft sensor in the end was it? It was an odd one jonse!
    #4
  6. Jonse
    Offline

    Jonse Active Member

    Joined:
    Oct 28, 2012
    Messages:
    379
    Likes Received:
    39
    [Apr 4, 2014]
    Yeah once it was swapped car was back and drove like a dream:)
    #5
  7. Allman45
    Offline

    Allman45 New Member

    Joined:
    Apr 4, 2014
    Messages:
    4
    Likes Received:
    0
    [Apr 4, 2014]

    Only just noticed iced it today so I haven't done any checks. Yea just high revs it cuts all power and sounds awful.

    im going on holiday this afternoon and will swap the standard valve back on when I'm home, hopefully that will sort it. Do you think? Or will I need a camshaft sensor?
    #6
  8. Allman45
    Offline

    Allman45 New Member

    Joined:
    Apr 4, 2014
    Messages:
    4
    Likes Received:
    0
    [Apr 4, 2014]
    #7
  9. Jonse
    Offline

    Jonse Active Member

    Joined:
    Oct 28, 2012
    Messages:
    379
    Likes Received:
    39
    [Apr 4, 2014]
    Sensor with fitting i think was just under £200
    #8
  10. Allman45
    Offline

    Allman45 New Member

    Joined:
    Apr 4, 2014
    Messages:
    4
    Likes Received:
    0
    [Apr 4, 2014]

    Do you think this is a cause of the forge spacer?
    #9
  11. S3_Mat
    Offline

    S3_Mat Active Member

    Joined:
    Oct 21, 2012
    Messages:
    264
    Likes Received:
    61
    [Apr 4, 2014]
    I doubt it if it is the camshaft sensor, beat thing to do is test drive it again, build the revs slowly if it cuts out without building boost its likely camshaft sensor
    #10

Share This Page