1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi S3 EVAP and fuel gauge readings

Discussion in 'A3/S3/Sportback (8P Chassis)' started by mmalh0151, Feb 24, 2013.

  1. mmalh0151
    Offline

    mmalh0151 Member

    Joined:
    Jan 7, 2013
    Messages:
    162
    Likes Received:
    5
    [Feb 24, 2013]
    Hi all, basically my car has had the charcoal canister cleaned out when it went in for some work at Awesome Gti but now the VCDS is bringing up an emission error to do with the EVAP system (I have cleared this code but keeps popping back up on VCDS)

    Now......I put 20 litres of fuel in before and the needle went up to just over 3/4 FULL tank!

    Obviously an issue here.

    Can anybody advise here please? Is it a valve that has gone or the charcoal cannister blocked again?

    A good thread is here....... The Audi TT Forum :: View topic - EVAP canister? N80? ** EDIT: SOLVED I THINK! **

    But need to look more into why my car thinks 20 litres of fuel is 3/4 full when it said there's almost no fuel left in the car at all (range said 5 miles and needle was firmly in red!)

    Car is a 2007 reg S3 with 63k miles on it.

    Any advice would be excellent.

    Cheers

    PS- The car is only run on Shell V power and I have not fully filled the car with fuel just yet.....But I did notice a problem last week when i filled 35 litres in it and it gave me a full tank and a range of 365 miles...Obviously not right!
    #1
  2. Ads

    Ads

    [Oct 31, 2014]

  3. mmalh0151
    Offline

    mmalh0151 Member

    Joined:
    Jan 7, 2013
    Messages:
    162
    Likes Received:
    5
    [Feb 25, 2013]
    The car is also under warranty through a secondary warranty company but obviously want to try and resolve this before it goes away for weeks on end!! Maybe worth fitting new dials to it or would that be too over the top?
    #2
  4. mmalh0151
    Offline

    mmalh0151 Member

    Joined:
    Jan 7, 2013
    Messages:
    162
    Likes Received:
    5
    [Feb 25, 2013]
    Just has this good bit of info from a Audi mechanic

    "Yep, the evap canister can break up causing the fault. There is a basic setting that tests the evap system but i cant remember which channel it is on. Taking the hose off the canister and running the test succesfully will point to a defective canister

    I have had a handful where the canister has broken up and blocked the solenoid valve.


    As for the fuel gauge, thats difficult to say without testing stuff. Its going to be either the dash insert or the fuel gauge sender, with a small possibility of the fuel pump control unit"

    :(
    #3
  5. Artimus
    Offline

    Artimus Short Back

    Joined:
    May 9, 2012
    Messages:
    1,897
    Likes Received:
    369
    [Feb 25, 2013]
    how about filling the tank to see if that recalibrates things.
    #4
  6. mmalh0151
    Offline

    mmalh0151 Member

    Joined:
    Jan 7, 2013
    Messages:
    162
    Likes Received:
    5
    [Feb 26, 2013]
    Cheers! Im sure there is something in VCDS that will test it all so may look at this on the weekend or something. If not, its going in for repair!
    #5

Share This Page