1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi s3 8l MAF sensor

Beany113 Oct 23, 2013

  1. Beany113

    Beany113 Member

    50
    0
    6
    Hi all got a new MAF sensor a few days ago because my car was running really low on power. Bought a new genuine Bosch one from GSF car parts. And it's gone already?! It's back to how it was before. What shall I do?
     
  2. Beany113

    Beany113 Member

    50
    0
    6
    Got the MAF sensor yesterday morning. Could there be anything that would make the car ruin the MAF so quickly?!
     
  3. Beany113

    Beany113 Member

    50
    0
    6
    I reset the ecu and things seem to be fine at the moment.
     
  4. badger5

    badger5 www.badger5.co.uk Site Sponsor

    9,559
    2,028
    113
    over oiled induction kit?
    vibration? (if not on oe airbox)

    both can kill maf's in short measure
     
  5. Beany113

    Beany113 Member

    50
    0
    6
    I'm currently using the standard air box and panel filter, but have ordered a piper cross panel filter
     
  6. Rob45

    Rob45 Member

    48
    1
    6

    Just got mine this morning, from ECP , was running for a week without maf , had ESP and engine light on , put new one in at the carpark , got my exchange so worked out £60.00

    ESP light had gone out but EML still on , got going and was running like a bag of poop , was miising boost at about 2000 rpm then felt fine, got home , noticed i hadnt fully tightened one side of the housing to the airbox , so sent that fully home and tight , started up again , EML still on , got off the drive and light has gone out , drives 100% now ;-) so another job sorted ..
     

Share This Page