1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi A4 yellow oil pressure light on

Discussion in 'The Welcome Section' started by Antonis, Oct 16, 2009.

  1. Antonis
    Offline

    Antonis New Member

    Joined:
    Oct 16, 2009
    Messages:
    2
    Likes Received:
    0
    [Oct 16, 2009]
    I wanted to get some feedback on the following repeated issue I am having.

    • The car when it starts up and is cold sounds like a diesel although it is a petrol engine
    • The yellow oil pressure light comes on
    • If I remove the dipstick to check the oil level then the light goes of for a few days but comes on again.
    • I do have to top the oil at times due to low levels which also temporarily solves the problem but it is still persistant.
    I have been told that it is either the oil sump sensor or the oil pump.
    #1
  2. Ads

    Ads

    [Nov 25, 2014]

  3. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,725
    Likes Received:
    314
    [Oct 16, 2009]
    Welcome. You don't say what car it is so any advice can only be an educated guess. I think the sender in the sump is faulty and /or the oil is worn out. If it were a red oil warning thats for pressure, and is bad...
    #2
  4. Antonis
    Offline

    Antonis New Member

    Joined:
    Oct 16, 2009
    Messages:
    2
    Likes Received:
    0
    [Oct 16, 2009]
    I have an audi a4 2.0L SE petrol.
    #3

Share This Page