1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi A4 Cabriolet Soft Top/ Roof / Hood Motor Repair Guide

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by VagPro, Sep 25, 2011.

  1. shabba007

    shabba007 New Member

    Joined:
    May 23, 2012
    Messages:
    11
    Likes Received:
    0
    Does this cleaning of the motor apply to a 56 plate A4 ? I took my roof down a few months ago in very cold condtions, maybe only 2-3 degrees as I was shifting some gear. The roof never came back up and I had close it manually. Now when I try to open the roof it only dis engages a couple of inches then stops. No sound comming from the motor. Does this sound like a knackered motor, or will cleaning fix.

    Either way, I want to avoid a £500 Audi bill.
     
  2. Advert Guest Advertisement


  3. shabba007

    shabba007 New Member

    Joined:
    May 23, 2012
    Messages:
    11
    Likes Received:
    0
    Fellas, before I try this is the actual roof fused in any way? Must admit I haven't tried that.
     
  4. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    Hello Shabba,

    Yes the first thing to do is check a fuse. If this fails

    The guide is for a 56 plate A4, the problems tends to occur more in the cold weather as the brushes get stuck in the carriers and arc on the commutator. From the description you have given me it sounds like the motor is not kicking in.

    Follow the guide step by step, do not forget to pry open the carriers slightly. I would recommend to disconnect the battery or fuse based on feedback received.
     
    syeed likes this.
  5. syeed

    syeed New Member

    Joined:
    May 22, 2012
    Messages:
    1
    Likes Received:
    1
    Hi Everyone

    Just writing to say Krumz detailed description on how to repair a non working roof is spot on. Bought a 56 reg A4 Cab a couple a weeks ago online at auction but did not realize the roof was not working till I got home. Checked the net for help found this guide and now problem solved. Thanks very much to Krumz for his patience and understanding who guided me through all the steps (even though I forgot to mark the motor housing and had to open and redo the right way round). Once again thanks.
     
    VagPro likes this.
  6. shabba007

    shabba007 New Member

    Joined:
    May 23, 2012
    Messages:
    11
    Likes Received:
    0
    Hi, is it obvious which fuse is for the roof ? Also noticed I get a few flashing roof warnings when I switch the ignition on.
     
  7. shabba007

    shabba007 New Member

    Joined:
    May 23, 2012
    Messages:
    11
    Likes Received:
    0
    OK, the fuse is OK, so then cleaned the motor, but still no joy. The following still happens...

    1. turn on ignition, get flashing roof light.
    2. press the 'roof down' button, windows go down, roof dis-engages then stops after one inch. Storage compartment doen not open. No 'motor' type noise.
    3. Have to press roof button again to close it.

    Mechanically the roof is sound as I can manually open and close it all day long.
     
  8. rjb24

    rjb24 New Member

    Joined:
    May 22, 2012
    Messages:
    2
    Likes Received:
    1
    shabba007 - Your description is exactly the same as the problem I had. Mine is 56 plate (feb 07) a4 3.2
    Presumably you noticed plenty of fluid in the pump reservoir?
    Did you manage to get the spindle (if that's the right word) really cleaned up? I found it tough until I wrapped some sandpaper round a screwdriver and applied a fair bit of pressure onto the surface and turned the motor by hand for a good 5 mins, it really cleaned up and I wear the roof goes up and down a bit quicker now!
     
  9. shabba007

    shabba007 New Member

    Joined:
    May 23, 2012
    Messages:
    11
    Likes Received:
    0
    Must admit I only spent a couple of mins cleaning it with a bit of sandpaper, I didn't think it looked too bad. It was a little grey to begin with. Yes fluid looks ok. Did your storage box lift when things weren't working ? I don't have a multimetre so havent checked for power.
     
  10. shabba007

    shabba007 New Member

    Joined:
    May 23, 2012
    Messages:
    11
    Likes Received:
    0
    well cleaned it again. This time noticed a little gap between one of the contacts as shown on the pic by the arrow. It felt like it was a little stuck and wasn't pushing up against the copper so, I helped it a little. Also notice a little play in the spindle ie, I can move it a couple of mil from side to side. That might be normal, I don't know.

    Anyway still no reaction from the motor.[​IMG]
     
  11. shabba007

    shabba007 New Member

    Joined:
    May 23, 2012
    Messages:
    11
    Likes Received:
    0
    managed to borrow a multimetre. Anyone know where (what) I should be checking for power to the motor ?
     
  12. Niccib

    Niccib New Member

    Joined:
    May 28, 2012
    Messages:
    1
    Likes Received:
    0
    Hi there,

    I wondered if anyone could help me with my Roof issue please ?
    i have a 07 plate a4 sline, basically like most of the post one here i opened it one day and it wouldnt close. The boot lid popped open but wouldnt push its self back up.
    I found the manual key, opened and shut it a few times but still not working.
    I then closed it with the key, then tried to open it with the button.
    The roof unclips windows go down but only opens about a inch.
    So today i took it to audi, they told me that i have a electrical fault with the pump not pushing the fluid up to make the roof open...
    You will have to forgive my naivety, if thats a incorrect explaination... i am a girl and have no idea of how a car works full stop !!
    Audi then told me that i need a new pump which would be £1400, i nearly passed out !!
    Any ideas if this could be fixed, eg buy getting a auto electrican to do the previous diagram displayed on the first pages as i dont think i will be able to undertake this myself in a million years.
    Or do i just have to face the fact that i will be using that massive key for the forseable future.
    Any comments would be greatly appreciated.
     
  13. shabba007

    shabba007 New Member

    Joined:
    May 23, 2012
    Messages:
    11
    Likes Received:
    0
    sounds like you have the exact same problem as I have. Thats the biggest quote I've heard so far. Someone will probably correct me, but I think the motor that drives the pump is around £200. Alternatively, if you (or friend) can get you motor out following the guide on the previous page, you can send it to this guy who can fix the motor.
    I'm just in the process of sending mine.

    Audi A4 Cabriolet Roof Motor Repair (Power-Packer) | eBay
     
  14. shabba007

    shabba007 New Member

    Joined:
    May 23, 2012
    Messages:
    11
    Likes Received:
    0
    just an update. This chap on Ebay who fixes the motor is awesome. Motor was posted on a Wednesday and I got it back by Friday. Roof now works again.
    Job done £75
     
  15. davidB7

    davidB7 New Member

    Joined:
    Jun 3, 2012
    Messages:
    1
    Likes Received:
    0
    Hi everyone and many thanks to Krumz for the great info. My hood had the same symptoms ie hood cover would unlatch and then nothing. I have looked at the pump and found one of the brushes jammed - this was fixed. In the meantine we had some sunshine and the hood was operated manually. Now the "hood not latched" alarm is on whenever the hood is up - it clears if the hood is manually lowered and stowed properly. I suspect the controller is out of synch and I have tried manualy operating the hood three times with the ignition on - it did not clear the alarm and nothing happens when the hood switch is operated - both up and down.

    Anybody got any ideas as to how to clear the alarm (it goes off every time 20 mph is reached) as I suspect I am getting nowhere until then. Grateful for any suggestions
     
  16. countax

    countax New Member

    Joined:
    Jun 5, 2012
    Messages:
    17
    Likes Received:
    1
    Krumz, THANK YOU SO MUCH.
    I purchased my 2006 cabriolet 2 days ago with a known 'roof won't come down' problem and i am pleased to say that following your advice i have managed to fix it. Like others have posted i also had a brush stuck in its holder. A simple use of a flat bladed screwdriver to open up the gap on the brass sleeve and the brush now moves freely and makes contact with the motor. The most difficult part of the whole job was removal of the boot side panel, but with care it came away from its clip without damage.
    If you are ever passing the Cotswolds then i owe you a pint or two as thanks.
    Nigel
     
    VagPro likes this.
  17. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    Shabba, sorry for not getting back to you, the problem you had was the brushes were getting stuck in the carrier and this needed to be pried open in order to let the brushes move freely. Glad you got it sorted anyway
     
  18. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    Hello niccib, same problem that I have written the guide for. To be certain it is the motor slap a multimeter to its power. Otherwise just open it up, give it a clean and do not forget to pry open the brush carriers. Let me know how you get on
     
  19. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    Check that you are locking the front of the hood to the windscreen correctly, or you may have damage the switch may be faulty. Get on Vagcom and see what it says.
     
  20. Michael Clarke

    Michael Clarke New Member

    Joined:
    Jul 2, 2012
    Messages:
    5
    Likes Received:
    0
    looking for some help with leak from Cabriolet roof. Water coming in at front driver's side corner where it meets the door post. Checked that roof is properly locking and lubricated latches. Is there anything anyone can suggest?
     
  21. lewie

    lewie Member

    Joined:
    Mar 20, 2011
    Messages:
    292
    Likes Received:
    6
    I have this too, only happens when I park the car faing downwards on my drive- never solved it just park my car facing upwards on the drive now
     
  22. Advert Guest Advertisement



    to hide this advert.
  23. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    Hi Michael,

    How does the roof sit with the seal on the top on the windscreen? It is possible to adjust how tight the roof seals there. Assume you have examined for no rips or wear on the rubber channels
     
  24. Michael Clarke

    Michael Clarke New Member

    Joined:
    Jul 2, 2012
    Messages:
    5
    Likes Received:
    0
    Hi, no damage to seals. The roof seems to be sitting as it always has. The edge of the roof, then some runbber and then the aluminium screen edge ...from memory.
     
  25. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    I would start by using some enigneers blue or grease to see that the seals are making contact at all points, however I am not sure the grease would do the seals any good.
     
  26. Michael Clarke

    Michael Clarke New Member

    Joined:
    Jul 2, 2012
    Messages:
    5
    Likes Received:
    0
    The seals seem to be tight enough. I closed the roof on to some paper and then pulled the paper out and there was resistance felt.
     
  27. Michael Clarke

    Michael Clarke New Member

    Joined:
    Jul 2, 2012
    Messages:
    5
    Likes Received:
    0
    Is there an adjustment I could try?
     
  28. kevins

    kevins New Member

    Joined:
    Jul 4, 2012
    Messages:
    2
    Likes Received:
    0
    Hi Krumz

    I have a problem with my friends 2004 A4 Cabriolet. Its a B6 model with engine BFB. There is a cable broken in the roof variable storage box. I am going to replace the complete box as you can not buy any parts for them. Do you have any information on changing the box from the workshop manual.

    Thanks

    Kevin
     
  29. JasonS

    JasonS Member
    VCDS Map User

    Joined:
    Feb 22, 2012
    Messages:
    124
    Likes Received:
    6
  30. Michael Clarke

    Michael Clarke New Member

    Joined:
    Jul 2, 2012
    Messages:
    5
    Likes Received:
    0
    Hi Krumz,

    is there anything you can suggest for this, thanks?
     
  31. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    Hi Michael,

    I am thinking that the paper test you did may suggest that the roof is making contact at certain locations and maybe not all along the rubber seal.

    Also how about some closeup pics of the rubber seals and I can compare this against mine?
     
  32. JasonS

    JasonS Member
    VCDS Map User

    Joined:
    Feb 22, 2012
    Messages:
    124
    Likes Received:
    6
  33. kevins

    kevins New Member

    Joined:
    Jul 4, 2012
    Messages:
    2
    Likes Received:
    0
    Thanks Jason, we fit the new box yesterday. Info was very handy.

    Kevin
     
  34. bearder2006

    bearder2006 Member

    Joined:
    Jun 18, 2009
    Messages:
    205
    Likes Received:
    0
    Mine has gone again folds away then when I'm putting up windows go down then boot pops up and that's it help again please
     
  35. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    Same problem as last time or something else ?
     
  36. bearder2006

    bearder2006 Member

    Joined:
    Jun 18, 2009
    Messages:
    205
    Likes Received:
    0
    Same pall good job it's pissing down every day lol
     
  37. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    Jay, weird as mine has been fine and I have had it open quiet a bid, open the motor and send some close up pics of the brushes in contact with the commutator, or pop over and lets get to the bottom of this.....
     
  38. bearder2006

    bearder2006 Member

    Joined:
    Jun 18, 2009
    Messages:
    205
    Likes Received:
    0
    I will do I think I still have your number I might have 30 min with it Tom
     
  39. bearder2006

    bearder2006 Member

    Joined:
    Jun 18, 2009
    Messages:
    205
    Likes Received:
    0
    Just had a look pall it was that bush again sticking so I've cleaned up and put a bit of wd40 in it seems ok again
     
  40. VagPro

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    419
    Likes Received:
    32
    Jay, have you pried open the carrier to sop t happening again ?
     
  41. bearder2006

    bearder2006 Member

    Joined:
    Jun 18, 2009
    Messages:
    205
    Likes Received:
    0
    Yes pall I thought I did that last time lol
     
  42. wraggm

    wraggm New Member

    Joined:
    Aug 11, 2012
    Messages:
    1
    Likes Received:
    0
    I have been struggling with a roof problem with my Audi A4 2007 for several months. Found an excellent mechanic in North London with 10 years Audi experience. Replaced my roof motor, relays and reset roof hydraulics and roof working fine now for GBP 550. Worth talking to if you live in the North London area. Contact Us
     

Share This Page