1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi A3 Turbo problems

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Faton Salihu, Sep 6, 2011.

  1. Faton Salihu
    Offline

    Faton Salihu New Member

    Joined:
    Sep 6, 2011
    Messages:
    5
    Likes Received:
    0
    [Sep 6, 2011]
    Hello Guys,

    Sorry English is not my first language so if spelling mistakes please ignoreJ

    I Have an Audi A3 56, works fine driving through town centre, but when on motorway driving 70 or above – all of sudden loses power and wont go past 60mph. I have taken to a mechanic was plugged it on computer twice and no issues there. Doesn’t show an issue regarding turbo problems or any other related issues, someone today mentioned it that the mechanic might of not had the latest software to diagnose faults could that be the case or can anyone suggest what I might need to do next.

    Regards,
    #1
  2. n25gabe
    Offline

    n25gabe Member

    Joined:
    Apr 25, 2011
    Messages:
    35
    Likes Received:
    1
    [Sep 6, 2011]
    sounds like either sticky vanes, or leak in boost hoses, firstly what engine? petrol or diesel? plus maybe engine code too may help people here diagnose
    #2
  3. Faton Salihu
    Offline

    Faton Salihu New Member

    Joined:
    Sep 6, 2011
    Messages:
    5
    Likes Received:
    0
    [Sep 8, 2011]
    Sorry for the late replay. my car is Audi A3 1.9 TDI on 56 Plate, i have no idea were i can find my engine code. i have taken my car to another mechanic and pluged into a computer he seems to think it could be this i have no idea what its called so i am going to attach some pictures.

    [​IMG]

    [​IMG]
    #3
  4. Faton Salihu
    Offline

    Faton Salihu New Member

    Joined:
    Sep 6, 2011
    Messages:
    5
    Likes Received:
    0
  5. Sheikh
    Offline

    Sheikh Member

    Joined:
    Aug 9, 2011
    Messages:
    662
    Likes Received:
    20
    [Sep 11, 2011]
    Its an N75 valve, i was just told the same thing!
    #5
  6. Faton Salihu
    Offline

    Faton Salihu New Member

    Joined:
    Sep 6, 2011
    Messages:
    5
    Likes Received:
    0
    [Sep 11, 2011]
    Thank you for the replay, have you fixed yours Zo?
    #6
  7. Sheikh
    Offline

    Sheikh Member

    Joined:
    Aug 9, 2011
    Messages:
    662
    Likes Received:
    20
    [Sep 11, 2011]
    Not yet mate, im gonna go to audi tomorrow and find out how much the part is. I'm thinking of doing the o-ring seals at the same time aswell as the innotec turbo cleaner. Hopefully that should sort out the overboost... if not i guess im looking at a new/reconditioned turbo.
    #7

Share This Page