1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi a3 oil makeover!

ticketyboo90 Oct 28, 2013

  1. ticketyboo90

    ticketyboo90 Member

    30
    0
    6
    Hi All, I own a 52 plate 1.6 8v audi a3 with 76k on the clock. I know it's not the best of engines lol. Anyway, every so often the low oil level shows and beeps on the dash followed by a eml. When I get out, let the car sit for 15min, check dipstick and it's fine! I get back in and the oil light goes off! After a few journeys the eml goes out and yet a few more times driving about the exact same thing happens! I know i have the wrong oil in (semi synthetic). Which I will be changing the filter and oil change for castrol edge 5w30 fully synthetic. I am also wondering wether it's worth changing the oil pump, and both oil sensors. I have some sealent which I will be using to put the sump back on as I am planning to give that a good long clean. I'm pretty confident I can take and clean out the sump but not to sure about the oil pump. (I just don't want to do a full oil change and cleaning the sump out for it all to come back off to get at the oil pump. The previous owner never had it serviced for years and so far It's already had a new oil mount that the filter screws to as that was damaged. I've also changed thermostat housing, stater motor, a mechanic done the cam-belt and water pump changed. I also did the breather pipe as that was split from where it attaches the rocker cover. I've changed air and pollen filter. I don't thinks it's ever been serviced! So yeah anyway it needs an oil makeover! I may just leave pump in but clear sump. Is there anything anyone can think of why my eml is coming on? I think it's the oil level sensor but I just don't know! I would of scrapped this car if I hadn't spend so much money repairing it, underneath it's pretty much a new car!
     
  2. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    17,775
    674
    113
    The oil level sensor cant turn on the engine management light.

    You need to scan for fault codes and see why the lights coming on. The ecu will tell you exactly why the lights on, we cant guess from here. Stick your location on your profile and you might find someone on the forum nearby that has a VCDS cable, or get yourself on ebay and get a cheap cable to find out whats going on.

    Semi-synth is fine, its only a 1.6 after all. Just make sure its changed regularly.

    Why do you think you need to touch the oil pump?
     
  3. ticketyboo90

    ticketyboo90 Member

    30
    0
    6
    Hey, i was just wondering if it was worth doing while I had the sump off! I do think it'll be fine though was just pondering! Do you know any of those on ebay that you would recommend? Many thanks!
     

Share This Page