1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

audi a3 1.8t quattro sport 2002 oil warning light problem

spencewatts Mar 26, 2013

  1. spencewatts

    spencewatts New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    hi guys. last week i replaed my oil pik ip pipe in my sump on my audi a3 1.8t quattro sport.i had the red oil light going round a bend and the 3 beeps.i have done 108.000 miles with full servie history.the light happened again today,its not all the time. am i looking at replaing the oil pump? any help would be grateful.like i said only seems to show or beep going fast around a bend,thanks.2002 model
     
  2. gen.heinz guderian

    gen.heinz guderian Well-Known Member VCDS Map User

    Messages:
    1,346
    Likes Received:
    125
    Trophy Points:
    63
    Might be best to replace the pump. If it pulled some sludge into it it may be on its last legs.
     
  3. Lewis583

    Lewis583 Active Member VCDS Map User

    Messages:
    956
    Likes Received:
    91
    Trophy Points:
    28
    Checked the oil level?
     
  4. spencewatts

    spencewatts New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    oil level is fine and no sludge was in there.only had a servie 3 weeks before.think i may have to do the pump.would nt be the oil pressure swith would it?
     
  5. spencewatts

    spencewatts New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    oil was fairly lean as only had a servie 3 weeks ago
     
  6. s3dave

    s3dave TFSI Hybrid Supporter

    Messages:
    10,110
    Likes Received:
    736
    Trophy Points:
    38
    Try the switch, but i would refrain from driving it until you are positive the problem is resolved..
     
  7. phil miller

    phil miller Well-Known Member VCDS Map User

    Messages:
    1,211
    Likes Received:
    166
    Trophy Points:
    63
    Please deont take this the wrong way but did you replace the rubber seal on the new pick up pipe? if you didnt fit one then that will be your problem dude
     
  8. spencewatts

    spencewatts New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    hi guys.yes i replaced the rubber seal between the pipe and pump.could it be the pressure switch or is it looking like the pump.is this a fault on all the 1.8t ? i have the 180 tt one.if i Di have the change the pump is this a pig of a job ? any help is greatly appreciated.thanks guys
     
  9. spencewatts

    spencewatts New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    hi guys.changed the oil pump today,but alas i went round a corner again and the oil light and the 3 beeps returned.is it possibly the pressure switch?
     
  10. Broken Byzan

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User quattro Audi A4

    Messages:
    13,221
    Likes Received:
    463
    Trophy Points:
    83
    I cannot believe you have done all of this work without actually checking the oil pressure with a gauge. TBH the only thing left is the switch and it's cheap as chips. I'm guessing you have a break in the wire or similar and the engine movement is causing the the light to come on
     
    spencewatts likes this.
  11. spencewatts

    spencewatts New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    i guess with the mileage as it is and other guys on here having pumps go bang at that mileage i just paniced.the switch is near the oil filter is nt it? is it a pig to get out? thanks
     

Share This Page