1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

audi a3 1.8t fault codes?

quattrosport14 Sep 23, 2010

  1. quattrosport14

    quattrosport14 New Member

    5
    0
    1
    hello guys, im pretty new to the whole vag scene and after a few months of owner ship started having a few warning lights flash up on the dash?
    the engine check light has come on and when i scan for faults it comes up with p0102 (maf reading too low) and also p0172 (too rich) although the car drives fine? really smooth, just worried this could be causing further damage? ive replaced the maf and fiddled the connection and erased the codes but they still come back:(

    also the esp light has come on after i uncliped a little box on the inside of the passengers side wing to fit my cai pipe? could this be a problem or something further on?:unsure: although this doesnt really affect the driving as i prefer it with no esp, i dont like way it cuts in and shudders the car to try and back it go straight? so for all the waffling but any help would be appreciated?:blush:
     
  2. voorhees

    voorhees Moderator Staff Member Moderator DSG

    16,081
    1,911
    113
    ESP is a safety feature which I personally wouldn't drive with it off,I know someone who did and ended up in a farmers field with a written off S3.
     
  3. quattrosport14

    quattrosport14 New Member

    5
    0
    1
    Yeah but I still prefer it off which is my driving style, I'd just like to get it how it should be with everything working... If anyone could help me and point me in the right direction it would be a great help?
     
  4. DJ_Troopa

    DJ_Troopa K1 Driver

    1,743
    14
    38
    P0172 also relates to the MAF. Looks like your MAF is dead matey.
     
  5. voorhees

    voorhees Moderator Staff Member Moderator DSG

    16,081
    1,911
    113
    he replaced the MAF and the codes still came up.
     
  6. quattrosport14

    quattrosport14 New Member

    5
    0
    1
    admittedly ive replaced MAF with a intermotor part? could these be pants and be worth trying a bosch item?:S

    looking back this problem has started coming up alot more since my cai was fitted? could the vibrations of the inner wings when the cai is bolted to be shaking the **** outta my MAF? or am i being dumb?

    its so strange how the car runs fine? picks up great, smooth as id expect tbh?
     

Share This Page