1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

audi 100 2.6 v6 oil light

Discussion in 'Classic Audi Forum' started by roob, Jul 5, 2007.

  1. roob
    Offline

    roob i know nothin about my car !!!

    Joined:
    Nov 21, 2006
    Messages:
    15
    Likes Received:
    0
    [Jul 5, 2007]
    oil light does not come on when ignition then oil pressure gauge goes up and down but then stays on normal then up and down and finally red warning light goes on and off but oil and drive are fine.



    HEELLP ME PLEEEEEASE:motz:
    #1
  2. Ads

    Ads

    [Dec 18, 2014]

  3. enda1
    Offline

    enda1 Member

    Joined:
    Jan 17, 2006
    Messages:
    436
    Likes Received:
    0
    [Jul 5, 2007]
    You need to check if the oil filter housing has 1 or 2 sensors mounted onto it. If its 2 sensors then 1 is the low pressure switch and 1 is the high pressure switch. If the oil light is not coming on when you turn the ignition on (without starting the car) then the low pressure oil switch is knackered. check it out and let me know how you get on
    #2
  4. roob
    Offline

    roob i know nothin about my car !!!

    Joined:
    Nov 21, 2006
    Messages:
    15
    Likes Received:
    0
    [Jul 5, 2007]
    as far as i can see it only has one do you mean by the oil filter and oil cooling box :think:
    #3
  5. Rev-head
    Offline

    Rev-head Active Member

    Joined:
    Oct 14, 2004
    Messages:
    2,987
    Likes Received:
    7
    [Jul 5, 2007]
    Oil filter
    #4

Share This Page