1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Assistance required!!!

leeds_182 Jan 7, 2011

  1. leeds_182

    leeds_182 Member

    121
    0
    16
    I've got a 54 plate a4 avant 1.9 tdi auto multitronic with 90k on the clock. Recently had a big service at ivc in Leeds including all belts and fluids etc etc.

    Anyway, driving home today and the car suddenly would not rev. Looked at the dash and the esp light was on and the coil light was flashing. Came to a stop at the side of the road and switched the car off and on again and this cleared the lights but as soon as I placed my foot on the gas the lights came back on again and the car would not rev - just ticked over at 900 revs as usual.

    The aa came out and the car was showing no faults so had to be towed to a local garage.

    Anyone any ideas???
     
  2. leeds_182

    leeds_182 Member

    121
    0
    16
    Any ideas anyone??
     
  3. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,039
    565
    113
    When you revved it did the revs not more "at all"?
     
  4. Mike B

    Mike B Well-Known Member

    1,091
    40
    48
    Something similar happened with my son in laws 1.9TDI touran recently .Took a long time but the eventually had to change the turbo.Hope yours is less serious
     
  5. leeds_182

    leeds_182 Member

    121
    0
    16
    Does not rev at all! It's a bit of a mystery.

    Hope it's not the turbo!
     
  6. quattro tony

    quattro tony Member

    167
    0
    16
    Ive come across this once before and it was a fault with the drive by wire throttle system. New throttle pedal fixed it, It should log a fault code up though, Might have to get a different diagnostic machine on it or check it while the light is on.The reason why i say this is cause i don't trust what the aa say anyways, I did a car last week which cut out non start and the aa said the clutch and starter had jammed up cause the engine wouldn't turn over,only to find the timing belt had snapped and the engine locked up !, he even tried bump starting it! Get yours into a workshop and hopefully can see whats going on, The one i had did a similar thing to yours, coil light on only idle, no response from throttle.
     
  7. leeds_182

    leeds_182 Member

    121
    0
    16
    Cheers pal. It's in the garage as we speak.
     

Share This Page