1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anyone with KW coils v3 I have a question

drnutta Jan 20, 2010

  1. drnutta

    drnutta Member

    371
    5
    18
    Hi Guys,
    Got my coils installed on sat... but having some weird noises coming from them...
    Almost like a squelching noise / squeak... hard to describe really... happens even on minor bumps and at times round abouts...

    Any idea's?
     
  2. Boydie

    Boydie Boycie VCDS Map User

    3,198
    312
    83
    Are they brand new?

    Who fitted them?

    Where exactly is the noise coming from? front or rear? which side?

    As far as I know, the V3's are dampening adjustable, so you would have a valve at the top or bottom of the shock to increase or decrease the stiffness of the shock? this could be leaking.

    You could just have a loose bolt at either end of the car - go over them again and see if they require tightening.
     
  3. mrgicm

    mrgicm Phantom black S3/

    137
    0
    16
    I have V3 for almost a year now. This happens to you when its cold out side, a little squeakky noises from the front. You can improve that by just slightly adjusting the damper settings, bescause the rings inside the coilovers that regulate the damping sometimes can be in that position so that they just make that noise. Dont worry everything is OK with your coilovers, it will go away as soon as the temp. outside rises just a little bit. :)
     
  4. S.

    S. Well-Known Member Team Ibis TFSI Owners Group quattro Audi S3 Manual

    1,901
    477
    83
    it's related with cold weather and oil viscosity in them. the lower the temerature is the higer viscosity gets (bigger resistance of oil). it should probably be gone with higher temperatures :think:
     
  5. S3Alex

    S3Alex Rarely neutral Team Ibis Audi S3

    10,274
    4,329
    113

    Interesting and good to hear it's benign.

    Mine do this as well,and I've been trying to find out why!
     
  6. drnutta

    drnutta Member

    371
    5
    18
    Hi Guys,

    Yes brand new and installed by AMD... was reading my manual aswell and apparently suppose to have 2 small allen keys?
    that the heck are those for... and I don't seem to have them in my bag of bits that i was presented with...

    I got a small paperclip looking thing and 2 spanner type things guess I'm missing stuff.

    On another note what setting do you guys recommend for daily driving.?:)
     
  7. N8

    N8 Kowalski Details VCDS Map User

    17,163
    718
    113
    My cousin's V3s do this on his Clio 197!!
     

Share This Page