1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anyone seen this before?

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by wallacr, May 1, 2010.

  1. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Hi All,

    I was just chatting to some guy in the car park of my local Tesco as he commented on liking my car and what I'd done to it, he also had a B6 but it seems it's all going wrong, see below:

    [​IMG]
    I always thought the B6 only had a right fog light, well mine only seems to and apparently it only happens every now and again.

    [​IMG]
    This only happens when he has his lights set to auto and then the lights are always on day or night.

    I think his Central Electronic unit is buggered as he said it all started happening around the same time the auto lights stopped working. Would anyone else think the same?

    Oh yeah, I used vag-com too and it said to many errors to continue on the Central Electronics module, that's why I thought it might be that which is buggered.

    I did suggest he come on here, but he said he struggles using Word, so I said I'd help.

    Rich
    #1
  2. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,226
    Likes Received:
    1,220
    Posting of errors may aid us in helping as thats a bulb warning & the light/rain sensor warning faults.
    #2
  3. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Thanks NHN, I said I'd call him later to tell him what I heard so I'll see if I can plugin again and take a few screenshots of the errors VCDS gave when it said too many errors.
    #3
  4. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Small update, plugged in VCDS again and the fog light warning message wasn't there today, but he said that's not always there anyway.

    VCDS never seemed to finish it's scan when I selected the module, it kept having that loading icon in the top left where is says what protocol it connected on, but it listed the fault code this time as:

    02104 - Light Detection Sensor (G399)
    30-00 - Open or Short to Plus

    As I have retrofitted Auto Lights in mine, we swapped the mirrors over and it seemed to work fine in mine, but his coming home light switch doesn't light up the one position like it does in mine, but his auto lights up yellow like mine.

    I'd be surprised if the wiring had gone faulty and I'd suspect it if it wasn't for that random left fog light error message, so I still think it's the Central Electronics module 8E0 907 279 F.

    Does anyone know if a B7 module will work in a B6? If so, any idea which ones work, as I've seen a few of those for sale quite reasonably that he could get.

    Rich
    #4
  5. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,226
    Likes Received:
    1,220
    As the sensor piggy backs in the module 09 anyway then it doesnt mean the central module is goosed, not impossible but doubtful atm, from the log it indicates wiring tbh mate.

    1st I would check all wiring at the mirror & the central electrics board as something may have been disturbed.

    Did you try your mirror in his car out of interest aswell as his in yours?

    Ideally you need to check etka to see if his board has been superseded & if so you can use the same one as he has now or any superseded version, although others may work but that would need to be a highend board, so the same.

    Is your board the same revision as his, if so try swapping them over & recoding, taking note of adaption channels & coding of both cars beforehand.
    #5
  6. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Thanks again for the reply NHN, I do have the same module in mine, but didn't really fancy taking it out to try it, but its an option I guess. I'd be with you on the wiring if it wasn't for the left fog light warning considering the left fog light was never set to work in the UK, only the right. Never really understood that though if I'm honest.

    I didn't try my mirror in his, didn't think of that as his worked in mine. Can try it though. Not tomorrow as I'm away for the day, but perhaps Tuesday evening.

    How's best to test the wiring? Just use a ami meter? Or is it worth buying a harness from Kufatec like I did with mine and just rewire? I guess I should look for a new version of ETKA, the last version I had only worked on XP and I now run W7. Any suggested sources would be appreciated.

    It's not even my car and yet for some reason it bothers me, I hope this guy appreciates this, lol.

    Rich
    #6
  7. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Finally got around to trying my unit in his car and it seems to work fine, well the auto lights work again, so now the hunt is on for a replacement unit. He hasn't seen the rear left fog light warning for most of the week, so not sure if that was due to the faulty unit too, soon see I guess.

    Rich
    #7
  8. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,226
    Likes Received:
    1,220
    Just to clarify, you saying he had your module in his car for a week without any issues or just momentarily?

    Did you not try his central electrics in your car to see if the fault follows as that would be undeniable proof its the board huh.

    Given he hasnt had that fog light fault, has he actually tested fog lights as it may not fault until they are turned on, have you checked any adaptation channels or coding to see if something had been enabled unintentionally, all things to check before condemning a board as such.
    #8
  9. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Sorry, I didn't really explain properly. He hadn't seen the rear left fog light error for the best part of the week, but the auto lights didn't work, but they did work with my module in his car.

    I didn't think of trying his board in mine, don't really fancy stripping it all down again now, I should have thought about that before.

    Will def check the adaption channels though, will take a look on the Ross Tech site later for reference and I could alway refer to mine too.

    Thanks NHN, appreciate the advice.

    Rich
    #9
  10. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,226
    Likes Received:
    1,220
    You would be best to stick his board in your car to test it ideally mate, that would be the best way to test if auto lights etc dont work, it really would, I strongly suggest that as those boards arent cheap.

    Forget the wiki as tbh its out of date for some & things are missing, just go into the module & go through it mate as thats the most uptodate in VCDS anyway.
    #10
  11. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    I thought you might say that, guess I know what I'm doing this weekend, lol.

    Will keep you posted.
    #11
  12. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,226
    Likes Received:
    1,220
    After the mirror swap, would of thought you'd pre-empt on the module mate :moa:

    TBH I have learnt this hard way aswell many times mate so know exactly what you're going through lol.
    Last edited: May 7, 2010
    #12
  13. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    You're right, I should have pre-empted it, having a dull moment I guess. No comments on that please, lol :laugh:
    #13
  14. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Ok, small update, tried to check the coding and adaption channels on his unit and no matter what I changed and where it never saved. I put it in my car and tried it too, same result. Is there a way to reset to factory settings to give that a try before getting a new module?

    Rich
    #14
  15. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,226
    Likes Received:
    1,220
    On some modules you can default some settings with adaption channel 00 or 01, have a looksy.

    I've also asked Lea if he can check his B6 for you just incase he sees anything I dont know of as I no longer have my S4.
    #15
  16. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Thanks Nigel, I can't remember about 00 (reset doesn't ring a bell though), 01 relates to the coming home lights time. I'll take a look at mine again tomorrow and see what Lea says too, then if there is a way will go and try it and see if it works.

    Apparently he hasn't had the rear left fog light warning at all since I last plugged in VCDS, so that's some progress I guess :)
    #16
  17. 1wheelonly
    Offline

    1wheelonly cabriolet

    Joined:
    Oct 14, 2007
    Messages:
    2,060
    Likes Received:
    4
    got to plug in tomorrow morning wallacr, will take a look for ya, no worries.
    i assume youve checked coding for rear fogs ! your right on that, deffo only one on drivers side ( well, there is on a cab )
    ill let you know mate
    #17
  18. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Thanks Lea, I appreciate it. There's only a right fog on mine.

    Rich

    PS. I started fitting my rear view camera today when I got back, but it got dark. So the camera is in, wires run, I just need to connect them up tomorrow.
    #18
  19. 1wheelonly
    Offline

    1wheelonly cabriolet

    Joined:
    Oct 14, 2007
    Messages:
    2,060
    Likes Received:
    4
    nice one, you wont be disapointed with the rev-cam, great little mod.
    #19
  20. wallacr
    Offline

    wallacr Member

    Joined:
    Nov 9, 2003
    Messages:
    241
    Likes Received:
    0
    Am looking forward to getting it up and running :)
    #20

Share This Page