1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

antiroll bar link problem

Discussion in 'A4/S4 forum(B5 Chassis)' started by bobo139, Oct 12, 2011.

  1. bobo139

    bobo139 New Member

    Joined:
    Jan 26, 2011
    Messages:
    16
    Likes Received:
    0
    Hey guys n gals,hoping use can shed light on ma problem,fitted a full front suspension kit which was all 8 wishbone arms, trackrod ends and antiroll bar links with new bolts and nuts about a month ago,now the problem is the pass side antiroll bar link has lost the bush,bolt,and nut from were it mounts to the bar.I'm guessing that the bolt or nut was weak.any other ideas how this happened. Also love this site, so much info.cheers.
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. B5NUT

    B5NUT Well-Known Member
    VCDS Map User

    Joined:
    Feb 6, 2010
    Messages:
    2,748
    Likes Received:
    364
    What make was the suspension kit, Not one of the £100 eBay kits?
     
  4. bobo139

    bobo139 New Member

    Joined:
    Jan 26, 2011
    Messages:
    16
    Likes Received:
    0
    Yeah it was.,I take it that was a bad buy.
     
  5. adamss24

    adamss24 Well-Known Member

    Joined:
    Jul 3, 2007
    Messages:
    3,759
    Likes Received:
    233
    Yep, you get what you pay for !
     
  6. B5NUT

    B5NUT Well-Known Member
    VCDS Map User

    Joined:
    Feb 6, 2010
    Messages:
    2,748
    Likes Received:
    364
    Yep, them kits are only good for getting the car through an MOT then selling on! I bet the rest of the arms will start to fail over the next few months.
     

Share This Page