1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Another water pump goes pop 2010 S4

Discussion in 'Audi S4/A4/A4 Cab (B8 Chassis)' started by Necroscope, Jan 21, 2011.

  1. Necroscope
    Offline

    Necroscope Member

    Joined:
    Dec 19, 2009
    Messages:
    254
    Likes Received:
    3
    So i start the car this monring, and begin scrapping the screen. Whilst doing this i hear a noise like plastic expanding under heat, i think to myself "thats new" but put it down to it being very cold this morning.

    Anyway after a few mins of running my heater normally blows nice and warm, but not this time. So after a mile or so i think, let stop and restart the engine just in case the climate is having a bad day.

    Just as i pull over the DIS displays "check fluid level" at which point the engine is tuned straight off.

    I pop the bonnnet and see about 1" of coolant in the tank and a load of steam.

    Audi pick me up and i get a nice A4 Avant to drive for the day.

    They havent confirm the problem yet, but i guess its a nice plastic pump gone pop. My car is a March 2010 with just under 6000 miles on the clock.

    The temp gauge was showing normal, my question is could this have fryed any other part of the engine before or after the thermostat?

    Cheers,

    Phil.
    #1
  2. bez101
    Offline

    bez101 Yorkshire & Humber Rep.

    Joined:
    Jul 8, 2008
    Messages:
    8,734
    Likes Received:
    494
    no not if you caught it in time
    sounds like you did
    #2
  3. Necroscope
    Offline

    Necroscope Member

    Joined:
    Dec 19, 2009
    Messages:
    254
    Likes Received:
    3
    Well my car went in on Friday morning, and came back out on the Friday evening.

    All seems well i am glad to say.

    Audi Haelsowen did a great job, and confirmed its only a 3 hour procedure. I just wished they did this work on a recall rather than let me breakdown...

    Looks like i didnt cook anything else on the engine, which is good, but i will keep an eye out.

    Anyway all 2010 S4 drivers, if your heater isnt working stop ASAP ;)
    #3

Share This Page