1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Alpine Ipod adapter doesnt charge my Ipod Touch... Is there a way round it?

Discussion in 'In-Car Entertainment' started by S3 Paul, Apr 13, 2012.

  1. S3 Paul

    S3 Paul Well-Known Member
    Regional Rep

    Joined:
    Oct 27, 2006
    Messages:
    2,803
    Likes Received:
    87
    As above realy, I have an Alpine DVD head unit with the Ipod interface box fitted,
    I used to use my old Nano in the car but now use an Ipod touch , The interface will work with the Touch but doesnt charge it like the Nano
    Is there a way around this??
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. s8craig

    s8craig Active Member
    VCDS Map User

    Joined:
    Jul 26, 2005
    Messages:
    1,562
    Likes Received:
    30
    How old is it? the Alpine I mean?

    I have fitted a few recently and they don't charge if connected to the Ipod/Iphone on startup, but if you start the car first and then attach the Iphone/Ipod it starts charging after a short while. The latest Ipod/Iphones have a huge current draw on connection and can kill an interface.

    The older Alpines certainly had issues with charging.
     
  4. S3 Paul

    S3 Paul Well-Known Member
    Regional Rep

    Joined:
    Oct 27, 2006
    Messages:
    2,803
    Likes Received:
    87
    Its an oldish Alpine,
    Somebody told me that a company called "connect2" or something did a conversion lead??
    I cant seem to find anything.
    I also have the Iphone 4s but dont use this for music but i tested it and it doesnt charge this either.
     
  5. s8craig

    s8craig Active Member
    VCDS Map User

    Joined:
    Jul 26, 2005
    Messages:
    1,562
    Likes Received:
    30

Share This Page