1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

All brake lights have randomly stopped working...

Discussion in 'A3/S3 Forum (8L Chassis)' started by Mi11ar, Sep 30, 2013.

  1. Mi11ar

    Mi11ar Member

    Joined:
    May 19, 2013
    Messages:
    316
    Likes Received:
    35
    Randomly on my drive back to camp on Sunday night, all 3 of my brake lights decided to stop working all at once, checked the fuse that's fine, and all the bulbs seem to be ok also, I've heard of people having a similar problem before something about a switch mechanism behind the brake pedal???

    Can anyone spread any light on this please?

    Cheers
     
  2. azman

    azman Member

    Joined:
    Feb 9, 2013
    Messages:
    58
    Likes Received:
    3
    same happened to mine, it was the brake switch that had packed in.
    how i love the a3 s3. easy job to change it, but i believe there are 2 variations of switch.

    Interior49.jpg
     
  3. Mi11ar

    Mi11ar Member

    Joined:
    May 19, 2013
    Messages:
    316
    Likes Received:
    35
    Ahh yes just as I expected, I'll have to track down which switch is for my Car then :p

    Btw thanks for the pic :)
     
  4. JohnM100

    JohnM100 Well-Known Member
    Gold Supporter VCDS Map User

    Joined:
    Jan 12, 2013
    Messages:
    820
    Likes Received:
    309
    The brake light switch was redesigned around 2007. The old one had a pink/violet collar and broke often - part number 1J0945511F. The redesigned part I think is black but sorry don't have the part number for that.

    If the switch has broken then your ESP light is probably on too.

    Good news is that the resigned part is much better and reliable.

    John.
     
  5. Mi11ar

    Mi11ar Member

    Joined:
    May 19, 2013
    Messages:
    316
    Likes Received:
    35
    Cheers :)

    I don't have any warning lights or anything on my dash everything is showing up as fine :s
     
  6. JJ.Foulds

    JJ.Foulds Well-Known Member

    Joined:
    Feb 23, 2013
    Messages:
    1,202
    Likes Received:
    170
    just spray with WD-40, i did this with mine when it was sticking and been working perfectly since, it might just be stuck or biut of dodgey connection. worth just giving a spray for a cheap easy fix.

    JJ
     
  7. azman

    azman Member

    Joined:
    Feb 9, 2013
    Messages:
    58
    Likes Received:
    3
    hi, my esp light wasnt on either?
    it threw up a code for brake switch and speed controller(cruise control
     
  8. JohnM100

    JohnM100 Well-Known Member
    Gold Supporter VCDS Map User

    Joined:
    Jan 12, 2013
    Messages:
    820
    Likes Received:
    309
    Revised part is dark green - 1C0945511A.

    When mine went (twice) the ESP light came on, but if yours don't then could point to something else.

    John.
     

Share This Page